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1 Getting started

1.1 Introduction

1.1.1 Introduction

PerfectTablePlan v7.1.0 for Windows

PerfectTablePlan helps you to quickly create table plans and seating charts for
weddings, parties, banquets and events. It's a lot easier and faster than using
scraps of paper or a spreadsheet.

The unlicensed version of PerfectTablePlan only allows you to save, export or
print plans with up to 30 guests. If you want more than 30 guests you will have
to buy a licence.

If you are confident of your computer skills you should start with the Quick start
guide. This will get you creating your first table plan very quickly. If you would
like more in-depth instructions please go through the Tutorial. Frequent users
who have been using PerfectTablePlan for a while should read the Expert tips.

Note We have a separate version of this document for Mac. It is also available in
HTML format.

1.1.2 Conventions in this document

Text that refers to elements of the user interface is in bold, e.g. Main window.

Menu1>Item1 means: click on Menu1 in the menu bar and select Item1.

Text that the user can type is shown in a non-proportional font.

Text that refers to keyboard keys is in italics. E.g. the keyboard accelerator for
Insert>Single Guest is Ctrl+G, which means hold down the Ctrl Key and press
the G Key.

Hyperlinks are shown in conventional hyperlink format.

Underline is used for emphasis.

'Click' means clicking the left mouse button, unless stated otherwise.

 

https://www.perfecttableplan.com/html/documentation.html
https://www.perfecttableplan.com/html/documentation.html
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1.1.3 System requirements

The minimum requirements for running this software are:

Processor Operating systems

Intel Windows 11, 64 bit

Windows 10, 64 bit, v1809/Oct-2018
update, or later

ARM Windows 11, 64 bit

If your operating system is older or newer than the above check our website to
find a compatible version of PerfectTablePlan.

If in doubt, try running an unlicensed trial version before you buy a licence.

1.1.4 The help system

Help is available in a number of different ways.

Context sensitive help

Context sensitive help provides detailed information on the use of each pane and
window. To access context sensitive help press the F1 key or click on a Help
button.This opens help in a separate window.

The Windows help viewer

You can print out sections of the help by right-clicking on a topic and selecting
Print. The Windows help application contains 4 standard help tabs:

Contents

Displays the Help table of contents as a tree. Click on topics to expand them.

Index

Displays the Help index.

https://www.perfecttableplan.com/html/requirements.html
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Search

Type a word or phrase into the field and click List Topics. A list of topics that
contain the word or phrase will be displayed. Double-click one of these to display
the desired topic in the right pane.

Favorites

Use this pane to bookmark useful pages.

PDF help

A PDF version of the help is also installed with the application. You may find this
more suitable for printing. Note however that is over 300 pages in length!

'How do I?' help

Click on the How do I? button on the main tool bar to see a list of common
tasks you might want to perform. Select an item in the list to go to the relevant
help page. The list of topics shown varies depending on what you are trying to
do (e.g. which panes are visible).

Tool tips

Some controls display tool tip windows when you hover your mouse cursor over
them. You can turn this feature on/off using the show tool tips checkbox in the

Preferences window.

Web pages

Additional documentation may be available on our web pages. To open the web
pages in a browser select Help>FAQ Page or Help>Web Pages.

1.2 Quick start guide

1.2.1 Quick start guide

This page provides instructions to get you started using PerfectTablePlan
quickly. If you want step-by-step instructions please go to the Tutorial.
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Note that you can easily switch between this Help window and the
PerfectTablePlan Main window using Alt+Tab keys on the keyboard (hold down
the Alt key and press Tab until you get the window you want).

There are 5 simple steps to creating a table plan:

1. Add guests.

2. Decide who to sit together.

3. Add tables.

4. Assign guests to seats.

5. Output results.

These 5 steps correspond to the 5 Task tool bar buttons.

When one of these buttons is pressed you will only be able to see the panes and
tool bar buttons appropriate to that task.

 Add guests

Start PerfectTablePlan, if you haven't already done so.

Click on the  button in the Task tool bar, if it isn't already selected.

Guests can be added as individuals, couples, families or groups using
Insert>Single Guest, Insert>Guest Couple, Insert>Guest Family,
Insert>Guest Group or the equivalent Insert tool bar buttons. You can add
everyone as individuals, but it saves time to add them as couples, families and
groups, where appropriate.

Each guest has the following properties:

Property Meaning
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Anon Check this if you don't know the
guest's name yet.

Title The guest's title.

First name(s) The guest's first (given) name(s).  You
can also record middle names or
initials, if you wish.

Last name(s) The guest's last (family) name(s).

Suffix Any title or role that comes after the
name.

Display name The name you wish to display for the
guest (which may include
qualifications, job title and other
information).

Gender Whether the guest is male or female.

Age Whether the guest is an adult or a
child.

Meal The guest's choice of meal (separated
by commas if there are choices in
multiple courses).

Special req Any special requirements the guest
has, e.g. diabetic or in a wheelchair
(separated by commas if there is more
than one special requirement).

Notes Used to record useful information not
recorded elsewhere.

Image An image or icon representing the
guest, up to 128 x 128 pixels.
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VIP Used to mark a Very Important Person.
For a wedding this may be a member
of the wedding party, for a conference
it may be a keynote speaker and for a
business lunch it may be a table
sponsor.

RSVP Whether the guest has been sent an
invitation, accepted, declined,
cancelled or arrived.

Work phone, Home phone, Mobile Phone numbers for the guest.

Email The email for the guest.

Most of this information is optional, but a guest must have at least a first name

or a last name. Guests are shown in bold in the  Guests and Groups pane
if they have not been assigned a seat. You can also add custom properties in the
Advanced and Professional editions of PerfectTablePlan.

Every guest is a member of a group (single guests belong to their own group).
Each group has optional contact details and notes. Each group only has one
contact address, so generally you should assign people to a group if they all
have the same contact address (e.g. a couple or family). You can easily drag

guests from one group to another in the Groups pane.

If you already have guest data (for example in a spreadsheet, text file, contacts
or address book) you can import it using File>Import.... See Importing data
for more information.

You can also quickly create a guest list using Insert>Quick Add Guests or the
equivalent Insert tool bar button. This allows you to enter one
guest/couple/family/group per line in free text format.

Once you have entered a guest's details you can change their properties later by
selecting them and then choosing Edit>Properties or the equivalent Main tool
bar button.

Click on the appropriate column headers in the Guests pane to sort the guests

by first name, last name etc. You can also see how guests are grouped in the 
Groups pane.
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You can enter general information about your event using File>Event
Information... and check the number of attendees and cost using
File>Numbers and Budget....

You should now make sure you save your plan using File>Save or the
equivalent Main tool bar button. You will be asked to provide a name for the
new plan file.

 Decide who to sit together

Click on the  button in the Task tool bar.

You may want to have some guests sitting close to each other (for example:
couples, friends and people who you think might be compatible) and some
sitting far apart (for example: divorced couples!). The automatic assignment
function will take this into account when it decides where to place guests.

Proximity Icon Meaning

Next to Should be placed next to
each other.

Near to Should be placed next to
or on the same table.

Near not next to Should be placed on the
same table, but not next
to each other.

Neutral  No preference.

Not Next to Should not be placed
next to and preferably
not on same table.

Not Near to Should not be placed on
the same table.



19

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Getting started

If you add guests using Insert>Guest Couple, Insert>Guest Family or
Insert>Guest Group, a sensible default value will be set for their proximity.
However you can change the proximity so that members of a group are not sat
together.

You can view and edit the proximity of guests in the Proximity pane. Just
click on the appropriate drop-down menu in the table to change the proximity.
Note that the table is symmetric - if you change the proximity for column A and
row B the proximity for row A and column B will change to match.

 Add tables

Click on the  button in the Task tool bar.

Tables can be added using the Insert menu, e.g. Insert>Circular Table, or
the equivalent Insert tool bar button. The types of table are:

Table Icon Meaning

E-shaped A head (top) table + 2 or
more sprigs (legs)
(Advanced and
Professional editions
only).

Rectangular A rectangular or square
table with seats on four
sides.

Banquet A long table with seats
on two sides.

Head A long table with seats
on only one side, for
example a head (top)
table at a wedding or
banquet.

Custom A rectangular or square
table with potentially
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different numbers of
seats on each of the 4
sides. It can have
rounded ends.

Circular A circular table with
seats all around it.

Semi-circular A semi-circular table
with seats around the
straight side and/or
curved sides.

Oval An elliptical table with
seats all around it.

Serpentine A 180 degree curved
table (Advanced and
Professional editions
only).

Half serpentine A 90 degree curved table
(Advanced and
Professional editions
only).

Row of seats A row of seats (no
table). Can be curved.

Each table has the following properties:

Property Meaning

Name The name displayed for the table. The
default name is "Table 1" , "Table 2"
etc, but you can set any name.

Shape See above.
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Angle The rotation angle of the table in the 

Floor Plan and Table Plan panes
(in degrees).

Colour The colour of the table in the Floor

Plan and Table Plan panes. This
overrides any colour set for the pane.

Seats The number of seats for the table.

Size The size of the table (in metres or
feet). Check the auto check box to size
the table automatically (according to
the seat size and the number of seats).

VIP Check the box to designate a VIP table.
The automatic seat assignment
attempts to assign VIP guests to VIP
tables.

Notes Used to record useful information not
recorded elsewhere.

The Create field allows you to add more than one table at a time.

Once you have created a table you can change any of its properties (including
the name and shape) by selecting it and then choosing Edit>Properties or the
equivalent Main tool bar button.

You should make sure that you have enough seats for all your guests. You can
see how many seats and guests you have at any time by looking in the Status
bar at the bottom of the Main window.

New tables will be placed in an empty space near the centre of the Floor Plan

pane. You can move tables in the Floor Plan by dragging them (left-click on
the centre of a table, hold down the left mouse button and drag to the

appropriate position). You can zoom in and out of the Floor Plan using the 
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and  buttons (or a 'pinch' gesture, if your device supports gestures), or zoom

so all tables are visible using the  button. When you are zoomed in you can

move around the Floor Plan by dragging the background (the cursor will
change to a hand) or clicking on the scroll bars. You can change the size of the

floor plan using the  button or dragging the bottom right hand corner of the
room.

Use the Insert Line, Insert text , Insert image and Insert shape

buttons to add lines, text, images and shapes to the Floor Plan pane. Lines
can be used to represent walls and other linear features. Text can be used for
titles, headers and footers. Images can be used for decorations, logos or clipart.
Shapes can be used to represent dance floors, stages and other features of your
floor plan. 

Rotate a table, shape or text 45 degrees clockwise or anti-clockwise by clicking

the Rotate clockwise or Rotate anti-clockwise buttons.

Move a table, shape or text behind (under) another by clicking the Move to
Back button.

You can also view one table at a time in the Table Plan pane. Use the  

  navigation buttons to view different tables.

Save your plan using File>Save.

 Assign guests to seats

Click on the  button in the Task tool bar.

Once you have entered guest details and added tables, you can assign seats
automatically or by using drag and drop. You will often need a combination of
both for best results.
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If you have people that you definitely want to sit in certain seats (for example
the wedding party or VIP guests) you should assign their seats manually. Drag

these guests or groups from the Guests or Groups pane to the appropriate

table or seats in either the Floor Plan, Table Plan or Schematic panes.
To drag a guest or group: left-click, hold down the mouse button and drag to the
appropriate seat (select more than one guest/group by using Shift+click or
Ctrl+click). Drag a whole group by holding down the Shift key when you start to

drag a member of that group. Make sure the Guests or Groups pane is set
to drag and drop mode.

You can 'lock' guests to stop the automatic seat assignment moving them later.

Lock them in place by selecting the guests, for example in the Guests or 
Floor Plan pane, and choosing Edit>Guest Property>Locked>Yes (you can
also select a table and lock all the guests on it).

The rest of the guests can now be assigned to the remaining seats automatically
by selecting File>Auto Assign Seats or the equivalent Main tool bar button. If
you have a large table plan you may need to increase the amount of time

allowed for the automatic assignment in the Preferences window.

The automatic assignment will try to find the best seating assignment using a
scoring approach. The scoring takes account of:

· guest proximity

· alternating genders (if selected in the Preferences window)

· seating VIPs on VIP tables

· not seating guests on their own
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· VIPs score higher than guests who aren't VIPs

You can halt the automatic assignment at any time by pressing the Stop button.
The best solution so far will be kept. If you don't like the changes you can select
Edit>Undo to undo the change. Multiple levels of undo are supported.

You can reassign guests by dragging and dropping them in the Floor Plan, 

Table Plan or Schematic panes to fine-tune the seat assignments. You can
also change proximities and re-run File>Auto Assign Seats as often as you
like.

You can also select a seat and choose Edit>Guest Suggestions to get a
ranked list of guests to place in this seat. The difference that assigning this
guest will make to the overall seating score is shown in brackets. Select a guest
if you want to place them in the seat (swapping them with any existing guest). 

You can see how good your seat assignment is by:

· Pressing the  button at the top of the Floor Plan or Table Plan panes.

Guest will be coloured from green (happy) to red (unhappy).

· Holding down the proximity buttons at the top of the Floor Plan or Table

Plan panes. For example the  button will show you potential seating issues

(such as guests with proximity  who aren't sat next to each other) and the

 button will show you critical seating issues (such as guests not sat next to

any of their  proximity guests). 

· Looking at the scores in the Schematic pane (check show scores, positive

scores are good, negative scores are bad).
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To see these proximity buttons you will need to click on the  button in the 

Floor Plan or Table Plan pane. Obviously, what makes a good table plan is
hard to fully define in mathematical terms, but the score will usually give a fair
indication.

Use the Table Chart pane to see your plan ordered by table.

Use the Guest Chart pane to see your plan ordered by guest last name.

Use the Report pane to see reports about your plan, including a Summary
report and a Troubleshooting report.

At any time you can unassign a guest from their seat by choosing

Edit>Unassign or dragging them on to the background in the Floor Plan or

Table Plan pane. 

 Output

Click on the  button in the Task tool bar.
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When you are happy with your table plan you can:

· Print off the Floor Plan , Table Plan, Table Chart, Guest Chart, 

Stationery and/or Report panes using File>Print or the equivalent Main
tool bar button. 

· Copy the contents of the Floor Plan , Table Plan, Table Chart, 

Guest Chart and/or Report panes into the clipboard using Edit>Copy.

Copy the contents of the  Table Chart,  Guest Chart or Report panes

into Microsoft Word or Excel by clicking the  or  buttons at the top of the
pane (you must have Microsoft Word or Excel installed).

· Export your plan to another application using File>Export.

· Order a digital poster print or place cards using File>Order Posters and

Cards.

· Display seating assignments as scrolling text on a VDU or plasma screen at

the venue using the VDU Chart pane.

The Stationery pane allows you to print place cards, badges, escort cards,
labels, invitations and other stationery. You can easily merge guest names and
addresses and other details into stationery items using substitution text.

Make sure you save your plan using File>Save before exiting.

If you want to get a feel for editing a table plan without creating a whole new
plan, try experimenting with the sample plans supplied with PerfectTablePlan.

This completes the quick start guide.

See also:

· Frequently Asked Questions

· Tutorial

· How do I?

· Expert tips
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1.3 Tutorial

1.3.1 Tutorial

This tutorial gives you step-by-step instructions on how to use some of the
major features of PerfectTablePlan. If you are a confident computer user and
want to get started quickly you might prefer the Quick start guide.

Next: 1. Getting started >>

1.3.2 1. Getting started

If PerfectTablePlan isn't already running, start it now.

You can do this either by double-clicking on the  PerfectTablePlan icon on your
Windows desktop or by selecting PerfectTablePlan from the Windows Start
button.

If you are reading this help on your computer screen try arranging the Help and
PerfectTablePlan windows so you can see them both. Alternatively you may find
it easier to print out this tutorial. To print the tutorial, right-click on Tutorial in
the left pane of the Help window and select Print. Select Print the selected
heading and all subtopics and click the OK button.

You can also print the PDF version of the help.

Warning The PDF help is more than 300 pages!

The Unlicensed software window may appear when you start
PerfectTablePlan.
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If you have a licence key you can enter it now, however you can complete the
tutorial without it. Click the Continue button.

If you don't enter a licence key, you will need to choose an edition of
PerfectTablePlan. You can complete this tutorial with any of the 3 editions.
Choose the edition that you think is most appropriate for you. If in doubt, click
the Compare editions button to find out more.
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The Getting Started window may now appear.
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If you don't want to see this window again, uncheck the show this message
next time check box. Click the Continue button. You should now see the Main

window. Click on the 1.Guests button in the Task tool bar, if it isn't already
selected.
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Take a minute to investigate the various menu items and tool bar buttons. If you
hover the mouse cursor over a tool bar button, a Tool tip window will appear
with some helpful text.

Select File>Event Information and add some basic details about the event.
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Click OK.

Next: 2. Add guests >>

1.3.3 2. Add guests

The first step to creating your table plan is to add information about your
guests. You can import guests from an existing guest list, but we are going to
add them directly here.

Click on the Insert single guest button in the Insert tool bar (on the left of
the Main window).
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The Insert Guest window will appear.
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Select Mr from the Title drop-down list. Note that the Gender has now been set
to Male.

Type John in the First name(s) field. Press the keyboard Tab key to move to

the next field.

Type Smith in the Last name(s) field. Press the Tab key. 

Leave the Suffix field empty. Press the Tab key. 

Note the Display name has been set to Mr John Smith.
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Click the Add button. The guest will be added to the Guests pane.
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Click on the Insert guest couple button in the left (Insert) tool bar. The 
Insert Couple window will appear. Fill in the details of the first guest of the
couple, as below. Click on the VIP check box to show that this is a particularly
important guest:
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Now complete the details of the second guest of the couple, as below:
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Click the Add button.

Click on the 2.Proximity button in the Task tool bar. Notice that a  is

displayed in the Proximity pane for the couple.
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This means that Joe Bloggs and Jill Bloggs should be placed on a table next to
each other.

Click on the 1.Guests button in the Task tool bar.

Click on the Insert guest family button in the left (Insert) tool bar. The 
Insert Family window will appear. Add the following guests:

Title First name Last name Gender Age

Mr William Jones Male Adult

Mrs Nicola Jones Female Adult

Master Jason Jones Male Child

Miss Natasha Jones Female Child

Note that you will have to scroll down the window to add all the guest details.

Click the Add button.
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Click on the 2.Proximity button in the Task tool bar. Notice that a  is

displayed in the Proximity pane for Mr and Mrs Jones. A  is displayed for all
the other family members. This means that Mr and Mrs Jones should be placed
on a table next to each other, and the rest of the family members near to each

other. Click on the 1.Guests button in the Task tool bar.

Select File>Save or the equivalent Main tool bar button to save the plan. The
Save As window will appear. Enter an appropriate name, such as tutorial,

and click Save.

Look at the Guests pane.

Notice that you can determine age and gender from the guest icon size and
colour. The guests are shown in bold as they haven't yet been assigned to seats.

Click on Display name, Title and other column headers to sort the guests.

Click on the Groups tab.
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Notice that the guests have been grouped as a couple, a family and a single
person (you can easily re-arrange the groups using drag and drop).

Select Edit mode:

Then click on the row with Mr John Smith and in the Title column. Type Dr
and press the Enter key.
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Note the Display name is also updated (unless you have previously edited it).

You can view/edit this guest by double-clicking on his  icon to display the 
Guest Properties window.

You can also set your guest's image, choice of meal, special requirements,
whether they have accepted their invitation etc. in this pane.

Note You can also add guests by importing them from other applications such as
Excel. This can save you a lot of typing. Importing is covered in Tutorial 9.

Next: 3. Set proximity >>

1.3.4 3. Set proximity

The next step to creating your table plan is to decide who should sit near (or not
near!) whom.

Click on the 2.Proximity button in the Task tool bar to show the 
Proximity pane:
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The  means that these guests should be placed next to each other. The 
means that these guests should be placed near to each other, either next to or

on the same table, but lower priority than .

Let us assume you have been asked not to seat Jason and Natasha next to

each other. Click on the cell where the column for Jason and the row for

Natasha intersect. Pull down the drop-down list and select Not Next to.
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Notice that the corresponding row for Jason and column for Natasha changes

to keep the table symmetric.

Click on the  button at the top of the pane to show additional options. Select

By group from the For drop-down list. The Proximity pane now shows just
one group at a time.

The proximity will become important when we start assigning guests to seats.

Next: 4. Add tables >>

1.3.5 4. Add tables

The next step is to add some tables for the guests to sit at. Click on the 

3.Tables button in the Task tool bar. Click on the Insert Head Table button
in the Insert tool bar.
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The Insert Head Table window will appear.
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Click the Add button. A long rectangular table with 8 seats down one side will

now appear near the centre of the Floor Plan pane.
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Click on the Insert Circular Table button in the left Insert tool bar. The 
Insert Circular Table window will appear. Change Seats to 6 and Create to 2.



48

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Getting started

Leave the auto box checked to allow PerfectTablePlan to set a table size based

on the number of seats and the Seat width set in the Dimensions window.

Next to the Create field you can see how many seats you will have after the
tables have been added, in this case 20 seats.

Click the Add button. Two circular tables, each with 6 seats, will now appear in

the Floor Plan pane. Click the  Zoom so all tables visible button at the

top of the Floor Plan pane to centre and zoom on the tables you have
added. 

Drag the tables to the approximate positions shown below. Currently both tables
are selected. Left-click and release on a table to select just that table. Left-click
on the table again and, holding down the mouse button, drag it to the desired
position and release. Repeat for the other table.
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Experiment with zooming in and out using the  and  buttons and scrolling
the scroll bars. 

Note You can also use the mouse wheel (if you have one) for zooming or

scrolling (depending on the setting in the Preferences window).

You can change the size of the floor plan using the  button or by dragging the
bottom-right corner of the room. This allows you to enter the dimensions of the
venue in which the event will take place.
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You can add lines, shapes, images and text to the floor plan by clicking on the 

, ,  and  buttons.

You can rotate a table, shape or text by clicking the  or  buttons. You can

move a table, shape or text behind another by clicking the  button.

You can change the colours and fonts in the floor plan by clicking the  button
at the top of the pane.

The Status bar now shows that you have 7 guests and 20 seats:

Click on the 1.Guests button in the Task tool bar. Add another 11 guests
using the same approach as in Tutorial section 2, so that you have a total of 18
guests. Set any groups, names, genders and proximities you like.

Click on the 3.Tables button in the Task tool bar. You should now have 18

guests and 20 seats. Right-click on the head table in the Floor Plan pane and

select Properties.

Change the number of seats to 6. Click the OK button.

There are now 18 seats and 18 guests.

Select File>Save to save the plan.

Note PerfectTablePlan creates a backup file every time you save the plan (unless

you have disabled this in the Preferences window). This is useful if you ever
need to retrieve an old version of the plan.
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Next: 5. Assign guests >>

1.3.6 5. Assign guests

The next step is to assign guests to seats. Click on the 4.Assign button in the
Task tool bar.

Ensure the Guests pane is at the front and set the Mode to Drag & drop
(not Edit).

Left-click on the  icon for Mr Joe Bloggs in the Guests pane. Drag him

(hold down the mouse button, move the mouse and then release) to a seat on

the head table in the Floor Plan pane.

Right-click on the seat you have dragged Mr Joe Bloggs to in the Floor

Plan pane and select Guest Property>Locked>Yes.
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A locked guest cannot be re-assigned until they have been unlocked. This is

particularly useful for stopping the Auto seat assign from moving guests who
you wish to remain in their assigned seat. You can also select a table and lock
all the guests on it.

Drag Mrs Jill Bloggs to the next seat to Mr Joe Bloggs and lock her, in

the same way. Note that locked guests appear underlined in the Guests and

Groups panes.

Now that you have assigned your VIPs, you are going to assign the rest of the
guests automatically.

Click on the Auto seat assign button in the Main tool bar. The Auto
Assignment window will appear:
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The Auto Assignment window should disappear after a few seconds. If you

look at the Floor Plan pane you should see that all seats now have guests
assigned. If you hover the mouse cursor over a seat the details of the guest
assigned will be displayed:

Notice that the locked guests have not been moved and that guests that are

assigned to seats are no longer displayed in bold in the Guests and Groups
pane.

You can customize the assignments by dragging guests between seats. If you
drag a guest to a seat occupied by another guest they will swap seats.

You may wish to use the Table Plan pane, which displays just one table at a

time with an optional legend. Use the     navigation buttons to change
table.
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Next: 6. Assess plan >>

1.3.7 6. Assess plan

For an alternative view of the table plan look at the Schematic pane. It shows
the same information in a different format. It doesn't show the positioning of

tables, but it does show the scoring. Click the  button and check the show
scores check box. The higher the score, generally the better the plan. In the
example below (which may be different to yours) you can see that Jason
Jones has a total score of +6 made up of:

+5 for being next to Mrs Nicola Jones with  proximity

+2 for being on same table as Mr William Jones with  proximity



55

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Getting started

-5 for being on same table to Miss Natasha Jones with  proximity

+4 for being a male next to 2 females

= +6 total

Auto Assign Seats tries to find the highest scoring layout. You can run it as
often as you like. Each time it will start with the current plan and attempt to

improve it. If you don't like the changes made by the Auto Assign Seats you
can undo them by selecting Edit>Undo.

You can also drag guests between seats in the Schematic pane.

Click on the Floor Plan pane tab to bring it to the front. Click on the 
button, some additional buttons will be shown.

Holding down any of the      buttons will draw lines between guests

who have this proximity. Holding down the  button shows all proximities. The

lines are coloured according to the proximity, e.g. red for .

Holding down the  button draws lines between guests who are not optimally

placed, for example guests with  proximity who not sat next to each other.

Holding down the  button show critical issues, for example guests with at least

one  proximity but not sat next to any of them.
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Depress the  button to colour code guests according to how well seated they
are based on the proximity of nearby guests; green for well seated and red for
poorly seated.

Depress the  button to colour code guest genders (blue for male, pink for
female, grey for undefined).

Depress the  button to colour code which groups guests belong to. 

Depress the  button to show colour-coded meal choices. Each meal is
displayed in a different colour. If you have more than one course (e.g.
“soup,fish,ice cream”) the courses will be displayed as concentric rings: outer
ring=first course, second ring=second course etc. .

Depress the  button to show guest age (children are shown smaller).

Depress the  button to show guest and table VIP status (shown with stars).

Depress the  button to show any guests with special requirements (i.e. with an
entry in their Special req. field).
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Depress the  button to show guest RSVP status.

Depress the  button to show which guests are locked (a padlock is displayed
for locked guests).

Some of the above will be easier to see if you use simple (e.g. default ) colours

in the Floor Plan pane. 

Using these buttons allows you to easily see whether moving guests to different
seats could improve your table plan. Try dragging some of the guests to
different seats. But keep an eye on the score in the Status bar to make sure
that making some things better doesn't make other things worse.

You can also see useful Summary and Troubleshooting reports of your plan

in the Report pane.

If you want to experiment with a table plan without creating one from scratch,
try loading one of the example plans installed with PerfectTablePlan (select
File>Open).

See also:

· Creating a good table plan

Next: 7. Print plan >>

1.3.8 7. Print plan

The next step is to print and/or export your table plan. Click on the 5.Output
button in the Task tool bar.

Select File>Print or the equivalent Main tool bar button to print the front tab in

the Right pane. The Print window will appear.
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Increase the Size until the plan will be printed across 4 pages (setting it to
140% should be about right). Click on the navigation control to preview different
pages.
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Click on Fit to page to fit the plan on a single page.

Click on the Setup... button to change printer settings, for example to select the
printer (if more than one is available), paper size, print resolution etc. . The
controls available on the Windows will depend on the pane you are printing. Click
on the Print button to print.

Print the Floor Plan pane to see the overall layout of the tables and guests.

Print the Table Plan pane for details of individual tables.

Print the Table Chart pane to see a chart ordered by table.

Print the Guest Chart pane to see a chart ordered by guest or group.

Print the Summary report from the Report pane for an overview of numbers
at your event.

Note You can also order digital prints online.

You can copy the contents of the Floor Plan, Table Plan, Table Chart,

Guest Chart or Report panes into the clipboard using Edit>Copy. Copy

the contents of the  Table Chart, Guest Chart or Report panes into

Microsoft Word or Excel by clicking the  or  buttons at the top of the pane.
You must have Microsoft Word or Excel installed.

You can also export these panes using File>Export, for example to email or put
on a web page. You can also use File>Export to export for use in another
application, for example to create custom reports.

As an alternative to printing, note that you can also display seating assignments
as scrolling text on a VDU or plasma screen.

Next: 8. Print stationery >>

https://www.perfecttableplan.com/html/order_plan.html


60

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Getting started

1.3.9 8. Print stationery

You can use the Stationery pane to print place cards, tickets, badges, escort
cards, invitations, thank you letters etc. . We are going to create some place
cards.

Bring the Stationery pane to the front. Click on the Stationery layout
button. 

The Stationery Layout window will appear. From the filters select Tent card
and then click on the DecaDry OCB3713 place cards. Click OK.

Make sure the Design tab is at the front.
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Set the number of Guides to 3 in the Stationery pane. These help to position

the text. Now click on the Add text button. The cursor will change to a
crosshair. Click on the bottom centre of the place card (as shown below).

Ensure Item per is set to Guest (at the top of the pane) and select
{guest_display_name} from Insert substitution text.

Make sure the text on the card is selected and click Mirror. 
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The text will be mirrored on the other side of the card.

Click on the Preview tab to preview how the place cards will be printed.
Notice that the text inside the curly brackets has been substituted by guest
display names. Change the page number to see what each page will look like.
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We now want to add additional text to help the staff to lay out the cards. Bring

the Design tab back to the front. Click on the bottom text on the card and
add the additional text as below by a combination of typing and using the
Insert substitution text drop-down. Reduce the font size so the text fits on
the card.
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Click on the Preview tab to preview the changes.

Select File>Print to print the stationery.

You can also add images, guest images, colour coded spots and personalised
maps to your stationery.

Note You can order blank place cards online.

Click on Save stationery to save this stationery design to use again (perhaps
in another plan).

Save your plan using File>Save.

To create address labels we would follow a similar approach, but would set
Item per to Group and for the substitution text we could use:

{group_name}
{group_contact}

You can also adapt the sample stationery we ship with PerfectTablePlan.

Note You can only save, print or export plans with more than 30 guests if you
have a valid licence for the software.

You have now completed the main part of the tutorial. If you want to find out
how to import guests whose details you have in a spreadsheet you might also
want to do the Import guests tutorial.

https://www.perfecttableplan.com/html/buy_place_cards.html
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Next: 9. Import guests >>

1.3.10 9. Import guests

You can import guest details from spreadsheets, databases and other formats,
so that you don't have to re-type them. We will illustrate this by importing some
guest details from Excel. The principles are similar for other applications and file
formats.

Note The user interface of Excel may differ between different versions.

Create a simple Excel spreadsheet like the one below and save it:

Create a new plan by selecting File>New. 

Select File>Import. The Import window will appear.
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Ensure Excel/CSV/text file is selected and click the OK button. An Open
window will appear. Navigate to the .xls/.xlsx/.csv file you just created and click
Open. If a .xls/.xlsx file has multiple tabs you will be asked to choose one. You

should now see the contents of the Excel file in the Import Data window.
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Tell PerfectTablePlan which columns correspond to which guest properties and to
ignore the first row, as shown below.
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Note that you can edit the data in the table before you import it. This will not
affect the original .csv file.

Click the Next> button (if you want to change anything you can then click
<Back ).

Click OK. If you are prompted to Save this import mapping to use again?
click Don't save. The guests should now be imported as below. 
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If it has imported anything incorrectly you can easily change it in Edit mode or
Edit>Undo the import.

The email address has been added to the group contact information. This is
shared by everyone in the group.

Click the Groups tab to see how guests have been placed into groups.

If you don't like how they have been grouped you can easily drag guests

between groups in Drag and drop mode in the Groups pane. E.g. You can
drag Miss Erica Black into the same group as Mr Alan Black.

If you look in the Proximity pane you will see it has set default proximities
for the guests in each group according to the settings in the Proximities tab of

the Preferences window.

If you are importing data in a format PerfectTablePlan already knows about, you

can select the format from the File type menu in the Import Data window:
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Click on the  button in the Import Data window to show additional options.
These options give you full control over how the import file is interpreted. For
example you can specify that columns in the import file are separated by Tab
characters, rather than commas:

PerfectTablePlan can import complex guest lists with multiple guests per row in
one multiple columns, including addresses, meal choice, VIP status, RSVP status
etc. . See example import formats for more details.

You can also import guest name data using the simpler (but less flexible) 
Quick Add Guests window.

You can also import guests from any application that supports vCard format.
This includes many email and address book applications. Just drag the guest

vCard(s) onto the PerfectTablePlan Guests pane.

Next: 10. Check-in guests >>
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1.3.11 10. Check-in guests

Professional edition only

You can check in guests by printing a barcode on their invitation, ticket or
badge and then scanning this barcode into PerfectTablePlan as they arrive.
This is much faster and less error prone than trying to find and update guest
records by typing into PerfectTablePlan.

This is a step-by-step guide to using barcodes for checking-in guests.

Requirements

1. A barcode scanner that emulates an extra keyboard. Usually this will plug
into a USB port in your PC or Mac. You can buy them from around $90/
£70/€80 and quite a few different scanners are available. For more
information see our USB barcode scanners web page. Note Most USB
barcode scanners do not support 2-dimensional/matrix barcodes, such as
QR codes.

2. A barcode font installed on the PC or Mac you are going to use to print
the barcodes. We recommend using barcodes that conform to the code
39 standard (also known as code 3/9 or code 3 of 9). Free barcode fonts
are available. For more information See our barcode fonts web page.

3. A good quality printer for printing the barcodes. Ideally a laser printer.
But an inkjet printer might be OK if it has a high quality setting (often
called 'Photo' or 'Image' quality).

4. A unique ID for each guest comprised of only barcode compatible
characters. If you let PerfectTablePlan generate your guest Ids then you
shouldn't have any problems. 

Guest Ids

PerfectTablePlan v7 will automatically create unique 15 character
Ids comprised only of the hex characters 0-9 and A-F (NB/ upper
case only). The ID is based on the time the guest was created
(milliseconds since 1-1-1970) and the number of guests previously

https://www.perfecttableplan.com/html/usb-barcode-scanners.html
http://en.wikipedia.org/wiki/Qr_code
http://en.wikipedia.org/wiki/Code_39
http://en.wikipedia.org/wiki/Code_39
https://www.perfecttableplan.com/html/barcode-fonts.html
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created on that computer, so it is very unlikely that 2 guests will
ever have the same ID, even if they were created on different
computers.

If you import your own guest Ids make sure that they contain only
the following characters: 0-9, A-Z, $%+-./ and space. Characters
not in this set will by converted to - (minus). Characters a-z will be 
converted to upper case, so Ids mustn't differ only by case. Also try
to keep the ID short (ideally 15 characters or fewer) to avoid the
barcode becoming very large.

You will be warned if you try to print or export non-unique, blank or
excessively long barcodes. PerfectTablePlan will give you the option
to automatically reassign these Ids.

Note PerfectTablePlan V4 used 32 character Ids, which are too long
for barcodes in most cases. If you open a v4 plan and try to print
barcodes from it you will be given the option to replace the long Ids
with shorter (but still unique) Ids.

Step 1. Install a barcode font

Make sure you have installed a barcode font (see above).

Step 2. Add barcodes to stationery

Create your invitations, badges or tickets as usual then add the substitution
text:

· {guest_barcode_id} (if you are printing a stationery item per guest);

or

· {group_members_barcode_ids_multi_line} (if you are printing a

stationery item per group)
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Do not select Word wrap.

Now set the substitution text to the barcode font you have installed. Don't
worry if it is very long or mostly blank at this stage in the Design tab.
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It might also be a good idea to include a human-readable version of the ID
under the barcode. To do this just add {guest_barcode_id} again, but

choose a normal (non-barcode) font this time. Ideally use a non-
proportional font, such as Courier. 

Make sure you leave some blank space around the barcode so it is easy for
the scanner to read. 

Now check the size of the barcodes in the Preview tab. 
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If the barcode is too big try increasing the size of the stationery. If that isn't
possible, try decreasing the barcode font size.

Font size

The size of the barcode is important as the USB scanner won't be
able to read it if it is too small or too big. Code 39 typically requires
at least 25 mm (1 inch) per 9 characters to be read reliably by a
USB barcode scanner. We have found that a font size between 20pt
and 25pt usually works well. The standard PerfectTablePlan
barcodes are 17 characters (15 ID characters plus an asterisk either
end), which is approximately 45 mm (1.75 inches) for a 20pt code
39 font (depending on the font).

Step 3. Test a sample of your stationery

1. Select File>Print. You will be warned if you have non-unique, blank or
excessively long guest barcode Ids and given the opportunity to allow
PerfectTablePlan to fix this.

2. Click on the Setup button in the Print window.
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3. In the Print setup window:

· Change Pages so that only a single page is printed.

· Click on Preferences and change the print quality to the highest

available.

· Click Print.

On the PC/Mac that you intend to use for checking-in guests:

1. Plug-in your USB barcode scanner into a USB port. Note Your PC/Mac
might have to install a new device driver the first time you use the
scanner. 

2. Start PerfectTablePlan.

3. Load your plan file.

4. Select File>Check-In Guests.

If the barcode cannot be read from the printouts, try the following:

· Increase the amount of white space around the barcode.

· Increase or reduce the barcode font size.

· Increase the quality of the print out.

· Change the background of the stationery to white.

· Change the colour of the barcode text to black.

· Use higher quality stationery.

· Test your barcode scanner on a barcode from another source (e.g. a tin of

baked beans) to ensure that the scanner isn't defective. Note  It might not
be able to read some formats of barcode fonts.

Step 4. Print your stationery
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Select File>Print and print all your stationery, making sure you still have
the printer set to high quality.

Test a random selection (as in step 3) to ensure you can still scan them.

Step 5. Check-in your guests

1. Set the Floor plan pane to show RSVP status and/or number of guests
arrived/unarrived at each table.

2. Select File>Check-In Guests.

3. Set the settings appropriately in the Check-In Guests window.

4. Click Start checking-in>>.

5. Scan guest barcodes with your barcode scanner.

Limitations

PerfectTablePlan does not support multiple users on different computers
updating the same table plan at the same time. This means that you can:

1. Check-in using PerfectTablePlan on a single computer/laptop. This will
allow you to easily see the total number of guests checked-in and empty
seats. However, this isn't practical for large numbers of guests.

or
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2. Check-in using PerfectTablePlan on a multiple computers/laptops, each
with a copy of the plan. This will allow you to check-in larger events. But it
won't allow you to easily see the total number of guests checked-in or
empty seats.

1.4 Editions

1.4.1 Editions

The table below summarises the differences between the 3 PerfectTablePlan

Editions. You can switch between editions in the Editions tab of the 
Preferences window. If you switch to an edition you don't have a licence for
you will be in trial mode (no saving, printing or exporting of plans with >30
guests).

Edition

Home Advanced Professional

Typical users

People organizing
their own wedding
reception, party or

bar/bat mitzvah

Charity organizers,
club secretaries,
lodge secretaries

and other frequent
users

Professional event
planners

Event size Unlimited Unlimited Unlimited

Number of events Unlimited Unlimited Unlimited

Duration of licence Unlimited Unlimited Unlimited

Free support by email

14-day money back
guarantee

Import guest data
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Rectangular, Banquet,
Head, Custom Circular,

Semi-circular, Oval
tables + rows of seats

Add images/textures to
floor plan

Add images to stationery

Add background image
to floor plan

E-shaped tables

Serpentine tables (90
and 180 degrees)

'You are here' maps in
stationery

Save import mappings

Custom seat numbering

Save a plan as a
template

Custom guest fields maximum 2 maximum 20

Edit VDU chart footer

Custom automatic seat
assignment

Automatically assign
multiple seatings in one

operation

Import seating data
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Import proximity data

Import/export record
Ids

Add barcoded Ids to
stationery

Check-in guests with a
USB barcode scanner

(scanner not included)

Bulk edit proximity

Fast table
renumbering/renaming

Fast table layout

Merge changes during
import 

Reports

summary

troubleshooting

summary

troubleshooting

multi-plan
summary/matrix/pairs/
guest seating (up to 3

plans)

summary

troubleshooting

multi-plan
summary/matrix/pairs/
guest seating (up to 50

plans)

detailed (summary)

detailed (guests)

Price per user see website

Upgrade to a higher edition

https://www.perfecttableplan.com/html/purchase.html
https://www.perfecttableplan.com/html/upgrade_edition.html
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2 Reference

2.1 User interface

2.1.1 Main window

This is the main window of the application. The tool bar buttons and panes
visible will depend on the button selected in the Task tool bar. Use the buttons
at the top of the window to minimise, maximise or close it.

See also:

· Menu bar

· Task tool bar

· Main tool bar
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· Insert tool bar

· Status bar

· Guests pane

· Groups pane

· Proximity pane

· Custom Field Proximity pane

· Floor Plan pane

· Table Plan pane

· Schematic pane

· Table Chart pane

· Guest Chart pane

· VDU Chart pane

· Stationery pane

· Report pane

· Dashboard pane

· Windows

· Drag and drop

· Keyboard accelerators

2.1.2 Menu bar

Use the Menu bar to access various actions supported by the software.

The File menu supports various actions on the current plan file.
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The Edit menu supports various edit actions. Apart from Undo/Redo,
Preferences and Copy, these act on the selected items in the most recently
selected pane (the icon for this pane is shown in the Status bar).

The View menu allows you control which elements of the user interface are
visible.

The Insert menu allows you to insert new guests and tables into your plan.

The Licensing menu allows you to add or update your licence key.

The Help menu allows you to access various forms of help information.

Hint Many commands are available as keyboard accelerators, for example to
access File>Open without using the mouse type Ctrl+O. Alternatively you can
use menu accelerators, for example type Alt-F-O to access File>Open. 

2.1.3 Task tool bar

The Task tool bar takes you through each step of creating a table plan.
Depending on which step is selected some panes and tool bar buttons will be
hidden.

Button Meaning

Step 1: Add guests to plan

Step 2: Decide who to sit
together/apart

Step 3: Add tables to plan

Step 4: Assign guests to seats

Step 5: Output plan
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2.1.4 Main tool bar

Use the Main tool bar to access common actions. All of these actions are also
available through the Menu bar. Many of them are also available as keyboard
accelerators, for example Ctrl+O opens an existing plan file. 

Note Only icons appropriate to the current task are displayed.

You can also hide the tool bar buttons for basic actions by checking hide

new/open/recent/save tool bar icons in the Preferences window

Button Meaning

New plan

Open existing plan

Open recently accessed plan

Save plan

Event Information window

Numbers and Budget window

Copy to clipboard contents of Right
pane

Show/edit properties of selected
item

Delete selected item(s)
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Automatic seat assignment

Order poster prints and place cards

Print

Email plan as an attachment (not
available on Mac)

Export plan in various formats

Show list of tasks you might need
help with

Hint Hover the mouse cursor over a tool bar button to get a tool tip window

explaining the action. You can turn tool tips on/off in the Preferences
window.

2.1.5 Insert tool bar

Use the Insert tool bar to add guests and tables. All of these actions are also
available through the Menu bar. Many of them are also available as keyboard
accelerators, for example Ctrl+G inserts a new single guest. 

Note Only icons appropriate to the current task are displayed.

Button Meaning

Import guest information

Quick add guests

Insert single guest
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Insert guest couple

Insert guest family

Insert guest group

Insert E-shaped table (Advanced and
Professional editions only)

Insert rectangular table

Insert banquet table

Insert head table

Insert custom table

Insert circular table

Insert semi-circular table

Insert oval table

Insert 180 degree curved table
(Advanced and Professional editions
only)

Insert 90 degree curved table
(Advanced and Professional editions
only)
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Insert row of seats

Hint Hover the mouse cursor over a tool bar button to get a tool tip window

explaining the action. You can turn tool tips on/off in the Preferences
window.

2.1.6 Status bar

The Status bar shows various useful information:

· a description of any menu item or tool bar button currently being hovered over

or selected

· the icon for the currently selected pane (where File>Edit>Delete and other

operations will be carried out)

· numbers related to the current plan, click on the numbers to configure this in

the Status bar tab of the Preferences window

· whether the software is licensed (and a Buy now or Upgrade now button, if

it isn't)

2.1.7 Guests pane

The Guests pane shows all the guests in the current plan as individuals.

The icon shown for a guest is determined from the details you have entered
about their gender and age.

You can change the column order by dragging and dropping the columns.

Guests who have declined or cancelled are shown with strikethrough text.

Guests who have not been assigned to seats are shown in bold. Guests who are

locked are shown with underlined text.

Select from the Mode drop-down list to change the behaviour of the pane (see
below).
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Click on the  button to sort the guests in a multi-level sort (e.g. by last name
then first name). Alternatively click on any of the column headers (for example
on Display name) to sort by just that column. Clicking a column again reverses
the sort order.

Type text in the Search field to hide non-matching guest names. E.g. if you
type ad it will hide all guests without ad in one or more of their properties (case

is ignored). Click the  cancel icon or press the Esc key to clear the field. Click

on the  button to show/hide drop-down lists for filtering guests. Choose from
the assignment status and RSVP status drop-down lists to hide guests with non-
matching assignment and RSVP status.

Click on the  button to show additional controls. 

If the Floor plan pane is displayed, check Mark guests in floor plan to
show a marker next to the guest you are hovering the mouse cursor over. 

Change the Search in drop-down list to control whether to search guest names
or all columns (including any custom fields). Searching just names should be a
bit faster. Hidden columns are not searched.

Check/uncheck column check boxes to show/hide columns. 

Right-click on a guest to display actions in a pop-up menu.

Note that changing the RSVP status of a guest from Accepted may unassign

them from their seat, depending on your settings in the Preferences window.

Drop a plan file from Windows onto this pane to open it. Drop an Excel, vCard,
text or CSV file from Windows onto this pane to import it. 

Drag a guest from another PerfectTablePlan window to add them to the current
plan.
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Mode

Drag & drop

Left-click on one or more guests and drag them to a seat or table in the Floor

Plan, Table Plan or Schematic panes to assign them to a seat. Hold down
the Shift key to also drag all the other members of their group.

Edit guest properties by double-clicking on them or right-click and select
Properties from the pop-up menu.

Right-click on a guest to display actions in a pop-up menu.

Double-click on a guest to display the Properties window.

Select more than one guest by using Shift+click or Ctrl+click. Use Ctrl+A to
select everything in this pane.

Edit

Click on a guest property to edit it.

Use the Enter, Tab or Ctrl+arrow keys to change row or column. Use the Space
or arrow down keys to edit a drop-down list.

See also: 

· Add or remove dots at the end of titles

· Add custom fields
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· Edit a property for multiple guests

· Importing guests

· Print a guest list

2.1.8 Groups pane

The Groups pane shows all the guests in the current plan arranged in their
groups.

The icon shown for a guest is determined from the details you have entered
about their gender and age.

You can change the column order by dragging and dropping the columns.

Guests who have declined or cancelled are shown with strikethrough text.

Guests who have not been assigned to seats are shown in bold. Guests who are
locked are shown with underlined text.

Groups with one or more guests who have declined or cancelled are shown with

strikethrough text. Groups with one or more guests who have not been

assigned to seats are shown in bold. Groups with one or more guests who are

locked are shown with underlined text.

The icon shown for a group is based on PerfectTablePlan's best guess at whether
the group is a family, couple etc. The group icon is just a visual cue, it doesn't
affect anything else.

Select from the Mode drop-down list to change the behaviour of the pane (see
below).

Click on the  button to sort the guests in a multi-level sort (e.g. by last name
then first name). Click on the Group name headers to sort groups by that
column. Click on one of the other columns to sort by Group name and then by
the clicked column. Clicking the column again reverses the sort order.

Note Guests are always sorted within their group in the Groups pane 

Type text in the Search field to hide non-matching group names. Guest
names are not searched. E.g. if you type Acme it will hide all groups without

Acme in their name (case is ignored). Click the cancel icon or press the Esc

key to clear the field.
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Click on the  button to show additional controls.

Click Expand all or Collapse all to expand/collapse all the groups.

If the Floor plan pane is displayed, check Mark guests in floor plan to
show a marker next to the guest you are hovering the mouse cursor over. If you
hover over a group all the guests in the group will be marked.

Check/uncheck column check boxes to show/hide columns. 

Note that changing the RSVP status of a guest from Accepted may unassign

them from their seat, depending on your settings in the Preferences window.

Drop a plan file from Windows onto this pane to open it. Drop an Excel, vCard,
text or CSV file from Windows onto this pane to import it. 

Drag a guest from another PerfectTablePlan window to add them to the current
plan.

Note Deleting a group deletes all the guests in it.

Mode

Drag & drop

To assign seats left-click on one or more guests or groups and drag them to a

seat or table in the Floor Plan, Table Plan or Schematic panes.

To change group membership left-click on one or more guests or groups and

drag them from one group to another within the Groups pane

Right-click on a guest or group to display actions in a pop-up menu.

Double-click on a guest or group to display the Properties window.

Select more than one guest or group by using Shift+click or Ctrl+Click. Use
Ctrl+A to select everything in this pane.
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Edit

Click on a guest or group property to edit it.

Use the Enter, Tab or Ctrl+arrow keys to change row or column. Use the Space
or arrow down keys to edit a drop-down list.

See also:

· Move guests from one group to another

· Insert a new guest into an existing group

· Edit a property for multiple guests

· Importing guests

· Import guests in couples/families/groups

· Print a guest list

2.1.9 Proximity pane

The Proximity pane shows an abstract view of who should be placed near
whom.

Note The table is symmetric, if you change the proximity for column A and row
B, the proximity for row B and column A will change automatically.

You can move around the table and change values using the Arrow keys, Space
bar and Return key.

Select from Display to change how the guest names are displayed.

Type text in the Search row and Search column fields to hide non-

matching guest names. E.g. if you type jo in the Search row field it will hide
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all rows for guests without jo in their name (case is ignored). Click the cancel

icon or press the Esc key to clear the field.

Default proximity values are set automatically for guests when they are added
as a couple, family or group, but you can add to or override as you wish. For
example, if you add Mr & Mrs A as a couple they will be automatically assigned

proximity Next to (a  will appear in the cells where the columns and rows
for Mr A and Mrs A intersect). The automatic assignment will then try to put

them next to each other. To change this proximity to Not Next to (perhaps

they have had an argument!) click on the cell and select  from the drop-down
list.

You can change the default proximities for couples, families and groups in the 
Preferences window.

Click on the  button to show additional options.

Select from For:

· All: all guests

· By group: guests in the selected group

· By group+: guests in the selected group and all guests with non-neutral

proximity to members of this group

Select from the drop-down list or click on the  and  buttons to change the
selected group.

Select from Columns:

· Show all: show all columns.

· Hide non-empty: hide columns that have at least one non-neutral proximity.

· Hide empty: hide columns that have only neutral proximity.

Note Columns hidden by Columns are in addition to columns hidden by 
Search column.

Check assignable guests only to show only guests who can be assigned to

seats (due to their locked + RSVP status and settings in the Preferences
window).
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Hint If you want to change the proximity for everyone in a single group it may

be easier to select a group (in the Groups pane) or more than one guest (in

the Guests pane or Groups pane) and then select Edit>Proximity. You
can set the proximity for everyone on a table by selecting the table and then
Edit>Proximity. This can be useful for arranging multiple seatings.

Professional edition only

Click on the Bulk Edit... button to update large numbers of proximities in a
single operation in the Bulk Edit Proximity window.

See also:

· Bulk edit proximity (video with audio, 1:08 minutes)

See also:

· Change the proximity for multiple guests

· Proximity

2.1.10 Custom Field Proximity pane

Professional edition only

The Custom Field Proximity pane allows you to set guest proximities
based on custom fields.

You can set proximities for custom fields of type Yes/No and Selection. E.g.
if you have a Selection custom field "department" with values "sales",
"marketing", "engineering" and "admin" you can set proximities in this pane
so that the automatic seat assignment will try to seat people in the same
department together or not together.

http://www.screencast.com/t/91mvOZ8WZ0
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You can set multiple custom proximities at the same time. E.g. you could
seat guests together (or apart) depending on their geographical area,
seniority and department.

The automatic seat assignment score is multiplied by the value of the
Weighting field. This can be useful to set the relative importance of

different custom field proximities. E.g. The score of 2 Next to proximity
guests seated next to each other is usually +20, but if the Weighting is set
to 0.5 it will be +10. The score is rounded to the nearest whole number.

If the table is large, editing it one cell at a time can be quite tedious. Click
on the Bulk Edit... button to edit multiple cells in a single operation using

the Bulk Edit Custom Proximity window. This button is only available
for custom fields of type 'selection'.

Note Setting proximities for custom fields will slow down the automatic seat
assignment.

See also:

· Custom proximity (video with audio, 1:04 minutes)

See also:

· Add custom fields

· Assign seating by guest type/category

http://www.screencast.com/t/kDCh3c4oWuNo
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2.1.11 Floor Plan pane

The Floor Plan pane shows an 'aerial' view of your table plan. You can only
select one seat or table at a time in this pane.

Appearance

Clicking on the  and  buttons zooms in and out. Clicking on the  button
zooms and scrolls (pans) the display to show all the items in your plan. You can
also use a 'pinch' gesture to zoom, if your device supports gestures. When you
are zoomed in you can move around by clicking on the scroll bars or by holding
down the right mouse button and dragging the background (the cursor will
change to a hand).

Toggle the  button on/off to magnify the area under the mouse cursor.
Magnification allows you to read a large plan without having to zoom in and out.
You can change the size of the area magnified and the level of magnification
using the sliders in the Configure magnification cursor window that appears
when you press the button in.

By default the inside of the floor plan is shown in white and the outside of the
floor plan is shown in grey.

You can change the floor plan dimensions and units by clicking on the  button.
You can also set whether a grid is drawn (and what size) and whether tables,
shapes and text are snapped to a grid (and what size).

You can also change the size of the floor plan by dragging the bottom-right
corner.

Advanced and Professional editions only
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Click the Scale background image button to resize a background image
to the same scale as your floor plan.

Click the Insert Line button to add a line or wall to the floor plan.

Click the Insert text button to add text to the floor plan (e.g. a title). We
would really appreciate a mention of www.perfecttableplan.com in the footer!

Click the Insert shape button to add shapes to the floor plan (e.g. to
represent dance floors or stages).

Click the Insert image button to add images to the floor plan (e.g. to add a
logo). You can also drag an image from your operating system or web browser

onto the Floor Plan pane.

Professional edition only

Click the Renumber/rename table button to quickly rename lots of
tables.

Click the Layout tables button to layout selected tables in a grid.

Click the Align vertical button to align (same X position) the selected item
centres under the top-most item selected.

Click the Align horizontal button to align (same Y position) the selected item
centres right of the left-most item selected.

Click the  or  buttons to rotate the selected table, shape or text item 45
degrees clockwise or anti-clockwise. For finer control use the Angle field in the
Table Properties window.

Click the Move to Back button to move the selected item behind (under)
others in the vertical stacking order.

https://www.perfecttableplan.com/
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Click the  button to change the fonts and colours. The table colour will be
overridden by colours set for individual tables through the Table Properties
window. 

Note If the name of a guest can't be fitted into the space available in the 
Floor Plan pane the font will automatically be scaled smaller for that name to
try to make it fit.

Hint If you want to seamlessly join two tables set the inner and outer colours of
the table to be the same.

Type text in the Search field to select matching floor plan items. E.g. if you
type x it will select all floor plan items that contain an 'x' (case is ignored). Click

the cancel icon or press the Esc key to clear the field. Note that only text
visible in the floor plan is searched (e.g. the contents of a guest's Notes field
will only be searched if the Display drop-down field is set to Notes).

Click on the  button to show additional options.

Select from the Seats drop-down list according to how you want seats and
guest names to be displayed.

Select from the Display drop-down list to change the text that is displayed for
assigned seats.

Advanced and Professional editions only

Set the Display drop-down list to Custom name... to choose your own
name format. This can include HTML tags and custom fields. For example:

{last}, {title} {f}<br><i>({position})</i>

Where position is a custom field.

Select from the Places drop-down list according to whether you want the guest
place setting to be Empty,  show Tableware (plate+cutlery) or the Seat
number. If you choose Seat number (small, medium or large) it will be shown
in the same font as the table name, but automatically resized to fit. If the seat
number is more than 2 characters long (e.g. because you have used the custom
seat numbering available in the Advanced and Professional editions) it may be
truncated or overlap other text. 
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Select from the Tables drop-down list according to what text you want
displayed for the table. If you show unassigned seats, any unassigned seats
may also be highlighted with a red cross, depending on the setting for Seats.

Note The name and number of seats assigned/unassigned is not displayed for a

row of seats in the Floor Plan pane.

Changing the Floor Plan

New tables are inserted in a vacant space near the current centre of the pane.
Once a table has been placed you can drag it to any location inside the floor
plan. 

You can also use the keyboard arrow keys to move selected items. If grid snap
is not on, you can hold down the Shift key to make smaller movements.

Guests can be dragged between seats or from the Guests pane or Groups
pane (set the Left pane Mode to drag & drop). Drop a guest away from a seat
or table to unassign them.

Note If you drag a guest on to a seat where another guest is already assigned,
the guest will swap seat with the guest being dragged.

If you drag to the edge of the pane the pane will scroll automatically.

Double-click on a table or guest to show the Properties window.

Right-click on a table or seat to display actions in a pop-up menu.

Check Freeze floor plan to prevent changes to the positions of tables, shapes,
images and text items on this pane. Note that you can still reassign guests and
change some item properties.
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Check Hide empty seats to hide seats with no assigned guest (and any
corresponding place settings). This makes drag and drop harder and is generally
only recommended when you are printing or exporting.

Assessing your plan

When you hover the mouse cursor over a table or assigned seat a tool tip
window with summary information will appear. You can turn these tool tips

on/off in the Preferences window.

Hold down the  button to show all guests that should be sitting next to each
other.

Hold down the  button to show all guests that should be sitting near to each
other.
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Hold down the  button to show all guests that should be sitting near but not
next to each other.

Hold down the  button to show all guests that should not be sitting next to
each other.

Hold down the  button to show all guests that should be not be sitting near to
each other.

Hold down the  button to show all guest proximities.

Hold down the  button to show potential seating issues, e.g. guests with 
proximity that aren't sitting next to each other.

Hold down the  button to show critical seating issues, e.g. guests that aren't

sitting next to any of their  proximity guests.

If you hold down the Shift key while pressing any of the above 6 buttons, only
the proximity for guests whose tables or chairs are selected will be shown. This
can be very useful when showing the proximities of all guests is too confusing.

Professional edition only

If you hold down the Alt key while pressing any of the above 6 buttons,
custom proximities will also be shown. This can be a lot of proximities, so
you may need to use it when selecting a subset of guests and also holding
down the Shift key.

Depress the  button to colour code guests according to how well seated they
are based on the proximity of nearby guests; green for well seated and red for
poorly seated.

Depress the  button to colour code guest genders (blue for male, pink for
female, grey for undefined).

Depress the  button to show the age of guests (large circle for adult, small
circle for child).

Depress the  button to colour code which groups guests belong to. 
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Depress the  button to show colour-coded meal choices. Each meal is
displayed in a different colour. If you have more than one course (e.g.
“soup,fish,ice cream”) the courses will be displayed as concentric rings: outer
ring=first course, second ring=second course etc.

You can also colour code guests by custom field.

Note The visualization colours are chosen automatically by default. We have
chosen the 12 default colours to be easily distinguishable, even for people with

most types of colour blindness. But you can change these colours in the 
Visualization colours window.

Depress the  button to show VIP guests and VIP tables.

Depress the  button to show guests with special needs.

Depress the  button to show guest RSVP status.

Depress the  button to show locked guests.

Depress the  button to show guides lines when you select a single floor plan
item.

Depress the  button to show spacings around each table (but not rows of
seats).

Depress the  button to show a colour key when you are using to colour to
visualize gender, groups, meals and custom fields. 

Hint Some of the above will be easier to see if you use simple (e.g. default )

colours in the Floor Plan pane.

Mouse wheel

If your mouse has a mouse wheel you can use it to scroll or zoom, depending on

the settings in the Preferences window. If you have set the mouse wheel to
scroll vertically hold down the Ctrl key to zoom, and vice versa. If you have set
the mouse wheel to scroll vertically, hold down the Alt key to scroll horizontally. 

Keyboard accelerators

You can change the selected table or seat using Alt+Left arrow and Alt+Right
arrow (change table) and Alt+Up arrow and Alt+Down arrow (change seat).
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Printing, copying and exporting

When you are happy with the layout you can print this page with File>Print.
You can also export the image as a PDF, PNG, BMP or JPEG file using
File>Export or copy it to the clipboard using Edit>Copy.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Change the size of the room

· Create a non-rectangular room

· Space tables correctly

· Space seats correctly

2.1.12 Table Plan pane

The Table Plan pane shows a single table, with an optional legend (text). You
can only select a single seat or table in this pane. The legend cannot be selected.

Appearance

Clicking on the  and  buttons zooms in and out. Clicking on the  button
zooms and pans the display to show all the contents. You can also use a 'pinch'
gesture to zoom, if your device supports gestures.

When you are zoomed in you can move around by clicking on the scroll bars or
by dragging the background (the cursor will change to a hand).

Click the  button to change the fonts and colours. The table colour will be
overridden by colours set for individual tables through the Table Properties
window.

Note If the name of a guest can't be fitted into the space available in the 
Table Plan pane, the font will automatically be scaled smaller for that name to
try to make it fit.

Click on the     buttons to display the first, previous, next or last table.
You can also select a table from the drop-down list.

https://www.perfecttableplan.com/video/floorplanv7.html
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Click on the  button to show additional options.

Select from the Arrow to drop-down list to display a directional arrow. This
arrow can point up, right, down, left or to any table. Note the arrow will not be
displayed when it is pointing to the current table.

Select from the Seats drop-down list according to how you want seats and
guest names to be displayed.

Change the Display drop-down to change the text that is displayed for assigned
seats.

Advanced and Professional editions only

Set the Display drop-down list to Custom name... to choose your own
name format. This can include HTML tags and custom fields. For example:

{last}, {title} {f}<br><i>({position})</i>

Where position is a custom field.

Select from the Places drop-down list according to whether you want the guest
place setting to be Empty,  show Tableware (plate+cutlery) or the Seat
number. If you choose Seat number (small, medium or large) it will be shown
in the same font as the table name, but automatically resized to fit. If the seat
number is more than 2 characters long (e.g. because you have used the custom
seat numbering available in the Advanced and Professional editions) it may be
truncated or overlap other text. 

Check the legend check box to show the text legend. Check the header, seat,
VIP, gender, age, meal, special, notes or group check boxes to show the
corresponding information in the legend.

Note The legend will display an Event: header if the Event field is set in the 
Event Information window.

Changing the Table plan

Guests can be dragged between seats or from the Guests pane or Groups
pane (set the Left pane Mode to drag & drop). Drop a guest away from a seat
or table to unassign them.
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Note If you drag a guest on to a seat where another guest is already assigned,
the guest will swap seat with the guest being dragged.

Double-click on a table or guest to show the Properties window.

Right-click on a table or seat to display actions in a pop-up menu.

Check Hide empty seats to hide seats with no assigned guest (and any
corresponding place settings). This makes drag and drop harder and is generally
only recommended when you are printing or exporting.

Assessing your plan

When you hover the mouse cursor over a table or assigned seat a tool tip
window with useful information will appear. You can turn these tool tips on/off in

the Preferences window.

Hold down the  button to show all guests that should be sitting next to each
other.

Hold down the  button to show all guests that should be sitting near to each
other.

Hold down the  button to show all guests that should be sitting near but not
next to each other.

Hold down the  button to show all guests that should not be sitting next to
each other.
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Hold down the  button to show all guests that should be not be sitting near to
each other.

Hold down the  button to show all guest proximities.

Hold down the  button to show potential seating issues, e.g. guests with 
proximity that aren't sitting next to each other on this table.

Hold down the  button to show critical seating issues, e.g. guests that aren't

sitting next to any of their  proximity guests on this table.

If you hold down the Shift key while pressing any of the above 6 buttons, only
the proximity for guests whose tables or chairs are selected will be shown. This
can be very useful when showing the proximities of all guests is too confusing.

Professional edition only

If you hold down the Alt key while pressing any of the above 6 buttons,
custom proximities will also be shown. 

Note Only the proximities for guests on the current table are shown.

Depress the  button to colour code guests according to how well seated they
are based on the proximity of nearby guests; green for well seated and red for
poorly seated.

Depress the  button to colour code guest genders (blue for male, pink for
female, grey for undefined).

Depress the  button to show the age of guests (large for adult, small for
child).

Depress the  button to colour code which groups guests belong to.

Depress the  button to show colour-coded meal choices. Each meal is
displayed in a different colour. If you have more than one course (e.g.
“soup,fish,ice cream”) the courses will be displayed as concentric rings: outer
ring=first course, second ring=second course etc.

You can also colour code guests by custom field.
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Note The visualization colours are chosen automatically by default. We have
chosen the 12 default colours to be easily distinguishable, even for people with

most types of colour blindness. But you can change these colours in the 
Visualization colours window.

Depress the  button to show VIP guests and VIP tables.

Depress the  button to show guests with special needs.

Depress the  button to show guest RSVP status.

Depress the  button to show locked guests.

Depress the  button to show a colour key when you are using to colour to
visualize gender, groups, meals and custom fields. 

Hint Some of the above will be easier to see if you use simple (e.g. default )

colours in the Table Plan pane.

Click the Terms button to change the words used in the pane.

Mouse wheel

If you mouse has a mouse wheel you can use it to scroll or zoom, depending on

the settings in the Preferences window. If you have set the mouse wheel to
scroll vertically hold down the Ctrl key to zoom, and vice versa. If you have set
the mouse wheel to scroll vertically, hold down the Alt key to scroll horizontally. 

Keyboard accelerators

You can change the selected table or seat using Alt+Left arrow and Alt+Right
arrow (change table) and Alt+Up arrow and Alt+Down arrow (change seat).

Printing, copying and exporting

When you are happy with the layout you can print this page with File>Print.
You can also export the image as a PDF, PNG, BMP,JPEG file using File>Export
or copy it to the clipboard using Edit>Copy.
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2.1.13 Schematic pane

The Schematic pane shows the table plan in an abstract form that is
convenient for browsing. It also optionally shows the assignment scoring.

Guests who have declined or cancelled are shown with strikethrough text.

Guests who are locked are shown with underlined text.

Select from the Mode drop-down list to change the behaviour of the pane (see
below).

Change the Display drop-down list to change the way in which the names of
assigned guests are displayed.

The order of the tables can be changed by clicking on the Table order button to

display the Table Order window.

Type text in the Search field to hide non-matching table names. Guest names
are not searched. E.g. if you type head it will hide all tables without head in

their name (case is ignored). Click the cancel icon or press the Esc key to
clear the field.

Click on the  button to show additional options.

New tables are added at the bottom of the pane. You can change the position of

a table in the order by dragging it. Alternatively, select the table and use the 

and  buttons at the top of the pane to move the table up or down the order.

Check the show scores check box to show the assignment scores. Note that a
'smoothing' function is applied to the total for each guest before the grand total
is calculated.
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Click Expand all or Collapse all to expand/collapse all the tables.

Mode

Drag and drop

Drag one or more guests to a seat or table within the Schematic pane to re-
assign their seat. Hold down the Shift key to also drag all the other members of

their group. You can also drag guests from the Guests pane or Groups

pane to the Schematic pane.

Note If you drag a guest on to a seat where another guest is already assigned
the guests will swap seats.

Drag a table within the Schematic pane to change the order in which it is

displayed here and in the Table chart pane.

Edit guest or table properties by double-clicking on them or right-click and select
Properties from the pop-up menu.

Right-click on a guest or table to display actions in a pop-up menu.

Double-click on a guest or table to display the Properties window.

Select more than one guest or table by using Shift+click or Ctrl+Click. Use
Ctrl+A to select everything in this pane.

Edit

Click on the locked or table column to edit a guest locked status or a table
name.

Use the Enter, Tab or Ctrl+arrow keys to change row or column. Use the Space
or arrow down keys to edit a drop-down list.

See also:

· Change the table order
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2.1.14 Table Chart pane

The Table Chart pane shows a seating chart, ordered by table. This can be
very useful for displaying at the entrance to an event. Tables with no guests
assigned are omitted. It is not possible to change the plan from this pane.

Use the Display drop-down list to change how guest/group names are
displayed.

Use the By drop-down list to display a line per Guest or a line per Group.

Note If you set By to Group you can control how group member names are
displayed using the Display group members as field in the Names tab of the

Preferences window.

Use the Sort by drop-down list to change the way how guests/groups are
ordered on each table.

You can also change the number of Columns in the chart and control the font

and colours by clicking on the  button.

Click the  or  buttons to paste the chart into a new Microsoft Word or Excel
document. You must have Microsoft Word or Excel installed.

Click on the  button to show additional options.

You can optionally show the table, section, seat, notes, meal choice, special
requirements, group and num. in group. The meal choice and special
requirements can be very useful for caterers.

Click on the Title or Footer button to add/edit a title or footer for this pane. The
Chart Title/Footer window will be displayed. We would really appreciate a
mention of www.perfecttableplan.com in the footer!

The order of the tables can be changed by clicking on the Table order button to

display the Table Order window. Alternatively, you can change the order in

the Schematic pane. Tables are laid out left to right and then top to bottom.

You can copy the contents of the whole pane to the clipboard as plain text and
HTML using Edit>Copy. Use right-click and Copy to copy selected text to the
clipboard.

When you are happy with the layout you can print this page with File>Print.

https://www.perfecttableplan.com/
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You can export the pane as an Excel, CSV, plain text or HTML file using
File>Export and selecting table chart to text/CSV/HTML file. Select Excel

CSV file, Text file or HTML file from the Save As type drop-down in the 
Export window. Plain text may be useful for emailing to your stationery
supplier. HTML preserves the layout and is useful for web pages and other
HTML-aware applications, such as Microsoft Word. CSV files can be opened as
Excel spreadsheets.

Hint Use Ctrl+A to select everything in this pane.

See also:

· Change the table order

· Change the order of guests in a group

2.1.15 Guest Chart pane

The Guest Chart pane shows a chart, ordered by guest name (alphabetically
by last name then first name). This allows guests to find their table quickly and
can be very useful for displaying at the entrance to an event. You can also print
off a full guest list. It is not possible to change the plan from this pane.

Use the Display drop-down list to change how guest/group names are
displayed. If you are displaying by group, the groups will be ordered by the last
name of the first guest in each group.

Use the By drop-down list to display a line per Guest or a line per Group.

Note If you set By to Group you can control how group member names are
displayed using the Display group members as field in the Names tab of the

Preferences window.

Using the For drop-down list you can display:

· guests who have (or haven't) been assigned to seats; or

· guests by RSVP status; or

· all guests; or

· selected guests
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You can also change the number of Columns in the chart and control the font

and colours by clicking on the  button.

Click the  or  buttons to paste the chart into a new Microsoft Word or Excel
document. You must have Microsoft Word or Excel installed.

Click on the  button to show additional options.

You can optionally show the headers, table, section, seat, notes, meal
choice, special requirements, RSVP status, group and num. in group. The
meal choice and special requirements can be very useful for caterers.

Click on the Title or Footer button to add/edit a title or footer for this pane. The
Chart Title/Footer window will be displayed. We would really appreciate a
mention of www.perfecttableplan.com in the footer!

Click the Terms button to change the words used in the pane.

You can copy the contents of the pane to the clipboard as plain text and HTML
using Edit>Copy. Use right-click and Copy to copy selected text to the
clipboard.

When you are happy with the layout you can print this page with File>Print.

You can export the pane as an Excel, CSV, plain text or HTML file using
File>Export and selecting guest chart to text/CSV/HTML file. Select Excel

CSV file, Text file or HTML file from the Save as type drop-down in the 
Export window. Plain text may be useful for emailing to your stationery
supplier. HTML preserves the layout and is useful for web pages and other
HTML-aware applications, such as Microsoft Word. CSV files can be opened as
Excel spreadsheets.

Hint Use Ctrl+A to select everything in this pane.

See also:

· Print a guest list

· Change the order of guests in a group

2.1.16 VDU Chart pane

The VDU Chart pane shows a scrolling list of guest seat assignments. It is
possible to show this pane in full screen mode. This can be very useful for

https://www.perfecttableplan.com/
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displaying on a VDU or plasma screen at a venue. But we strongly recommend
you test this before an event to ensure that you your hardware/software is
compatible with the screen and you have the correct cable.

It is not possible to change the plan from this pane.

Change the Display drop-down list to change the information displayed:

· Last First to display by guest, with the last name in column 1 and first name

in column 2. Ordered alphabetically by last name. Anonymous guests are not
shown.

· First Last to display by guest, with the first name in column 1 and last name

in column 2. Ordered alphabetically by last name. Anonymous guests are not
shown.

· Display name to display by guest, with the display name in column 1.

Ordered alphabetically by last name. Anonymous guests are not shown.

· Group to display by group, with the group name in column 1. Ordered

alphabetically by group name. 

Advanced and Professional edition only

· Select custom field of type selection to display by the values of that field.

Ordered alphabetically by value.

Change the By drop-down depending on whether you wish to show seat
numbers along with the table/row.

Advanced and Professional edition only

If you have a single E-shaped table, then the name of the section (sprig) is
shown instead of the table name.



115

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

Change the Columns to change the number of columns of guest information
displayed.

Change the Text percentage to change the percentage of the space occupied by
scrolling text. The remainder will display the floor plan. Set it to 100% to hide
the floor plan. The image shown is a simplified version of your floor plan. To
change the colour or other properties of the floor plan (including the seat

number font size) go to the Floor Plan pane.

Move the Speed slider right to increase the scrolling speed and left to decrease
the scrolling speed.

Click the  button to start the text scrolling and the  button to pause it (only
one of these is visible at any time).

Click the  button to display this pane full screen. Press any key or click the
mouse to exit full screen mode.

Click on the  button to show additional options.

Click the Font font drop-down list, size edit or colour button to change the font,
size or colour of the scrolling text. Check auto size to have the font size set
automatically.

Note Large fonts can be slow to draw and cause a jerky effect.

Click the Background colour button to change the background colour of the
pane.

Check the contrast check box if you want to show alternate rows in a contrast
colour.

Change the Floor plan drop-down list to change whether the floor plan image is
displayed on the left of the scrolling text or on top of the scrolling text.

Click the Title... button to add/edit title text.

Professional edition only

Click the Footer... button to add/edit footer text.
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Click the Terms... button to change the column headers used (e.g. to another
language).

See also:

· VDU chart (video with audio, 2:17 minutes)

· Assign (or reassign) seats in real time

· Display seating on a VDU or plasma screen

2.1.17 Stationery pane

The Stationery pane allows you to design and print items of stationery and
easily merge in details of your guests and their seating arrangements from your
PerfectTablePlan data. Each page can contain a single stationery item (e.g. an
A4 invitation letter) or multiple items (e.g. 3x6 address labels).

Design a master for your stationery items in the Design tab and preview it in

the Preview tab.

Note You can order place cards online.

Top controls

Click on the Open stationery button to load a stationery design. A few
samples are included with PerfectTablePlan. You can also save your own designs
to use later or send to other PerfectTablePlan users.

Click on the Stationery layout button to change the layout of the existing
design. For example to change the page size or the number and dimensions of
items on the page.

Click on the Save stationery button to save the current stationery design to
a file. You will be able to load this design back into this plan, or another plan, at
a later date.

Select from the Item per drop-down list to create a stationery item for each
guest, each group or each table.

Select from the For drop-down list to choose which guests/groups you wish to
create stationery items for.

http://www.screencast.com/t/gTZCirs5v
https://www.perfecttableplan.com/html/buy_place_cards.html


117

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

For example, if you are printing place cards, you probably want to select Item
per to Guest and For to Assigned. If you are printing invitations you probably
want to select Item per to Group and For to All. If you want to reprint an
individual place card you probably want to select Item per to Guest and For to
Selected....

Select from the Sort by drop-down list to determine the order in which
stationery items are ordered. This feature should make it easier to set up place
cards if you have hundreds of guests. It is only available for Item per=Guest .

Click on the  button to show additional options.

Select from the Fold drop-down list to a horizontal or vertical fold. This can be
useful for designing and printing tent fold cards. Folds are displayed in printouts.

Set the Border thickness to greater than 0 to add a border to each stationery
item.

Click on the Border colour button to change the colour of the border around
each item. This has no effect if the Border thickness is 0.

Click on the Background colour button to change the background colour of
each item.

Design tab

Click on the Insert text button to add text and merge guest data.

Click on the Insert image button to add a graphic/image/clipart. You can
also drag an image from your operating system or web browser onto the

Design tab of the Stationery pane.

Click on the Insert guest image button to add a guest image. If Item per is
set to Group or Table this will display all the images of the guests for the group
or assigned to the table. 

Click on the Colour spot button to add a colour coded spot.

Advanced and Professional editions only
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1. Click on the You are here button to add a personalised map .

Click the Horizontal centre or Vertical centre buttons to
horizontally/vertically centre the currently selected item.

Click the Snap horizontal and Snap vertical buttons to
horizontally/vertically snap the currently selected item to the nearest guide line.
At least 1 guide line must be displayed.

Click the  or  buttons to rotate the selected item 90 degrees clockwise or
anti-clockwise.

Click the Move to Back button to move the selected item behind any other
item.

Click the Mirror button to vertically mirror the currently selected item.

Click the Delete button to delete the currently selected item.

Change the value of Guides to the number of guidelines you wish to add to the
design. These can be useful for aligning text neatly. They are not shown in
printouts.

Click on the Font button to change the font of the selected text. Alternatively

you can use the Font size field or the Italic, Bold and Underline
buttons. 

Note PerfectTablePlan will automatically reduce the font size to try to keep it
within a stationery item.
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The font size has been automatically reduced to fit for the left hand stationery item

Click on the Colour button to change the colour of the selected text.

Click on the Left align, Centre align or Right align buttons to change
the alignment of the selected text.

Click on the Word wrap button to allow line breaks to be added where text is
too long to fit within the stationery. If this isn't sufficient to fit the text within the
stationery, the font size may be automatically reduced as well.

Drag the splitter at the top of the text edit box to increase or decrease the size
of the text edit area.

Preview tab

Select Display to show either a full page of items or a single item (e.g. 3x6
address labels or a single address label) and the number of the page/item to
display.

Set Start position to position on the page where you wish the first item to be
printed.

Check cut marks if you would like cut marks to be printed on the page. This can
be useful if you are using a guillotine to cut the page.

Substitution text
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If you use the following text in your design it will be substituted by the
appropriate data from your plan.

In alphabetical order:

Substitution text Substituted
by

Example Available for
'Item per'

{current_date} The current
date in your
local format

31/12/2009 Guest, group or
Table

{current_time} The current
time in 24 hour
format

13:59:00 Guest, group or
Table

{event_date} event date

from Event
Information
window

31/1/2010 Guest, group or
Table

{event_name} event name

from Event
Information
window

Gala dinner Guest, group or
Table

{event_notes} event notes

from Event
Information
window

Guest, group or
Table

{event_venue} event venue

from Event
Information
window

The Crown hotel Guest, group or
Table

{group_address} the address of
the group

1 The Street

The Town

Nowhereshire

Guest or Group
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NW1 123

England

{group_address1} line 1 of the
group address

1 The Street Guest or Group

{group_address2} line 2 of the
group address

Guest or Group

{group_contact} full contact
details of group
(address +
contact
numbers)

1 The Street

The Town

Nowhereshire

NW1 123

England

111-1111-1111

email@email.com

Guest or Group

{group_country} the address
country

England Guest or Group

{group_email} group email
address

email@email.com Guest or Group

{group_home_phone
}

group home
phone number

111-111-1111 Guest or Group

{group_meals} meals of group
members

fish + beef Guest or Group

{group_members_bar
code_ids_multi_line}

list of group
member guest
Ids in a form
suitable for a

*1234567890*

*2345678901*

Guest or Group



122

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

code 39
barcode, one
per line with
blank lines
between
(Professional
Edition only)

{group_members_mu
lti_line}

list of group
members, one
per line

Mr J Smith

Mrs K Smith

Guest or Group

{group_members} list of group
members on
one line

Mr & Mrs J. Smith
or Mr & Mrs John
Smith (depending
on the setting of
the Display
group members
as field in the
Names tab of the

Preferences
window)

Guest or Group

{group_members_firs
t}

first member of
group

Mr J Smith Guest or Group

{group_mobile} group mobile
phone number

111-111-1111 Guest or Group

{group_name} group name Smith family Guest or Group

{group_notes} notes for the
group

Guest or Group

{group_num_membe
rs}

number of
members of the
group

2 Guest or Group

{group_special_reqs} special
requirements of
group members

wheelchair Guest or Group
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{group_state_county
}

the address
state/county

Nowhereshire Guest or Group

{group_table_section
s}

the table
section(s) the
group is
assigned to -
blank if not an
E-shaped table
(Advanced and
Professional
Editions only)

A & B Guest or group

{group_tables} the table(s) the
group is
assigned to

table 1 Guest or group

{group_town_city} the address
town/city

The Town Guest or Group

{group_work_phone} group work
phone number

111-111-1111 Guest or Group

{group_zip_postcode
}

the address
zip/postcode

NW1 123 Guest or Group

{guest_age} guest age adult Guest

{guest_barcode_id} guest ID in a
form suitable
for a code 39
standard
barcode
(Professional
Edition only)

*0123456789* Guest

{guest_display_name
}

guest display
name

Mr John Smith
Master of
Ceremonies

Guest
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{guest_email} guest email
address

email@email.com Guest

{guest_first_name} guest first
name(s)

John Guest

{guest_first_name_in
itials} 

guest first
name(s) as
initials

J. Guest

{guest_gender} guest gender male Guest

{guest_home_phone
}

guest home
phone number

111-111-1111 Guest

{guest_last_name} guest last
name(s)

Smith Guest

{guest_last_name_ini
tials} 

guest last
name(s) as
initials

S. Guest

{guest_meal_multi_li
ne}

guest meal,
one course per
line

soup

fish

Guest

{guest_meal} guest meal soup,fish Guest

{guest_mobile} guest mobile
number

111-111-1111 Guest

{guest_notes} notes for the
guest

Guest

{guest_rsvp} guest RSVP
status

Accepted Guest

{guest_seat} seat guest
assigned to

1 Guest
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{guest_special_req} guest special
requirements

visually impaired Guest

{guest_suffix} guest suffix PhD Guest

{guest_table_section
}

table section
guest assigned
to - blank if not
an E-shaped
table
(Advanced and
Professional
Editions only)

A Guest

{guest_table} table guest
assigned to

Table 3 Guest

{guest_title} guest title Mr Guest

{guest_vip} guest VIP
status

VIP Guest

{guest_work_phone} guest work
phone number

111-111-1111 Guest

{table_groups_multi_
line}

list of groups at
table, one
group per line

Smith family

Jones family

Table

{table_groups} list of groups at
table on one
line

Smith family &
Jones family

Table

{table_guest_meals_
multi_line}

list of guests
and meals for
table, one per
line

Mr J Smith: beef

Mrs K Smith: fish

Table

{table_guests_alpha_
multi_line}

list of guests at
table in

Mrs K Jones Table
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alphabetic last
name order,
one guest per
line

Mr J Smith

{table_guests_alpha} list of guests at
table in
alphabetic last
name order, on
one line

Table

{table_guests_multi_
line}

list of guests at
table in seat
order, one
guest per line

Mr J Smith

Mrs K Jones

Table

{table_guests} list of guests at
table in seat
order, on one
line

Mr & Mrs J Smith Table

{table_meals_multi_l
ine}

list of guest
meals for table,
one meal per
line

beef x3

fish x2

Table

{table_meals} list of guest
meals for table
on one line

beef x3 + fish x2 Table

{table_name} the name of
the table

Table 1 Table

{table_notes} notes for the
table

Table

{table_num_seats} number of
seats for the
table

8 Table

{table_shape} table shape Circular Table



127

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

The final text will:

· have any leading or trailing spaces removed

· have multiple consecutive spaces replaced with a single space

Note Text will only be substituted if Item per is set to the correct value, e.g.
{guest_title} will not be substituted if you  set Item per to Table.

Exporting

You can export your stationery to a PDF file by selecting File>Export and
selecting stationery to PDF file.

See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Print stationery tutorial

· Merge guest names into stationery

· Load sample stationery

· Create address labels

· Change the order of guests in a group

2.1.18 Report pane

The Report pane shows reports of your plan. It is not possible to make changes to
the plan from this pane.

Type is the type of report:

Report
type

Description Example usages Editions
available

Summary An overall
summary of the
current plan

· how many guests have

accepted their invitation

all

https://www.perfecttableplan.com/video/stationeryv7.html
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· how many males vs females

· how many of each meal have

been ordered by guests

Troublesh
ooting

Identifies issues
that may need
attention in the
current plan

· guests with 'Not near to

proximity' that have been
placed on a table together

· tables with duplicate names

· groups with no guests

all

Multi-plan
(summary
)

Shows where
guests were
seated across
multiple plans in
a textual form

· which events Mr John Smith

attended and who he sat next
to at each event

· any guests without 'near to' or

'next to' proximity who have
sat next to each other at 2 or
more events

Advanced (up
to 3 plans)
and
Professional
(up to 50
plans)

Multi-plan
(pairs)

Shows how
guest pairs were
seated across
multiple plans in
a tabular form

· checking how often pairs of

guests were sat next to each
other or at the same table
across multiple events

Advanced (up
to 3 plans)
and
Professional
(up to 50
plans)

Multi-plan
(matrix)

Shows how
guests were
seated relative
to other guests
across multiple
plans in a
tabular form

· checking for guests sat next to

each other at more than one
event

Advanced (up
to 3 plans)
and
Professional
(up to 50
plans)

Multi-plan
(guest
seating)

Shows where
guests were
seated across

· giving to people attending

networking events

Advanced (up
to 3 plans)
and
Professional
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multiple plans in
a tabular form

(up to 50
plans)

Detailed
(summary
)

A detailed
summary of a
particular aspect
of the current
plan

· how many guests ordered each

meal by table

· total of 'amount owing' custom

field by group

Professional

Detailed
(guests)

Similar to a
Detailed
(summary)
report, but also
lists guest
names

· which guests ordered each

meal by table

· the names of guests listed by

special requirement and table

Professional

Click the Terms... button to change the words used in the report (e.g. to
another language). Note that not all text can be replaced in all reports.

You can copy the contents of the whole pane to the clipboard as plain text and
HTML using Edit>Copy. Use right-click and Copy to copy selected text to the
clipboard.

When you are happy with the layout you can print this page with File>Print.

You can export the pane as an Excel, CSV, plain text or HTML file using
File>Export... and selecting report to text/CSV/HTML file. Select Excel

CSV file, Text file or HTML file from the Save as type drop-down in the 
Export window. Plain text may be useful for emailing to your caterer. HTML
preserves the layout and is useful for web pages and other HTML-aware
applications, such as Microsoft Word. CSV files can be opened as Excel
spreadsheets.

Click the  or  buttons to paste the chart into a new Microsoft Word or Excel
document. You must have Microsoft Word or Excel installed.

Summary report

The summary report gives overall statistics for your plan.

Troubleshooting report
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The trouble shooting report checks for the following 47 potential issues in your
plan. If there are more than 100 results for any one issue, only the first 100 will
be displayed for brevity.

For the purposes of the report seated 'next to' means adjacent seats and 'near
to' means seated on same table, table section (for E-shaped tables) or row of
seats.

Issue Notes Reported

Empty guest Ids Professional edition only

Duplicate guest Ids case insensitive

the number of duplicates is
shown in brackets

Professional edition only

Duplicate guest
Title+First+Last names

case insensitive

the number of duplicates is
shown in brackets

always

Duplicate guest display
names 

case insensitive

the number of duplicates is
shown in brackets

always

Guests without titles if of guests have
titles

Guests without first
names

if of guests have
first names

Guests without last
names

if of guests have
last names

Guests with gender
different to title default

The default gender for a
title is set in 'Titles' tab of

the Preferences window

always
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Guests with age different
to title default

The default age for a title is

set in 'Titles' tab of the 
Preferences window

always

Guests with undefined
gender

if of guests have
defined genders

Guests without a guest
or group phone number

if of guests have
at least 1 guest or
group phone number
(work, home or mobile)

Guests without a guest
or group email

if of guests have
a guest or group email

Guests with unset RSVP if of guests have
RSVP set

RSVP Declined/Cancelled
guests assigned to seats 

always

RSVP Accepted/Arrived
guests not assigned to
seats 

always

Assigned VIP guests not
at VIP tables

if 1 or more VIP tables

Assigned guests without
meals

if of assigned
guests have meals set

Proximity 'Next to'
guests not seated near
to each other

unassigned guests are
ignored

always

Proximity 'Next to'
guests seated near but
not next to each other

unassigned guests are
ignored

always
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Proximity 'Near to'
guests not seated near
to each other 

unassigned guests are
ignored

always

Proximity 'Not near to'
guests seated next to
each other

unassigned guests are
ignored

always

Proximity 'Not near to'
guests seated near but
not next to each other 

unassigned guests are
ignored

always

Proximity 'Not next to'
guests seated next to
each other 

unassigned guests are
ignored

always

Proximity 'Not next to'
guests seated near but
not next to each other 

unassigned guests are
ignored

always

Guests with all 'Next to'
and 'Near to' proximities
unfulfilled

guest has at least 1 'Next
to' or 'Near to' proximity set
but none of these
proximities are satisfied

the number of 'next to' and
'near to' proximities
unfulfilled is shown in
brackets

unassigned guests are
ignored

always

Guests with all 'Next to'
proximities unfulfilled

guest has at least 1 'Next
to' proximity set but none
of these proximities are
satisfied

the number of 'next to'
proximities unfulfilled is
shown in brackets

always
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not shown if displayed in
"All 'Next to' and 'Near to'
Proximities unfulfilled"

unassigned guests are
ignored

Guests with no proximity unassigned guests are
ignored

if of assigned
guests have proximities
set

Guests with >2 'Next to'
proximities

a guest can only sit next to
a maximum of 2 other
guests

unassigned guests are
ignored

always

Guests with >n 'Next to'
and 'Near to' proximities

if the biggest table is 10
seats then a guest can only
sit next to or near to a
maximum of 9 other guests

unassigned guests are
ignored

if there is at least 1
table

Duplicate group names case insensitive

the number of duplicates is
shown in brackets

always

Groups with no
members 

always

Groups with anonymous
members 

the number of anonymous
members is shown in
brackets

always

Groups on more than
one table

the tables are shown in
brackets

always
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Groups with incomplete
contact details

groups with the 'Address 1'
or 'City' contact fields not
set

if of groups have
contact details set

Duplicate table names case insensitive

the number of duplicates is
shown in brackets

always

Tables with empty seats the number of empty seats
is shown in brackets

if of tables have
no empty seats

See also:

· Troubleshooting report (video with audio, 1:10 minutes)

Advanced and Professional editions only

Multi-plan reports

Click the Choose plans... button to select which plans to include in your
report. The Choose plans window will appear. The maximum number of
plans depends on which Edition of PerfectTablePlan you have.

In the Professional edition you can select from the Match by drop-down list
depending on whether you want to match guests between plans by their ID
or name (Title+First name+Last name, case is ignored). 

Note Guests will only have the same ID if:

1. You copied a plan (e.g. using File>Save As); or

2. You imported the same ID for the same guest to multiple plans.

Click Go to create the report.

Multi-plan (summary) report

http://www.screencast.com/t/giJslgIMV2ob
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Check the detailed check box if you want to include a detailed report on
each guest (this can make the report very long). 

Multi-plan (pairs) report

Set Show guests sat depending on whether you are interested in guests
sat at the same table (table section for E-shaped tables) or just guests sat
next to/opposite each other.

Set the times value to set the threshold for how many times a pairing has
to occur before it is displayed. For example, to show guests that are sat on
the same table more than once, set Show guests sat to same
table/section and times to >1.

Proximity is shown by colour (see the key in the report). Potential problems
are highlighted in yellow, the greater the issue the darker the yellow.

In the above example we can see that:

1. Mr Andrew Adams and Mrs Nikki Adams were seated next to each other in
seatings 1,2 and 3. The proximity for all 3 seatings was 'Next
to' (denoted by the red background colour).

2. Mrs Rose Atwell sat on the same table as (but not next to or opposite)
Mrs Nikki Adams for seating 3. Their proximity was neutral.

3. Mrs Michelle Blaire was sat at the same table as (but not next to or
opposite) Mrs Rose Atwell for seatings 1 and 2. The proximity for seating
2 was 'Not next to' (denoted by the grey background colour). The yellow
background colour of the cell shows that there is a potential issue (guests
with 'Not next to' proximity sat at the same table).

Multi-plan (matrix) report
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Set Show guests sat depending on whether you are interested in guests
sat at the same table (table section for E-shaped tables) or just guests sat
next to/opposite each other. 

Proximity is shown by colour (see the key in the report). Potential problems
are highlighted in yellow, the greater the issue the darker the yellow.

In the above example we can see that:

1. Mr Andrew Adams and Mrs Nikki Adams were seated next to (denoted by
a '*') each other in seatings 1,2,3 and 4. The proximity for all 4 seatings
was 'Next to' (denoted by the red colour).

2. Mrs Rose Atwell sat on the same table as (but not next to or opposite) Mr
Colin Ayer for seating 3. Their proximity was neutral.

3. Mrs Michelle Blaire sat next to or opposite Mr Colin Ayer for seating 4.
Their proximity was neutral.

4. Mrs Cynthia Brown was sat at the same table as (but not next to or
opposite) Mr Andrew Adams and Mrs Nikki Adams for seatings 1 and 2.
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The proximity for seating 2 was 'Not next to' (denoted by the grey
colour). The yellow colour of the cell shows that there is a potential issue
(guests with 'Not next to' proximity sat at the same table).

Multi-plan (guest seating) report

Set Show seats if you want to show seats as well as tables.

Professional edition only

Detailed (summary) and Detailed (guests)
reports

Display is the guest property you wish to display, e.g. the meal choice.

By is how you want to group the results, e.g. by table. Choose N/A if you
don't want to group the results.
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For allows you to specify which guests you wish to include in your report.

For example, if you have a custom field 'amount owing' and you want a total
of how much money is owed by each group for all the people that have
accepted their invitations set Type to 'Detailed summary', Display to
'amount owing', By to 'Group' and For to 'RSVP accepted'.

See also:

· Detailed reports (video with audio, 0:40 minutes)

2.1.19 Dashboard pane

The Dashboard pane shows a quick visual overview of the state of your plan.

Set Chart type depending on whether you prefer Donut or Pie charts.

Set Legend depending on how you want the legend (colour key) displayed.

Set Columns according to how many charts you want displayed across the
pane.

Click on the  button to show additional options.

You can check which charts you want to display. There are 8 standard charts:

Chart Meaning

http://www.screencast.com/t/huJ6hcSbhq
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Guests Assigned Guests with seats assigned or
unassigned.

Seats Assigned Seats with guests assigned or
unassigned.

Tables/Rows Filled The tables and seat rows with either all
seats filled or not all seats filled.

All RSVP The RSVP statuses of all guests.

Unassigned RSVP The RSVP statuses of guests not
assigned to seats.

Assigned RSVP The RSVP statuses of guests assigned
to seats.

Gender All guests by gender.

Age All guests by age.

Advanced and Professional edition only

Custom fields of type Selection or Yes/No can be displayed in this pane.

Click on the Colours... button to change the colours used to denote gender or
custom fields.

Click on the Terms... button to change the words used inside the pane.

You can copy the Dashboard pane  to the clipboard using Edit>Copy and
print it using File>Print.

Export the dashboard using File>Export>dashboard to PDF/PNG/JPG/BMP
file.
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2.1.20 Windows

2.1.20.1 Windows

Help on the following windows is available:

About window

Auto Assign Multiple Seatings window

Bulk Edit Custom Proximity window

Bulk Edit Proximity window

Change Group window

Chart Title/Footer window

Check-In Guests window

Choose plans window

Custom Field window

Custom seat numbering window

Dimensions window

Edit Guest Property window

Edit Table Colour window

Edit Table Seats window

Edit Table Size window

Event Information window

Export window

Export Data window
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Export PDF window

Export VCard window

Find Plan Files window

Fonts and Colours window

Group Properties window

Guest Properties window

Image Properties window

Import window

Import Data window

Insert Couple window

Insert Family window

Insert Image window

Insert Group window

Insert Guest window

Insert Shape window

Insert Table window

Insert Text window

Join Columns window

Licence window

Main window

Most Recently Accessed window

Multi-Level Sort window
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Numbers and Budget window

Page Setup window

Preferences window

Print window

Print Setup window

Quick Add Guests window

Renumber/Rename tables window

Replace Text window

Save Stationery Layout window

Select Gradient window

Select Groups window

Select Guests window

Select Texture window

Shape Properties window

Shuffle Seats window

Show Guest Details window

Split Columns window

Stationery Layout window

Table Layout window

Table Order window

Table Properties window

Table Section Properties window
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Text Properties window

Visualization colours window

2.1.20.2 About window

The About window tells you which version of PerfectTablePlan you are using. To
display this window select Help>About....

Click on Credits to see the credits list.

Click on Close to close the window.

2.1.20.3 Auto Assign Multiple Seatings window

Professional edition only

The Auto Assign Multiple Seatings window allows you to assign multiple
seating in a single operation. It is particularly useful for events where you
want to sit different guests together for consecutive seatings, e.g. a
business networking dinner. To display this window select File>Auto
Assign Multiple... .

Set Number of seatings to the number of seating plans you wish to
create.

Set New plans folder to the folder you wish the new plans to be created in
(one for each seating). Check prompt before overwriting if you wish to
confirm overwriting any files with the same name. New plan files shows
the names of the files that will be created.

Auto assign shows the settings that will be applied to the automatic seat
assignment for each seating. Click the Change... button if you wish to
change them.

Set the After each seating drop-down list according to how you want
guest proximity to change after each seating.

Set the On completion drop-down list according to which multi-plan report
you wish to show on completion.
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Notes:

· A new plan file is created for each seating.

· When the proximities are changed after each seating it will only make a

proximity 'worse'. E.g. it will change  'Not next to'  'Not near to', but
not vice versa.'

· You can set up additional constraints using custom proximities. These are

remain unchanged between seatings.

· You can edit the plans created 'by hand' (e.g. to unassign a guest who

couldn't make a particular seating) and re-run the multi-plan report.

See also:

· Arrange multiple seatings for an event

2.1.20.4 Bulk Edit Custom Proximity window

Professional edition only

The Bulk Edit Custom Proximity window allows you to change large

numbers of cells in the Custom Field Proximity pane in a single
operation. To display this window Click on the Bulk Edit... button at the top

of the Custom Field Proximity pane.

For example, if you have a custom field 'State' with 50 possible values
(Alabama, Alaska, Arizona ... etc), and you want to set custom proximity so
that people from the same State sit 'near to' each other, you will have to set
all 50 diagonal cells to 'near to'. This is tedious to do one cell at a time.
However you can use this window to do it in a single operation by setting
Change cells to Diagonal, With proximity to Any and To proximity to
Near to.

Set the Change cells drop-down list according to which cells you want to
change. Typically this will be the diagonal cells (i.e. where 2 guests have the
same value for a custom field). 
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Set the With proximity drop-down list according to which proximity values
you want to change. For example, you might only want to change
proximities that are currently neutral so that you don't change cells that you
have previous changed. 

Set the To proximity drop-down list to the new proximity.

The number of cells that will be changed is displayed. Click OK to accept the
changes. Click Cancel to discard the changes. 

This window is only available for custom fields of type 'selection'.

See also:

· Add custom fields

· Assign seating by guest type/category

2.1.20.5 Bulk Edit Proximity window

Professional edition only

The Bulk Edit Proximity window allows you to change large numbers of
proximities in a single operation. For example you can set the proximity of
all guests seated at the same table to ‘not next to’. You can also restrict
what values of existing proximity are changed. For example you can change
only ‘neutral’ proximities, so that existing proximities are not affected. This
makes it much easier to update proximities across multiple events, e.g. to
only have couples sitting next to each other at consecutive events. To

display this window Click on the  button at the top-left of the Proximity
pane and then click on the Bulk Edit... button.

Set the Change proximity for drop-down list according to which guests
you want to change the proximity for. For example, select Guests seated
next to each other to change the proximity for each pair of guests sat
next to each other.
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Set the With proximity drop-down list according to which proximity values
you want to change. For example, you might only want to change
proximities that are currently neutral so that you don't overwrite existing
proximities. 

Set the To proximity drop-down list to the new proximity.

The number of changes that will be made is displayed. Click OK to accept
the changes. Click Cancel to discard the changes. 

See also:

· Bulk edit (video with audio, 1:08 minutes)

2.1.20.6 Change Group window

The Change Group window allows you to move one or more guests from one
group to another. To display this window select one or more guests and then
select Edit>Change Group....

Move guest(s) displays the guests that will be moved.

Select the group you want to move the guests to in To group and click OK or
double-click on the new group.

Note You can also change the group of a guest by dragging and dropping them

from one group to another in the Groups pane or by setting the Guests
pane Mode to Edit and editing the Group column.

2.1.20.7 Chart Title/Footer window

The Chart Title/Footer window allows you to change the title or footer

displayed in the Table Chart , Guest Chart or VDU chart panes. To
display this window click the Title or Footer button at the top of the appropriate

pane. Click on the  button to reveal the button.

Type the text of the title or footer in the Text edit.

In the Table chart or Guest chart pane set the size of the text relative to
the rest of the text in the pane using the Size drop down list. +4 is the largest

text and -4 is the smallest text.

http://www.screencast.com/t/91mvOZ8WZ0
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In the VDU chart pane set the font family and font size using the appropriate
controls.

Click on the Colour button to change the colour of the title or footer.

Check bold, italic and underline to set the text style of the title or footer.

Click OK to accept the changes. Click Cancel to discard the changes.

We would really appreciate a mention of www.perfecttableplan.com in the
footer!

2.1.20.8 Check-In Guests window

Professional edition only

The Check-In Guests window allows you to quickly check-in guests at
your event using a barcode scanner. To display this window select
File>Check-In Guests... .

Check set guest RSVP to and the appropriate status if you want to change
the RSVP status of guests as they check-in (typically you will want to set it

to arrived).

Check append to guest notes and the appropriate text if you want to
append some text to the Notes field of each guest checked in. For example,
you might want to add "Scanned by Jim". Check with timestamp to add a
timestamp to the entry.

Check show guest details if you want to show the guest details on-screen
as they are checked in. From the adjacent drop-down list you can choose
whether to show All details or Selected... details.

Check show guest image if you want to show the guest image on-screen
as they are checked in.

Check requires confirmation if you want to confirm each check-in e.g.
before updating guest RSVP status and/or notes.

http://www.perfecttableplan.com
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Check audible feedback if you want the computer to beep each time a
guest ID is successfully scanned and matches the guest database.

Click Start checking-in>> when you are ready to start checking-in guests.

Guest ID is where guest Ids are input via a barcode scanner. You can also
manually type in a guest ID here and press the Return key, but a barcode
scanner is a lot more efficient.

Guest displays all the information about the last guest scanned. Click on the
Edit guest button to edit this information. Click on Clear to clear this
information.

Stats shows up-to-date statistics on  your plan.

Click <<Change settings to go back and change the settings.

Click Close to chose this window.

See also:

· Checking-in guests 

· Check-in guests tutorial

· Assigning (or reassigning) seats in real time

2.1.20.9 Choose Plans window

Advanced and Professional editions only

The Choose plans window allows you to choose plans for the Multi-plan

reports in the Report pane. The plans will be listed in the report in the
same order they are displayed in this window. The maximum number of
plans depends on which Edition of PerfectTablePlan you have.
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Check/uncheck include current plan to include or exclude the current
plan. it will use the version in memory (including any unsaved changes)
rather than the version last saved to disk.

Click Add to add one or more plans.

Click Delete to delete the selected plan(s).

Click Up to move the selected plans(s) up one row.

Click Down to move the selected plan(s) down one row.

Click OK to choose these plans and close the window. Click Cancel to
discard the changes.

2.1.20.10 Custom Fields window

Advanced and Professional editions only

The Custom Fields window allows you to define your own properties for
guests. To display this window select Edit>Custom Fields... .

Click on Add to add a new custom field. The number of custom fields are
limited by the edition selected.

Click on Del to delete the selected custom fields.

Click on Up to move the selected custom fields up.

Click on Down to move the selected custom fields down.

Click OK to accept the changes and close the window. Click Cancel to
discard the changes.

The properties of each custom field are:



150

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

Property Meaning

Name The name of the custom field (maximum 20 characters).
No two custom fields can have the same name.

Type The type of field (see below).

Allowed values The values the field can take. The user can only set this
for Selection types.

Default value The value set by default for new and existing guests.

Notes Notes on the field. This appears as a tooltip when you
hover over the corresponding control.

The types of custom field are:

Field type Allowed values

Yes/No Yes or No.

Text Any text.

Number Any whole number (integer) between -2,147,483,648 and
2,147,483,647.

Currency Any floating point number between -21,474,836.48 and
21,474,836.47. Accurate to two decimal places.

Selection One of a comma separated list of items defined in the Allowed
values column.

Tags 0, 1 or many comma separated items.

You cannot change the type of a custom field after you have clicked OK. You
can delete it and replace it with a custom field with a different type and the
same name, but you will lose all the values set for the original custom field.
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See also:

· Custom fields

2.1.20.11 Custom Seat Numbering window

Advanced and Professional editions only

The Custom seat number window allows you to set custom seat
numbering for a table or row of seats. To display this window set Seat
numbers to custom or click the Change... button in the Table properties
window.

The seats are shown in order from the first seat and proceed clockwise. You
can use the cursor keys to move up and down. A Preview of the changes is
shown, with a marker pointing to the seat currently being edited.
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Click OK to accept the changes. Click Cancel to discard the changes. 

See also:

· Change the seat numbering

· Rename/renumber tables

2.1.20.12 Dimensions window

The Dimensions window allows you to change the dimensions of the floor

plan. To display this window click the  button at the top of the Floor Plan
pane.

Units allows you to choose metres or feet, as you prefer.

Size is the size of the floor plan metres/feet across (X) and down (Y).
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Area is across x down, in m2 or ft2 (depending on your choice of units).

Area per guest is the amount of area per guest, in m2 or ft2 (depending on
your choice of units).

Area per accepted guest is the amount of area per guest who has 

Accepted, in m2 or ft2 (depending on your choice of units). As a rough
guideline:

seating type comfortable space per
guest

minimum space per guest

ft2 m2 ft2 m2

all standing 7 0.7 5 0.5

all seated,
rectangular
tables

11 1 8 0.7

all seated,
circular
tables

14 1.3 11 1

Note Local fire regulations may specify limits on the number of guests for a
venue.

Seat width is the number of metres/feet between the centre of one seat and
the next (including elbow room). Automatic table size is calculated from seat
width, so increasing/decreasing seat size may increase/decrease table sizes.

Check Draw grid if you would like a visible grid to be drawn in the Floor Plan
pane. If checked you can set the drawn grid Size in the chosen units. Every fifth
line is shown darker to make it easier to count grid squares.

Check include in print/copy/export if you would like to include grid lines
when you print, export or copy to the clipboard.

Note Printing/exporting a fine grid (e.g. each foot) in a large room can slow
down print/export times considerably.
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Check Snap to grid if you would like the centres of items in the Floor Plan
pane to be constrained to a grid. If checked you can set the snap to grid Size in
the chosen units. If you turn Snap to grid on or change the snap grid Size, you
will be given the option to snap all tables, shapes and text to the new grid.

Note The drawn grid and the snap grid are independent of each other.

You can also re-size the floor plan by dragging the bottom right corner.

Advanced and Professional editions only

You can add a background image to the Floor Plan pane, scale it to the
appropriate size and then place your tables on top of it. This can be very
useful when you have a scale floor plan of the venue.
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scaled floor plan image image used as floor plan background with
tables added

Click on Browse... to locate the image file you want to use as your
background. PNG, JPEG and BMP image file formats are supported.

Click on Delete to delete the background image.

Change Background image size to change the size of the background
image as it appears in the Floor Plan pane. It will be in the units set in the
Units field. Uncheck constrain proportions if you want to stretch the floor
plan image vertically or horizontally (you won't need to do this if it is to
scale). The easiest way to scale the background image correctly is using the
background image scaling feature.

Use background image scaling to correctly scale the image.

The image data is stored inside your plan file, so you can move the plan file
to another computer without losing your image.

Note A very large image may cause your plan to be slow to load, draw and
save. You can use a graphics package such as MSPaint or Adobe Photoshop
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to resize your image smaller. Images larger than 0.25 Mega pixels will be
compressed in JPEG format for faster loading and saving. This will remove
any transparency in the image and may also reduce the image quality.

Click OK to accept the changes. Click Cancel to discard the changes. Any
changes you make to dimensions only apply to the current plan.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Space tables correctly

· Use an image of the venue

2.1.20.13 Edit Guest Property window

The Edit Guest Property window allows you to change a guest property (e.g.
title, meal choice or RSVP status) for multiple guests in a single operation. To

display this window select the guests you wish to edit in the Guests, 

 Groups, Floor plan, Table plan or Schematic panes and then select a
sub-menu under Edit>Guest Property containing '...'.

Note Selecting a table in the Floor plan, Table plan or Schematic

panes will select all the guests on that table. Selecting a group in the Groups
pane will select all guests in that group.

The display names of the guests selected will be displayed (up to 10) and the
property to edit. If the guests have more than one value for this property
<<varies>> will be displayed. <<varies>> is not an acceptable value to set.

Click OK to accept the changes and close the window. Click Cancel to discard
the changes.

See also:

· Edit a property for multiple guests

https://www.perfecttableplan.com/video/floorplanv7.html
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2.1.20.14 Edit Table Colour window

The Edit Table Colour window allows you to change the inside (fill) colour for
multiple tables in a single operation. To display this window select the tables you

wish to edit in the  Floor plan, Table plan or Schematic panes and then
select Edit>Table Property>Colour....

Select solid, gradient or texture to choose the colour, gradient or texture of

the table in the Floor Plan and Table Plan panes. This overrides any table

colour set for the pane in the Fonts and colours window. Click Default to
set the table colour back to the default.

Click OK to accept the changes and close the window. Click Cancel to discard
the changes.

See also:

· Edit a property for multiple tables

· Set transparent as colour

2.1.20.15 Edit Table Seats window

The Edit Table Seats window allows you to change the number of seats for
multiple tables in a single operation. To display this window select the tables you

wish to edit in the  Floor plan, Table plan or Schematic panes and then
select Edit>Table Property>Seats....

Note All of the selected tables must be of the same shape. You can set them to
the same shape using Edit>Table Property>Shape. You cannot remove seats
with locked guests.

Click OK to accept the changes and close the window. Click Cancel to discard
the changes.

Advanced and Professional editions only

You cannot change the number of seats for an E-shaped table this way.
Double-click on the E-shaped table and click on the Sections button.

See also:



158

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

· Edit a property for multiple tables

2.1.20.16 Edit Table Size window

The Edit Table Size window allows you to change the size of multiple tables in
a single operation. To display this window select the tables you wish to edit in

the  Floor plan, Table plan or Schematic panes and then select
Edit>Table Property>Size....

Note All of the selected tables must be of the same shape. You can set them to
the same shape using Edit>Table Property>Shape. 

Click OK to accept the changes and close the window. Click Cancel to discard
the changes.

Advanced and Professional editions only

You cannot change the size of an E-shaped table this way. Double-click on
the E-shaped table and click on the Sections button.

See also:

· Edit a property for multiple tables

2.1.20.17 Event Information window

The Event Information window allows you to show/edit general properties
of the plan. To display this window select File>Event Information or the
equivalent Main tool bar button.

Event allows you to enter a brief description of the event.

Venue allows you to enter a brief description of the event location.

Date allows you to enter the date of the event. The date format conforms to
your system locale. For example if you have set your locale to the USA you
should see MM/DD/YYYY format dates and if you have set your local to the UK
you should see DD/MM/YYYY format dates. You can change your locale through
the operating system, e.g. in Windows 11 go to Control Panel>Regional and
language options. You need to restart PerfectTablePlan after changing the
locale to see the effect.
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Days remaining shows the number of days remaining until the event.

Notes is for general notes on the event.

Click OK to accept the changes and close the window. Click Cancel to discard
the changes.

2.1.20.18 Export window

The Export window allows you to choose a type of file to export. To display
this window select File>Export or the equivalent Main tool bar button. You
cannot export data if your plan is empty.

Check display the document to display the document after export. The
viewing application will be chosen by Windows.

Check display the folder containing the document to display the folder
exported to in Windows Explorer.

Check copy the document location to the clipboard to copy the location of
the exported document as text to the Windows clipboard.

Check create a new email with the document added to compose a new
email with the exported document added as an attachment or a hyperlink.
PerfectTablePlan will attempt to create a new email using your default Windows
email application. This is not always possible, depending on how your email is
set-up.

Click OK to export the document. Click Cancel to cancel the export.

See also:

· Export formats

2.1.20.19 Export Data window

The Export Data window allows you to export guest and seat assignment
data from your plan to use in other applications, for example to import into
spreadsheets to create customized reports. To display this window select
File>Export, select guest and seating data to Excel/CSV/delimited text

file in the Export window and click OK. You cannot export data if your plan
has no guests.
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Set the Export a record per drop-down to guest or group, depending on
whether you want to export a record (line) for each guest or a record for each
group of guests. For example:

· If you want a complete list of guests to send to your stationery supplier, you

should select guest.

· If you want to create a mail merge you will probably only want to send one

letter to each group, so you should select group.

Select from the For drop-down menu depending on which guests you wish to
export.

Check Output header record if you want to add a record with the field
headings at the top of the export file.

Click on the  button to show more options.

Select the appropriate Fields check boxes, depending on what information you
want to export to the file. Use the Select all, Unselect all and Invert
selection buttons to save time changing your selection.

Use the Format drop-down list to choose whether the exported file is in Excel,
CSV or a delimited text format (e.g. fields separated by Tab characters). If you
are using delimited text format, set Field separator and Record separator
to the field and record separators you want in the export file.

Note Excel and many other types of application can open/import CSV files. 

Preview shows you what the export file will look like. It shows the effect of
changes made to Export a record per, Output header record etc. If there
are more than 20 records to export, it only shows the first 20.

Note The members (formal) output is affected by the setting of the Display

group members as field in the Names tab of the Preferences window.

Set Export file to the location of the file you wish to create. You will be
prompted if there is already a file at this location. Click on the Browse... button
to browse to a location.

Click OK to export the data and close the window. Click Cancel to discard the
changes.

See also:
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· Export formats

2.1.20.20 Export PDF window

The Export PDF window allows you to set the paper size and orientation of
the PDF document you are about to create. To display this window export a file
in PDF format.

Choose the page size from the Size drop-down list.

Choose the page orientation from the Orientation drop-down list.

For a custom page size select <Custom> from the Size drop-down list and set
Width, Height and Units appropriately.

Click OK to create the PDF document and close the window. Click Cancel to
cancel the export process.

Note When printing a PDF from Adobe Acrobat, make sure you set Page scaling
to None to print the PDF at the correct size.

See also:
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· Export formats

 

2.1.20.21 Export VCard window

The Export VCard window allows you to export guest data from your plan in
vCard format to use in other applications, for example to import into address
books of other applications. To display this window select File>Export, select

guest data to vCard file(s) in the Export window and click OK. You cannot
export data if your plan has no guests.

Select from the Export drop-down list whether you wish to export all guests in
the plan or just those currently selected in the front tab of the Left pane (all
members of any group selected will be exported).

Select from the to drop-down list whether you wish to export all guests to a
single vCard file or a separate vCard file for each guest.

Select from the in drop-down list, depending on which format of vCard you want
to export in: 

· vCard format version 3.0 is recommended.

· vCard format version 2.1 is an old format that does not support UTF-8

encoding. This means that some non-English characters may not be
supported. It is included for compatibility with older software.

Set Location to the folder you wish to create the export file(s) in. You will be
prompted if there is already a file with the same name. Click on the Browse...
button to browse to a location.

Click OK to export the data and close the window. Click Cancel to discard the
changes.

See also:

· Export formats

2.1.20.22 Find Plan Files window

Use the Find Plan Files window to locate PerfectTablePlan plan files on your
computer. To display this window select File>Find or (to display backup files)
File>Backups.
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Select from the Find drop-down list depending on the type of PerfectTablePlan
file you wish to find.

Set the in field to select the folder you wish to search. Click the Browse...
button to browse folders. Check include sub folders to search all folders within
the selected folder (and all the folders they contain, and so on).

Click Start to start the search. Click the button again to stop the search.

The files found are displayed in the list. The Last modified time is shown in ISO
format (YYYY-MM-DDTHH:MM:SS). Click Open (or double-click a file in the list)
to open the selected plan or backup file and close this window. Check open
read-only to open the plan as read-only (this can be useful when you have
multiple-users accessing the same plan file). Click Cancel to close this window
without opening a plan.

Note It may take several minutes to scan your harddisk. So you should only use
this window for plans that you can't find using File>Open or File>Open
recent.

See also:

· Most Recently Accessed window

· Backup files

· Create a re-usable template plan

2.1.20.23 Fonts and Colours window

The Fonts and colours window allows you to change fonts and

colours/gradients/textures in the Floor Plan, Table Plan, Table Chart

and Guest Chart panes. To display this window click the  button at the top
of the appropriate pane. The exact appearance of the window depends on which
pane is at the front. Use 'themes' to load and save groups of font and
colour/gradient/texture choices.

Click the buttons to set the colours/gradients/textures for the appropriate text,
tables, seats and backgrounds. Some of these buttons may give you choice of a
solid colour, a colour gradient or a texture.

Click Font... to set the appropriate font.
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Click Auto size to set the seat text font size to the optimal size (the largest it
can be without any text having to be sized smaller to fit).

Click on the  button to load the selected theme from the Themes list.

Click on the  button to save the existing colours and fonts into the Themes
list for future use.

Click on the  button to delete the selected theme from the Themes list.

Click Visualization... to change visualization colours used in the Floor Plan,

Table Plan and Stationery panes via the Visualization colours
window.

Click More fonts... to go to the PerfectTablePlan fonts web page.

Click Default to set all colours and fonts back to their original settings.

The effects of changes are shown in the Preview.

Click OK to accept the changes and close the window. Click Apply to apply the
changes without closing the window. Click Cancel to discard the changes and
close the window.

Once a theme has been created it will be available to other plans.

See also:

· Set transparent as colour

2.1.20.24 Group Properties window

The Group properties window allows you to show/edit group properties. To

display this window select a single group in the Group pane and select
Edit>Properties or the equivalent Main tool bar button.

Group

Name is the name of the group. PerfectTablePlan will attempt to guess a
reasonable name from the names of the members when the group is created,
but you can change this at any time.
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Notes is for any general notes relevant to everyone in the group. Click on
Stamp >> to add a time and date stamped comment to the top of the Notes.

Order is the order to display the group members. For example in the Table

Chart , Guest Chart or Stationery pane.

Contact

These fields store contact information for everyone in the group. This can be
useful for creating address labels.

Buttons

Click on the     buttons to display the properties of the first, previous,
next or last group. The groups are ordered alphabetically.

Click OK to accept the changes and close the window. Click Apply to apply the
changes without closing the window. Click Cancel to discard the changes.

2.1.20.25 Guest Properties window

The Guest Properties window allows you to show/edit guest properties. To

display this window select a single guest in the Guests, Groups, Floor

Plan, Table Plan or Schematic panes and select Edit>Properties or the
equivalent Main tool bar button or double-click on the guest.

Guest

Check Anon if you don't know the name of the guest.

Title is the guest's title. You can type the title or select it from existing choices
in the drop-down list. Once you have typed it in once, it will be available to
select next time you create a guest in this plan. Common titles can also be

configured in the Preferences window.

First name(s) is the guest's first (given) name(s). You can also record middle
names or initials, if you wish.

Last name(s) is the guest's last (family) name(s).

Suffix can be used for anything that appears after the guest's name, such as a:
job title (e.g. 'Director of sales'), role (e.g. 'Master of ceremonies'), qualification
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(e.g. 'BSc') or post-nominal title (e.g. 'OBE'). Common suffixes can also be

configured in the Preferences window.

Display name is the name in the format you want to display it, e.g. Mr John
Smith Phd, Master of Ceremonies. PerfectTablePlan sets a default display

name from the Title, First name, Last name and Suffix (according to the

Default display name format field in the Names tab of the Preferences
window), but you can change this at any time. You can also use HTML tags to
control the appearance of the guest Display name field. See names and titles
for more details.

Gender is the gender of the guest. This can be useful information when doing
the assignments. The automatic assignment will endeavour to alternate men and

women where it can (unless you have disabled this in the Preferences
window). PerfectTablePlan will try to set the Gender from the Title, but you can
change this at any time.

Age is the age of the guest: adult or child. Typically a child is anyone under the
age of 16. This can be useful information when doing the seat assignments.
PerfectTablePlan will try to set the age from the Title where it can, but you can
change this at any time.

Meal is the meal choice for this guest. You can type the meal or select it from
existing choices in the drop-down list. Once you have typed it in once, it will be
available to select next time. If you have a choice of more than one course you

should enter the courses separated by commas, e.g. soup,fish,flan, the 
Report pane will then total each course separately.

Special req. is for any special requirements the guest has, for example: nut
allergy, elderly or in a wheel chair. If there is more than one special requirement

they should be separated by commas, the Report pane will then total each
special requirement separately.

Notes is for any general notes relevant to the guest. This can be used to store
any information not stored elsewhere, for example whether the guest has paid.
Click on Stamp >> to add a time and date stamped comment to the top of the
Notes.

Image is an image to optionally display for this guest. To change the image,
either:

· Click on the Browse... button to select an image file to load. PNG, JPEG and

BMP image file formats are supported. You can also click on the image to
select an image file; or
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· Drag and drop an image onto Image; or

·  Select an image from the drop-down list; or

· Click Default to set the default image for the guest gender and age.

Guest images larger than 128 x 128 pixels will be automatically resized to fit
with 128 x 128 pixels.

Check VIP if the guest is an important guest, for example a guest of honour or a
member of a wedding party. The automatic assignment will take special care
assigning their seat, trying to assign them to a VIP table if there is one.

Check Locked to lock the guest to their current seat (or no seat). You will have
to unlock them to reassign their seat. This is particularly useful for stopping the
automatic assignment from moving them.

Select the RSVP status according to whether an invite has been sent, accepted,
declined or cancelled. Note that you may not be able to assign guests who have

not Accepted, depending on your settings in the Preferences window.

Use Work phone, Home phone, Mobile and Email to store guest contact
details. It is also possible to store contact details for the group in the Group
tab. 

Assigned shows which seat the guest has been assigned to (if any).

All fields are optional, except that a guest must have at least a First name or a
Last name.

Advanced and Professional editions only

You can add your own custom fields.

Note You can also edit many of these properties directly in the Guests pane

and Groups pane.

Group
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Name is the name of the group. PerfectTablePlan will attempt to guess a
reasonable name from the names of the members when the group is created,
but you can change this at any time.

Notes is for any general notes relevant to everyone in the group. Click on
Stamp >> to add a time and date stamped comment to the top of the Notes.

Order is the order to display the group members. For example in the Table

Chart , Guest Chart or Stationery pane.

Note You can easily change the group of a guest by dragging them from one

group to another in the Groups pane.

The contact details in this tab are shared by everyone in the group. This
information is optional. It can be useful for creating stationery, such as address
labels. You can also store phone numbers and emails for each guest.

Buttons

Click on the     buttons to display the properties of the first, previous,
next or last guest. The guests are ordered alphabetically.

Click OK to accept the changes and close the window. Click Apply to apply the
changes without closing the window. Click Cancel to discard the changes and
close the window. You will be warned if the guest has been edited to have the
same First Name, Last name and Title as an existing guest (unless you have
disabled this warning).

See also:

· Add or remove dots at the end of titles

· Edit a property for multiple guests

· Names and titles

2.1.20.26 Image Properties window

The Image properties window allows you to show/edit image properties in

the Floor Plan pane. To display this window select a single image in the 
Floor Plan pane and select Edit>Properties or the equivalent Main tool bar
button.
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A preview of the currently selected image is displayed. You can drag and drop a
new image here, e.g. from Windows Explorer or a web browser.

If you have added other images to this plan you can select them from the
Select image drop-down list.

Click on the Browse... button to select an image file to load. PNG, JPEG and
BMP image file formats are supported.

Name is the name of the original image file.

Pixels is the size of the image in pixels (the preview may be displayed smaller in
this window).

Set the Size field(s) to the dimensions of the image as it appears in the floor
plan. Note that the image preview will not change.

Check Constrain proportions to display the image with the same width:height
proportions (aspect ratio) as the image. 

Set the Units drop-down list to your preferred units.

Set Angle to the rotation angle of the image on the floor plan. Note that the
image preview will not change.

Notes can be used to store any relevant notes for the image. Click on Stamp
>> to add a time and date stamped comment to the top of the Notes.

The image data is stored inside your plan file, so you can move the plan file to
another computer without losing your image data.

Click OK to accept the changes and close the window. Click Apply to apply the
changes without closing the window. Click Cancel to discard the changes.

See also:

· Add a graphic/image/clipart to the floor plan

2.1.20.27 Import window

The Import window allows you to choose a type of file to import. To display
this window select File>Import or the equivalent Insert tool bar button.

See also:
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· Importing

· Import Data window

· Importing guests from Excel files

· Importing guests from text and CSV files

· Importing guests from vCards

· Import guest details from Outlook

· Import guest details from Outlook Express

2.1.20.28 Import Data window

The Import Data window allows you to import data into your plan from other
applications, for example from an Excel, CSV or text file. This can save you a lot
of typing. To display this window select File>Import... or the equivalent Insert

tool bar button. The Import window will be displayed. Select
Excel/CSV/text file and click OK. An Open window will be displayed. Select

the file you wish to import. The Import Data window will be displayed.

Mapping imported columns to guest properties

Setting up common titles and suffixes will often help PerfectTablePlan to make
better sense of the data you are importing. Click on the Titles and Suffixes
buttons to set your preferences.

Select File type to import a pre-defined file type. Select custom to define your

own. Click on the  button to show more options.

Map imported columns to guest properties shows you how the file data will
be imported, including the effects of various options described below.

If File type is set to custom, you need to tell PerfectTablePlan which columns
in the import file correspond to which guest properties. Select from the drop-
down lists at the top of each column to do this. For example column 1 might
correspond to the guest title, column 2 column to the guest last name and the
column 4 column to the guest meal choice. Leave the drop-down list as
<ignore> to ignore the contents of a column.
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Empty lines in your import file are ignored.

If you have multiple guests in one row or the title, first name, last name or
suffixes are not in separate columns, PerfectTablePlan will do it's best to unravel
them. For example it can handle all the following:

You will be warned of any unmapped input columns:
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If title is imported, but not gender or age, the import will attempt to guess the

gender or age from the title using the titles set in the Preferences window.

Note You can edit information in the table. This will change the information
imported, but not affect the contents of the file you are importing. Make sure
you press Enter to confirm any edits before clicking on Apply or OK.

Text is imported directly except for Gender, Age, VIP, RSVP, Icon file and
Import this row Y/N?, which are based on the values below:

Colu
mn

Values

Gend
er

Text must start with:

· 'F' or 'f' for a female

· 'M' or 'm' for male

otherwise the guest is imported with unknown gender

Age Text must start with:

· 'C' or 'c' for a child

otherwise the guest is imported as an adult

VIP Text must start with:

· 'V', 'v', 'Y' or 'y' for a VIP

otherwise the guest is imported as an non-VIP

RSVP Text must be:

· 'Arrived' for arrived, case unimportant

· 'Opened', 'Unopened', 'Delivered' or 'Unconfirmed' for sent, case

unimportant (for integration with paperlesspost.com, pingg.com and
zankyou.com)
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· 'Confirmed' for accepted, case unimportant (for integration with

zankyou.com)

· 'Not coming' or 'Regrets' for declined, case unimportant (for

integration with paperlesspost.com and zankyou.com)

Or else start with:

· 'S' or 's' for sent

· 'A', 'a', 'Y' or 'y' for accepted

· 'C' or 'c' for cancelled

· 'D', 'd', 'N' or 'n' for declined

Otherwise the RSVP status is unset.

Gues
t
imag
e

This needs to be the full path (location) of the image file. E.g. C:
\Users\andy\Documents\PerfectTablePlan\guesticon.png.

The images should be PNG or JPEG format. Images larger than 128 x
128 pixels will be scaled down.

Impo
rt
this
row
Y/N?

The row will not be imported if the cell contents are empty or contain
text beginning with 'N', 'n', 'F' or 'f'.

Changes made to text in the import table will not change the import file. You can
also edit any of these properties later, after completing the import.

Advanced and Professional editions only

Importing custom fields

You can import custom field values as below:
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Type Value

Yes/
No

'1' or text starting with 'y' or 't' (not case sensitive) imported as
'yes'

'0' or text starting with 'n' or 'f' (not case sensitive) imported as 'no'

Otherwise set to default

Text Text imported

Num
ber

Valid whole numbers imported

Otherwise set to default

Curr
ency

Valid whole numbers or decimal numbers imported

Otherwise set to default

Sele
ction

Allowed selections imported

Otherwise set to default

Commas are removed from values

Tags Text imported

If you want to import into a custom field that you haven't already created,
select <custom field> from the drop-down list. This will create a new
custom field for you. It will also do its best to guess the correct type and to
set the allowed values for a custom field of type Selection.
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Saving mappings

If you create a new import mapping you will be given the option to save it for
use as a new File type. This will then be available the next time you import.

Advanced and Professional editions only

Custom fields are saved in import mappings. For example, if you set up a
new import mapping assigning a column to be imported to a custom field
with name ‘region’ and type selection, if you choose that import mapping in
future:

· If a custom field with name ‘region’ exists then the column will be

imported into that.

· If no custom field with name ‘region’ exists then a new custom field of type

‘region’ and type selection will be created (assuming you aren’t exceeding
the maximum custom fields allowed).

Importing groups

If you wish to import guests as couples, families and/or groups you need to:

1. Have a group column in your input data

2. Use the same name in the group column for each person in the couple, family
or group

3. Make this column the Group column during import
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If group consecutive guests with same last name is checked then
consecutive guests with the same last name will be added to the same group.
This can be useful for family events. This option is not available if you set a
group column.

You can set the default proximities for guests imported as members of couples,

families and/or groups in the Preferences pane.

When you import group properties (such as group contact details) these are
taken from the first guest in the group.

The Num. guests field is the number of anonymous guests to be added to the
names imported. It can be from 0 to 999. For example, if the guest is "John
Smith" and Num. guests field is 2 the guests "John Smith" and 2 anonymous
guests will be added (all in the same group).

The Num. in group field is the total number of guests in the group, including
any named guests. It can be from 0 to 999. For example, if the guest is "John
Smith" and Num. in group field is  4 the guests "John Smith" and 3
anonymous guests will be added (all in the same group). If Num. in group is
fewer than the number of named guests, it will be ignored.

Note You can set the Num. guests or Num. in group column, but not both.

You can easily change the grouping of guests later by dragging them to another

group in the Groups pane.
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Professional edition only

Importing seating data

You can specify the guest table or table+seat during import. You must
create tables with the appropriate names and numbers of seats before you
import guests.

For more information see Import seating data.

See also:

· Import seating data (video with audio, 0:25 minutes)

Importing guest proximities

You can specify which guests to sit near to (or away from) during import.
Guests can be referred to by name, ID or group.

http://www.screencast.com/t/R6x41pIA3bWU
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For more information see Import proximity data.

Importing guest Ids

Select ID to designate a column as containing the unique identifier for
guests. The identifier can be any unique string of characters of any length.
The guest will keep this identifier right through to saving or exporting the
plan, even if their name is changed. If you don't have an ID column guests
will be assigned unique identifiers by PerfectTablePlan.

Further options

Location shows the location of the import file. Worksheet shows the name of
the worksheet (tab) selected from the Excel spreadsheet. Click on the Browse...
button to change the file/worksheet you wish to import.

Use Ignore first if you wish to ignore one or more rows in the file. Often the
first row is a header and you won't want to import it.

Use Encoding to set the text encoding for text based input files, such as CSV
files. Automatic guesses the encoding and will be the right choice in the vast
majority of cases.

Use the Format drop-down list to choose whether the imported file is in Excel
format, CSV format or a custom format (e.g. columns separated by Tab
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characters). If you are using a custom format, set Column separator and Row
separator to the field and record separators in the import file.

Check group consecutive guests with same last name if you want to
automatically assign consecutive guests with the same last name into the same
group. This option is not available if you have selected a group column.

Uncheck single guest per cell if some rows might contain names of multiple
guests e.g. if you want to interpret "Mr & Mrs Smith" as separate guests "Mr
Smith" and "Mrs Smith".

Click on Add row to add an additional row to be input. This is useful if you want
to type in the data for additional guests. If a row is selected the new row will be
added below, otherwise it will be added to the end.

Click on Delete row to delete the currently selected row.

Click on Add column to add an additional column to be input. This is useful if
you want to type in some additional data for each guest, e.g. their gender or
group. If a column is selected the new row will be added to the right, otherwise
it will be added to the end.

Click on Split column(s)... to split one or more selected columns into multiple
columns. 

Click on Join columns... to join two or more selected columns into a single
column. See below for more details.

Click on Copy column(s)... to make copies of one or more selected columns.
The copies are added to the right of the selected columns.

Click on Delete column to delete the currently selected column.

Splitting and joining columns

When you are importing it can be useful to split and join columns. For example
you might want to  split a column in the format "name, company" into two
separate columns "name" and "company", so you can import them into separate
fields in PerfectTablePlan. You can carry out multiple split and join operations to
get the data into the appropriate format.

For more details see joining and splitting columns.
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Preview

One you have mapped all the columns to PerfectTablePlan properties click
Next>.

You will then get the chance to preview the changes, before updating your plan.
Uncheck any guests you don't wish to import.

If there are existing guests in your plan, guests will be colour coded. Blue for
existing guests. Pink for new guests.
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Professional edition only

Merging changes

You can also merge changes to already imported guests.

You will be warned about potential issues, such as duplicate names or Ids.
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The duplicates are also marked with a flag icon in the last column.

Uncheck any guests that you don't want to import. Use the Uncheck imported,
Check imported, Uncheck imported duplicates or Check imported
duplicates to speed this up.

Click <Back to make changes. Click Cancel to discard the import. Click OK to
import the data and close the window.

See also:

· Import your guest list (video with audio, 11:59 minutes)

· Edit guest list data during import (video with audio, 1:16 minutes)

· Importing

· Merge import

· Quick Add Guests window

https://www.perfecttableplan.com/video/importv7.html
https://www.screencast.com/t/wNAWDGOug
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· Importing guests from Excel files

· Importing guests from text and CSV files

· Importing guests from vCards

· Import guest details from Outlook

· Import guest details from Outlook Express

· Example import formats

2.1.20.29 Insert Couple window

The Insert Couple window allows you to enter details for a couple. To display
this window select Insert>Guest couple or the equivalent Insert tool bar
button.

Note Guests added as a couple will share the same contact details. If this isn't
appropriate add them as individual guests with Insert>Single Guest instead.

Guests

Check Anon if you don't know the name of the guest. The guest below will also
be set to anonymous by default.

Title is the guest's title. You can type the title or select it from existing choices
in the drop-down list. Once you have typed it in once, it will be available to
select next time you create a guest in this plan. You can also add standard titles

in the Preferences window.

First name(s) is the guest's first (given) name.  You can also record middle
names or initials, if you wish.

Last name(s) is the guest's last (family) name. For convenience, the last name
of the second guest is set to the same as the last name of the first guest, but
you can change this at any time.

Suffix can be used for anything that appears after the guest's name, such as a:
job title (e.g. 'Director of sales'), role (e.g. 'Master of ceremonies'), qualification
(e.g. 'BSc') or post-nominal title (e.g. 'OBE'). Common suffixes can also be

configured in the Preferences window.



184

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

Note The Title, First name, Last name and Suffix will be automatically
capitalised (e.g. mr john smith converted to Mr John Smith) if you have

checked  automatically capitalise new guest names in the Names tab of

the Preferences window.

Display name is the name in the format you want to display it, e.g. Mr John
Smith Phd, Master of Ceremonies. PerfectTablePlan sets a default display

name from the Title, First name, Last name and Suffix (according to the

Default display name format field in the Names tab of the Preferences
window), but you can change this at any time. You can also use HTML tags to
control the appearance of the guest Display name field. See names and titles
for more details.

Gender is the gender of the guest. This can be useful information when
assigning seats. The automatic assignment will endeavour to alternate men and

women where it can (unless you have disabled this in the Preferences
window). PerfectTablePlan will try to set the gender from the Title where it can,
but you can change this at any time.

Age is the age of the guest: adult or child. Typically a child is anyone under the
age of 16. This can be useful information when assigning seats. PerfectTablePlan
will try to set the age from the Title where it can, but you can change this at
any time.

Meal is the meal choice for a guest. You can type the meal choice or select it
from existing choices in the drop-down list. Once you have typed it in once, it
will be available to select next time. If you have a choice of more than one
course you should enter the courses separated by commas, e.g. soup,fish,flan,

the Report pane will then show a total for each course separately.

Special req. is for any special requirements the guest has, for example: nut
allergy, elderly or in a wheel chair. Once you have typed it in once, it will be
available to select next time. If there is more than one special requirement they

should be separated by commas, the Report pane will then total each
separately.

Notes is for any general notes relevant to the guest. This can be used to store
any other relevant information. Click on Stamp >> to add a time and date
stamped comment to the top of the Notes.

Image is an image to optionally display for this guest. To change the image,
either:
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· Click on the Browse... button to select an image file to load. PNG, JPEG and

BMP image file formats are supported. You can also click on the image to
select an image file; or

· Drag and drop an image onto Image; or

·  Select an image from the drop-down list; or

· Click Default to set the default image for the guest gender and age.

Guest images larger than 128 x 128 pixels will be automatically resized to fit
with 128 x 128 pixels.

Check VIP if the guest is an important guest, for example a guest of honour or a
member of a wedding party. The automatic assignment will take special care
assigning their seat, trying to assign them to a VIP table if there is one.

Select the RSVP status according to whether an invite has been sent, accepted,
declined or cancelled.

Use Work phone, Home phone, Mobile and Email to store guest contact
details. It is also possible to store contact details for the group in the Group
tab. 

Note You need to scroll down using the scroll bar to fill out all the details for the
other guest in the couple.

All fields are optional, except that each guest must have either a first name or a
last name.

You can jump between guests using Page Up and Page Down keys.

Advanced and Professional editions only

You can add your own custom fields.

A couple will be given proximity Next to by default. You can change this at

any time in the Proximity pane.
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Group

Select create new if you wish these guests to be the only members of a new
group. Select add to existing and select a group if you wish these guests to be
added to an existing group.

Name is the name of the group. PerfectTablePlan will try to construct a display
name from the names of the couple, but you can change this at any time.

Notes is for any general notes relevant to the group. This is shared by all
members of the group. Click on Stamp >> to add a time and date stamped
comment to the top of the Notes.

The contact details in this tab are shared by everyone in the group. This
information is optional. It can be useful for creating stationery, such as address
labels. You can also store phone numbers and emails for each guest.

Note You can easily change the group membership of a guest later by dragging

them from one group to another in the Groups pane.

Buttons

Click Add to accept the changes and close the window. You will be warned if you
are adding a guest with the same First Name, Last name and Title as an
existing guest (unless you have disabled this warning). Click Cancel to discard
the changes.

2.1.20.30 Insert Family window

The Insert Family window allows you to enter details for a family with two or
more members. To display this window select Insert>Guest family or the
equivalent Insert tool bar button.

Note Guests added as a family will share the same group notes and contact
details. If this isn't appropriate add them as individual guests with
Insert>Single Guest instead.

Guests

Members is the number of members in the family. You can set this to 0 to
create an empty group.



187

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

Check Anon if you don't know the name of the guest. Guests below will also be
set to anonymous by default.

Title is the guest's title. You can type the title or select it from existing choices
in the drop-down list. Once you have typed it in once, it will be available to
select next time you create a guest in this plan. Common titles can also be

configured in the  Preferences window.

First name(s) is the guest's first (given) name(s).  You can also record middle
names or initials, if you wish.

Last name(s) is the guest's last (family) name(s).

Suffix can be used for anything that appears after the guest's name, such as a:
job title (e.g. 'Director of sales'), role (e.g. 'Master of ceremonies'), qualification
(e.g. 'BSc') or post-nominal title (e.g. 'OBE'). Common suffixes can also be

configured in the Preferences window.

Note The Title, First name, Last name and Suffix will be automatically
capitalised (e.g. mr john smith converted to Mr John Smith) if you have

checked  automatically capitalise new guest names in the Names tab of

the Preferences window.

Display name is the name in the format you want to display it, e.g. Mr John
Smith Phd, Master of Ceremonies. PerfectTablePlan sets a default display

name from the Title, First name, Last name and Suffix (according to the

Default display name format field in the Names tab of the Preferences
window), but you can change this at any time. You can also use HTML tags to
control the appearance of the guest Display name field. See names and titles
for more details.

Gender is the gender of the guest. This can be useful information when
assigning seats. The automatic assignment will endeavour to alternate men and

women where it can (unless you have disabled this in the Preferences
window). PerfectTablePlan will try to guess the gender from the Title where it
can, but you can change this at any time.

Age is the age of the guest: adult or child. Typically a child is anyone under the
age of 16. This can be useful information when assigning seats. PerfectTablePlan
will try to set the age from the Title where it can, but you can change this at
any time.

Meal is the meal choice for a guest. You can type the meal choice or select it
from existing choices in the drop-down list. Once you have typed it in once, it
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will be available to select next time. If you have a choice of more than one
course you should enter the courses separated by commas, e.g.

soup,fish,flan, the Report pane will then show a total for each course

separately.

Special req. is for any special requirements the guest has, for example: nut
allergy, elderly or in a wheel chair. Once you have typed it in once, it will be
available to select next time. If there is more than one special requirement they

should be separated by commas, the Report pane will then total each
separately.

Notes is for any general notes relevant to the guest. This can be used to store
any other relevant information. Click on Stamp >> to add a time and date
stamped comment to the top of the Notes.

Image is an image to optionally display for this guest. To change the image,
either:

· Click on the Browse... button to select an image file to load. PNG, JPEG and

BMP image file formats are supported. You can also click on the image to
select an image file; or

· Drag and drop an image onto Image; or

·  Select an image from the drop-down list; or

· Click Default to set the default image for the guest gender and age.

Guest images larger than 128 x 128 pixels will be automatically resized to fit
with 128 x 128 pixels.

Check VIP if the guest is an important guest, for example a guest of honour or a
member of a wedding party. The automatic assignment will take special care
assigning their seat, trying to assign them to a VIP table if there is one.

Select the RSVP status according to whether an invite has been sent, accepted,
declined or cancelled.

Use Work phone, Home phone, Mobile and Email to store guest contact
details. It is also possible to store contact details for the group in the Group
tab. 

Note You need to scroll down using the scroll bar to fill out all the details for the
other guests in the family.
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All fields are optional, except that each guest must have either a First name or
a Last name.

You can jump between guests using Page Up and Page Down keys.

Advanced and Professional editions only

You can add your own custom fields.

Adult in a family will be given proximity Next to each other by default. The

rest of the members of the family with be given proximity Near to each other.

You can change this at any time in the Proximity pane.

Group

Select create new if you wish these guests to be the only members of a new
group. Select add to existing and select a group if you wish these guests to be
added to an existing group.

Name is the name of the family group. PerfectTablePlan will try to construct a
display name from the names of the family, but you can change this at any time.

Notes is for any general notes relevant to the family group. This is shared by all
members of the family group. Click on Stamp >> to add a time and date
stamped comment to the top of the Notes.

The contact details in this tab are shared by everyone in the group. This
information is optional. It can be useful for creating stationery, such as address
labels. You can also store phone numbers and emails for each guest.

Note You can easily change the group membership of a guest later by dragging

them from one group to another in the Groups pane.

Buttons

Click Insert guest to add another guest. Click Delete guest to delete the last
guest.
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Click Add to accept the changes and close the window. You will be warned if you
are adding a guest with the same First Name, Last name and Title as an
existing guest (unless you have disabled this warning). Click Cancel to discard
the changes and close the window.

2.1.20.31 Insert Image window

The Insert image window allows you to add images to the Floor Plan
pane. These images can be useful for adding logos, crests,  decorative features
and floor plan items that are not well represented by shapes. To display this

window click the Insert image button at the top of the Floor Plan pane.

A preview of the currently selected image is displayed (if any). You can drag and
drop a new image here, e.g. from Windows Explorer or a web browser.

If you have already added images to this plan you can select them from the
Select image drop-down list.

Click on the Browse... button to select an image file to load. PNG, JPEG and
BMP image file formats are supported.

Name is the name of the original image file.

Pixels is the size of the image in pixels (the preview may be displayed smaller in
this window).

Set the Size field(s) to the dimensions of the image as it appears in the floor
plan. Note that the image preview will not change.

Check Constrain proportions to display the image with the same width:height
proportions (aspect ratio) as the image. 

Set the Units drop-down list to your preferred units.

Set Angle to the rotation angle of the image on the floor plan. Note that the
image preview will not change.

Notes can be used to store any relevant notes for the image. Click on Stamp
>> to add a time and date stamped comment to the top of the Notes.

Click Add to accept the changes and close the window. Click Cancel to discard
the changes.
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Note The new image will be placed automatically in the Floor Plan pane. It
will attempt to place it in a space near the centre of the room. You can then drag
it to the appropriate position.

The image data is stored inside your plan file, so you can move the plan file to
another computer without losing your image data.

You can change any of the image properties at a later point using the Image
Properties window.

You can also insert an image by dragging an image file from your operating

system or web browser into the Floor Plan pane.

· Add a graphic/image/clipart to the floor plan

· Find free clipart

2.1.20.32 Insert Group window

The Insert Group window allows you to enter details for a group with two or
more members. This is useful for quickly adding a group of friends or work
colleagues. To display this window select Insert>Guest Group or the
equivalent Insert tool bar button.

Note Guests added as a group will share the same group notes and contact
details. If this isn't appropriate add them as individual guests with
Insert>Single Guest instead.

Guests

Members is the number of members in the group. You can set this to 0 to
create an empty group.

Check Anon if you don't know the name of the guest. Guests below will also be
set to anonymous by default.

Title is the guest's title. You can type the title or select it from existing choices
in the drop-down list. Once you have typed it in once, it will be available to
select next time you create a guest in this plan. Common titles can also be

configured in the  Preferences window.

First name(s) is the guest's first (given) name(s).  You can also record middle
names or initials, if you wish.
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Last name(s) is the guest's last (family) name(s).

Suffix can be used for anything that appears after the guest's name, such as a:
job title (e.g. 'Director of sales'), role (e.g. 'Master of ceremonies'), qualification
(e.g. 'BSc') or post-nominal title (e.g. 'OBE'). Common suffixes can also be

configured in the Preferences window.

Note The Title, First name, Last name and Suffix will be automatically
capitalised (e.g. mr john smith converted to Mr John Smith) if you have

checked  automatically capitalise new guest names in the Notes tab of the

Preferences window.

Display name is the name in the format you want to display it, e.g. Mr John
Smith Phd, Master of Ceremonies. PerfectTablePlan sets a default display

name from the Title, First name, Last name and Suffix (according to the

Default display name format field in the Names tab of the Preferences
window), but you can change this at any time. You can also use HTML tags to
control the appearance of the guest Display name field. See names and titles
for more details.

Gender is the gender of the guest. This can be useful information when
assigning seats. The automatic assignment will endeavour to alternate men and

women where it can (unless you have disabled this in the Preferences
window). PerfectTablePlan will try to guess the gender from the Title where it
can, but you can change this at any time.

Age is the age of the guest: adult or child. Typically a child is anyone under the
age of 16. This can be useful information when assigning seats. PerfectTablePlan
will try to set the age from the Title where it can, but you can change this at
any time.

Meal is the meal choice for a guest. You can type the meal choice or select it
from existing choices in the drop-down list. Once you have typed it in once, it
will be available to select next time. If you have a choice of more than one
course you should enter the courses separated by commas, e.g. soup,fish,flan,

the Report pane will then show a total for each course separately.

Special req. is for any special requirements the guest has, for example: nut
allergy, elderly or in a wheel chair. Once you have typed it in once, it will be
available to select next time. If there is more than one special requirement they

should be separated by commas, the Report pane will then total each
separately.
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Notes is for any general notes relevant to the guest. This can be used to store
any other relevant information. Click on Stamp >> to add a time and date
stamped comment to the top of the Notes.

Image is an image to optionally display for this guest. To change the image,
either:

· Click on the Browse... button to select an image file to load. PNG, JPEG and

BMP image file formats are supported. You can also click on the image to
select an image file; or

· Drag and drop an image onto Image; or

·  Select an image from the drop-down list; or

· Click Default to set the default image for the guest gender and age.

Guest images larger than 128 x 128 pixels will be automatically resized to fit
with 128 x 128 pixels.

Check VIP if the guest is an important guest, for example a guest of honour or a
member of a wedding party. The automatic assignment will take special care
assigning their seat, trying to assign them to a VIP table if there is one.

Select the RSVP status according to whether an invite has been sent, accepted,
declined or cancelled.

Use Work phone, Home phone, Mobile and Email to store guest contact
details. It is also possible to store contact details for the group in the Group
tab. 

Note You need to scroll down using the scroll bar to fill out all the details for the
other guests in the group.

All fields are optional, except that each guest must have either a First name or
a Last name.

You can jump between guests using Page Up and Page Down keys.

Advanced and Professional editions only
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You can add your own custom fields.

All the members of the group with be given proximity Near to each other by

default. You can change this at any time in the Proximity pane.

Group

Select create new if you wish these guests to be the only members of a new
group. Select add to existing and select a group if you wish these guests to be
added to an existing group.

Name is the name of the group. PerfectTablePlan will try to construct a display
name from the members of the group, but you can change this at any time.

Notes is for any general notes relevant to the group. This is shared by all
members of the group. Click on Stamp >> to add a time and date stamped
comment to the top of the Notes.

The contact details in this tab are shared by everyone in the group. This
information is optional. It can be useful for creating stationery, such as address
labels. You can also store phone numbers and emails for each guest.

Note You can easily change the group membership of a guest later by dragging

them from one group to another in the Groups pane.

Buttons

Click Insert guest to add another guest. Click Delete guest to delete the last
guest.

Click Add to accept the changes and close the window. You will be warned if you
are adding a guest with the same First Name, Last name and Title as an
existing guest. Click Cancel to discard the changes and close the window.

2.1.20.33 Insert Guest window

The Insert Guest window allows you to enter details for a single guest. To
display this window select Insert>Single Guest or the equivalent Insert tool
bar button.
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Note A single guest is created as the only member of their own group. To add a
guest to an existing group select add to existing in the Group tab.

Guest

Check Anon if you don't know the name of the guest.

Title is the guest's title. You can type the title or select it from existing choices
in the drop-down list. Once you have typed it in once, it will be available to
select next time you create a guest in this plan. Common titles can also be

configured in the  Preferences window.

First name(s) is the guest's first (given) name(s).  You can also record middle
names or initials, if you wish.

Last name(s) is the guest's last (family) name(s).

Suffix can be used for anything that appears after the guest's name, such as a:
job title (e.g. 'Director of sales'), role (e.g. 'Master of ceremonies'), qualification
(e.g. 'BSc') or post-nominal title (e.g. 'OBE'). Common suffixes can also be

configured in the Preferences window.

Note The Title, First name, Last name and Suffix will be automatically
capitalised (e.g. mr john smith converted to Mr John Smith) if you have

checked  automatically capitalise new guest names in the Names tab of

the Preferences window.

Display name is the name in the format you want to display it, e.g. Mr John
Smith Phd, Master of Ceremonies. PerfectTablePlan sets a default display

name from the Title, First name, Last name and Suffix (according to the

Default display name format field in the Names tab of the Preferences
window), but you can change this at any time. You can also use HTML tags to
control the appearance of the guest Display name field. See names and titles
for more details.

Gender is the gender of the guest. This can be useful information when
assigning seats. The automatic assignment will endeavour to alternate men and

women where it can (unless you have disabled this in the Preferences
window). PerfectTablePlan will try to guess the gender from the Title where it
can, but you can change this at any time.

Age is the age of the guest: adult or child. Typically a child is anyone under the
age of 16. This can be useful information when assigning seats. PerfectTablePlan
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will try to set the age from the Title where it can, but you can change this at
any time.

Meal is the meal choice for a guest. You can type the meal choice or select it
from existing choices in the drop-down list. Once you have typed it in once, it
will be available to select next time. If you have a choice of more than one
course you should enter the courses separated by commas, e.g.

soup,fish,flan, the Report pane will then show a total for each course

separately.

Special req. is for any special requirements the guest has, for example: nut
allergy, elderly or in a wheel chair. Once you have typed it in once, it will be
available to select next time. If there is more than one special requirement they

should be separated by commas, the Report pane will then total each
separately.

Notes is for any general notes relevant to the guest. This can be used to store
any other relevant information. Click on Stamp >> to add a time and date
stamped comment to the top of the Notes.

Image is an image to optionally display for this guest. To change the image,
either:

· Click on the Browse... button to select an image file to load. PNG, JPEG and

BMP image file formats are supported. You can also click on the image to
select an image file; or

· Drag and drop an image onto Image; or

·  Select an image from the drop-down list; or

· Click Default to set the default image for the guest gender and age.

Guest images larger than 128 x 128 pixels will be automatically resized to fit
with 128 x 128 pixels.

Check VIP if the guest is an important guest, for example a guest of honour or a
member of a wedding party. The automatic assignment will take special care
assigning their seat, trying to assign them to a VIP table if there is one.

Select the RSVP status according to whether an invite has been sent, accepted,
declined or cancelled.
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Use Work phone, Home phone, Mobile and Email to store guest contact
details. It is also possible to store contact details for the group in the Group
tab. 

All fields are optional, except that a guest must have either a First name or a
Last name.

Advanced and Professional editions only

You can add your own custom fields.

Group

Select create new if you wish this guest to be the only member of a new group.
Select add to existing and select a group if you wish this guest to be added to
an existing group.

Name is the name of the group. The software will try to construct a display
name from the name of the guest, but you can change this at any time.

Notes is for any general notes relevant to the group. This is shared by all
members of the group. Click on Stamp >> to add a time and date stamped
comment to the top of the Notes.

The contact information is optional. It can be useful for creating stationery, such
as address labels. You can also store phone numbers and emails for each guest.

Note You can easily change the group membership of a guest later by dragging

them from one group to another in the Groups pane.

Buttons

Click Add to accept the changes and close the window. You will be warned if you
are adding a guest with the same First Name, Last name and Title as an
existing guest (unless you have disabled this warning). Click Cancel to discard
the changes.
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2.1.20.34 Insert Shape window

The Insert Shape window allows you to add shapes to the Floor Plan
pane. These shapes can be useful for representing dance floors, stages, walls

and other floor plan features. To display this window click the Insert Shape

button at the top of the Floor Plan pane.

Name is the name of the shape (optional).

Click the Font... button to set the font for the name.

Click the Name colour button to set the colour for the shape name text.

Set the Shape drop down list to the desired shape.

Set Angle to the rotation angle of the shape.

Use the Inside colour drop-down list and colour button to set a solid colour, a
colour gradient or texture for the inside of the shape.

Use the Edge colour button to set a colour for the outside of the shape.

Set the Size field(s) to the dimensions of the shape.

Set the Units drop-down list to your preferred units.

Notes can be used to store any relevant notes for the shape. Click on Stamp
>> to add a time and date stamped comment to the top of the Notes.

Click Add to accept the changes and close the window. Click Cancel to discard
the changes.

Note The new shape will be placed automatically in the Floor Plan pane. It
will attempt to place it in a space near the centre of the room. You can then drag
it to the appropriate position.

You can change any of the shape properties (including the name and shape

type) at a later point using the Shape properties window.

See also:

· Add a dance floor, stage etc to the floor plan

· Set transparent as colour
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2.1.20.35 Insert Table window

The Insert Table window allows you to create one or more tables. To display
this window select Insert>E-Shaped Table,  Insert>Rectangular Table,
Insert>Banquet Table, Insert>Head Table,  Insert>Custom Table,
Insert>Circular Table, Insert>Semi-Circular Table, Insert>Oval table,
Insert>Serpentine Table, Insert>Half Serpentine Table, Insert>Row
Seats or the equivalent Insert tool bar button.

Name is the name of the table. The software will choose a unique name for you,
but the names don't have to be unique and can be blank. 

Select solid, gradient or texture to choose the colour, gradient or texture of

the table in the Floor Plan and Table Plan panes. This overrides any table

colour set for the pane in the  Fonts and colours window. Click Default to
set the table colour back to the default.

Shape is the shape of the table. The available table shapes are:

Table Icon Meaning

E-Shaped a head (top) table + 2 or
more sprigs (legs)
(Advanced and
Professional editions
only)

Rectangular a rectangular or square
table with seats on four
sides

Banquet a long table with seats
on two sides

Head a long table with seats
on only one side, for
example a head (top)
table at a wedding or
banquet

Custom a rectangular or square
table with potentially
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different numbers of
seats on each of the 4
sides

can have rounded ends

Circular a circular table with
seats all around it

Semi-circular a semi-circular table with
seats around the straight
side and/or curved sides

Oval an elliptical table with
seats all around it

Serpentine a 180 degree curved
table (Advanced and
Professional editions
only)

Half serpentine a 90 degree curved table
(Advanced and
Professional editions
only)

Row of seats a row of seats (no
table), can be curved

Seats is the number of seats. For a circular, oval or head table or a row of seats
you specify the total number of seats. For a banquet table you specify the
number of seats across. For a rectangular table you specify the number of seats
across and the number of seats down. For a semi-circular table you specify the
number of seats across and around. For a custom or serpentine table you
specify the number of seats on each of the 4 sides.

Note For a square table create a rectangular table and set the number of seats
across and down the same. You can specify a table with no seats for a cake,

gift or serving table - it will not be shown in the Table Chart pane.
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Advanced and Professional editions only

You can change the seat numbering:

· If you set Seat numbers to sequential you can change the number of

the first seat and whether the seats are ordered clockwise or anti-
clockwise.

· If you set Seat numbers to custom... you can change them to anything

you like (including letters or names) in the Custom seat numbering
window.

· If you set Create to 2 or more, Seat numbers to sequential and check

start each with new seat number then the first seat of each table/row
will start with a new seat number, consecutive from the previous one.

Set the Display drop-down to Seat number at the top of the Floor Plan

or Table Plan panes to see seat numbers in these panes.

Size is the size of the table. Check the auto check box to automatically size the

table according to the number of seats and the seat size (as set in the 
Dimensions window). Uncheck the auto check box to set your own table size.

Note The automatic table size is calculated to avoid gaps and overlaps between
seats, partly on aesthetic grounds. Click here to find out about 'industry
standard' table sizes.

If you have a circular table bigger than the auto size you can uncheck space
seats evenly to group all the seats together. This is useful for 'sweetheart' or
'cabaret' style seating.

VIP is used to designate tables for VIPs to sit at. The automatic assignment will
attempt to seat VIPs on VIP tables.

Notes can be used to store any relevant notes for the table, e.g. details of table
decorations. Click on Stamp >> to add a time and date stamped comment to
the top of the Notes.

Create can be used to create more than one table at a time. The text alongside
tells you how many seats will be available after the new tables have been

https://www.perfecttableplan.com/html/table_size__shape_and_layout.html
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created. The tooltip shows many you need to create to add to seat all guests
and all RSVP=accepted guests.

Click Add to accept the changes and close the window. Click Cancel to discard
the changes.

Note The new table(s) will be placed automatically in the Floor Plan pane. It
will attempt to place them in spaces near the centre of the room. You can then
drag them to the appropriate position.

You can change any of the table properties (including the name and shape) at a
later point using the Table Properties window.

See also:

· Add/remove a single seat to/from a table

· Change the seat numbering

· Create rectangular tables with seats on 1,2 or 3 sides

· Create an E-shaped table

· Create a horseshoe shaped table

· Create sweetheart/cabaret style tables

· Set transparent as colour

2.1.20.36 Insert Text window

The Insert Text window allows you to add text to the Floor Plan pane.
This text can be used for titles, headers, footers and captions. To display this

window click the Insert Text button at the top of the Floor Plan pane.

Text is the content of the text.

Set Angle to the rotation angle of the text.

Click the Font... button to set the font for the text.

Use the Colour button to set a colour for the text.
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Click Add to accept the changes and close the window. Click Cancel to discard
the changes.

Note The new text will be placed automatically in the Floor Plan pane. It will
attempt to place it in a space near the centre of the room. You can then drag it
to the appropriate position.

You can change any of the text properties at a later point using the Text
Properties window.

See also:

· Add a title or text into the floor plan

· Set transparent as colour

2.1.20.37 Join Columns window

The Join Columns window allows you to join columns of data in the 
Import Data window. This can be very useful for modifying input data into an
appropriate format to import into PerfectTablePlan. To display this window click

on the Join columns... button in the Import Data window (you may need to

click the  button to make the Join columns.. button visible).

Set the order to the order you wish to join the column(s) in.

Set the separator to the text you wish to join the columns with.

Select ignoring empty cells to ignore empty cells.

Click OK to join the columns and close the window.

Click Cancel to discard the changes.

Joining creates a new column to the right of the columns being joined. The new
column is selected. The original columns are not changed. 

You can carry out as many split and join operations as you need to get your
data into appropriate columns.

See also:

· Edit guest list data during import (video with audio, 1:16 minutes)

https://www.screencast.com/t/wNAWDGOug
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· Split columns window

2.1.20.38 Licence window

The Licence window allows you to enter your licence key. To display this
window select Licensing>Licence.

Your licence status is displayed. If the software is unlicensed you will not be able
to save, export or print plans with more than 30 guests.

If you have a licence key copy and paste it into the Key field by clicking the
Paste key button or using the Ctrl+V accelerator. The key will only be
comprised of the number characters 0-9 and the alphabetic characters a-f. Dash
(-) and space characters are optional and are ignored.

Click Buy licence key now to purchase a licence key on-line (an Internet
connection is required).

Click Upgrade V6 to V7 if you have a version 6 key and wish to upgrade to
version 7.

Click Upgrade edition to upgrade to a higher edition of PerfectTablePlan.

Click Subscribe to newsletter to go to a web page where you can subscribe to
our occasional newsletter. The newsletter includes details of new releases of
PerfectTablePlan.

Click Paste key to paste from the clipboard into the Key field.

Click troubleshoot licence problems to go to our Frequently Asked Questions
web page.

Click resend licence key to go to our key retrieval page.

Click more details on licensing to go to our licensing web page.

Click OK to enter the licence key. If you have entered a new key you will be
notified of whether the key is valid or not.

Click Cancel to discard the changes.

See also:

· Licensing
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2.1.20.39 Multi-Level Sort window

Use this window to sort guests by more than one column (e.g. by last name then

by first name). To display this window click the  button at the top of the 

Guests pane or Groups pane.

Click Add to add a new sort level.

Click Delete to delete the selected sort level(s).

Click Up to move the selected sort level(s) up one row.

Click Down to move the selected sort level(s) down one row.

Click OK to accept the changes and close the window. Click Cancel to discard
the changes.

Note If you just want to sort by a single column, you can just click the
appropriate column header (click it again to reverse the sort direction).

See also:

· Assign seating by order of precedence

· Order guests by title or suffix

2.1.20.40 Most Recently Accessed window

The Most Recently Accessed window is a convenient way to open plans that
you have recently opened or saved, rather than having to search your computer
for them. To display this window select File>Open Recent... or click on the
equivalent Main tool bar button.

Plan files are shown in the order they were last opened/saved (most recent at
the top). You can click on the column headers to sort them. The Last modified
time is shown in ISO format (<YYYY-MM-DD>T<HH:MM:SS>).

Check open read-only to open the plan as read-only. This can be useful when
you have multiple-users accessing the same plan file.

Select from the Show drop-down list to filter plans by how recently they were
modified.
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To display this window every time you start PerfectTablePlan select Show this
window from the At start-up drop-down list. It will only be displayed at start-
up if there is at least one file in the list and a file has not already been loaded
(e.g. by double-clicking on a plan file to start PerfectTablePlan).

To open a plan file select it in the list and click the Open button or double-click
on the plan file. To close the window without opening a plan click the Cancel
button.

See also:

· Find Plan Files window

· Backup files

2.1.20.41 Numbers and Budget window

The Numbers and Budget window allows you to estimate approximate
number of guests attending and costs. To display this window select
File>Numbers and Budget or the equivalent Main tool bar button.

Fixed allows you to enter the fixed cost of the event, regardless of the number
of guests, e.g. venue and band hire cost.

Per child allows you to enter the cost of the event per child, e.g. the food and
drink cost per child.

Per adult allows you to enter the cost of the event per adult, e.g. the food and
drink per adult.

Set the Chance of attending to values that you feel reflect the probability of

guests attending, depending on their RSVP status. For example, set Accepted
to 95% if you think guests who have accepted their invitation are 95% likely to
attend.

The Guests column shows the number of guests for each RSVP status.

The Sub total column shows the estimated number of guests attending for each
RSVP status.

Estimated guests is an estimate of the number of guests attending (rounded
to the nearest whole number). For example, if you have 10 guests 0% likely to
attend, 10 guests 10% likely to attend, 10 guests 95% likely to attend and 5
guests 100% likely to attend the estimated number of guests is 16 ( 10 x 0% +
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10 x 10% + 10 x 95% + 5 x 100%). Due to rounding the total number of
guests may not be the same as estimated adults + estimated children.

Estimated cost is derived from the cost data provided and the estimated
number of guests.

Obviously the results are only as accurate as the data you provide.

Note You can easily change guest RSVP status in the Guests pane.

Click OK to accept the changes and close the window. Click Cancel to discard
the changes.

See also:

· Report pane

2.1.20.42 Page Setup window

Use this window to set the printer paper size, orientation and margins. To
display this window select File>Page Setup....

See also:

· Print window

· Print Setup window

2.1.20.43 Preferences window

The Preferences window allows you to change the behaviour of the software
according to your preferences. Changes apply to all plans edited by the current
user henceforth, not just the current plan. To display this window select
Edit>Preferences.

The Window has 9 tabs:

· Edition

· General

· Auto assign

· Proximity
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· Names

· Titles

· Suffixes

· Status bar

· Terms

· Backups

· Warnings

· Transfer

Edition

There are 3 different PerfectTablePlan products (editions). Each edition is aimed

at a different type of user. When you enter your licence key in the Licence
window this will set PerfectTablePlan to the edition you have purchased. But, if
you are using the trial version of PerfectTablePlan, you can choose any of the 3
editions to try. You can also try a different edition to the one you have
purchased (for example you can try the Advanced edition, even if you have only
purchased the Home edition) but your licence key will be invalid until you revert
to the correct edition.

Note You may lose data if you change the edition. For example, if you change
from Advanced edition to Home edition any custom fields will be deleted. You
may therefore wish to save your plan before changing edition.

Click Compare editions to find out more about the different editions of
PerfectTablePlan.

General

Check show tool tips to display helpful tool tips when you hover the mouse

over controls and over tables and seats in the Floor Plan pane and Table
Plan pane.

Check tool bar text to show text under each tool bar icon.
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Check hide open/recent/save tool bar icons to hide the tool bar buttons for
basic actions. Even if this box is unchecked the buttons will only be shown in
some contexts, depending on the Task bar settings.

Check export image as large as possible to make Floor Plan or Table
Plan images created by exporting as large as possible (each seat up to 300
pixels across, depending on the amount of memory available). If this box is
unchecked images will be exported/copied as standard size (each seat up to 100
pixels across, depending on the amount of memory available). The maximum
size of image exported is 4096x4096 pixels, regardless of whether this box is
checked. Export to PDF format if you want higher resolution.

Check use native file open/save windows to use the native Windows file
Open and Save windows. We only recommend unchecking this if you have
problems with the native file open/save windows.

Check allow file locking to lock open plan files so that only a single user can
write to them (any number can read). This is useful when you have multiple
users accessing shared plans across a network.

Set Tool bar icon size according to the size of icons you want to use in the
main toolbar.

Set Button icon size according to the size of icons you want to use for icon
buttons in panes.

Set When read-only plan updated according to what you want to happen
when you have opened a plan as read-only and it is updated by another
application (e.g. PerfectTablePlan running on another computer).

· Do nothing to ignore updates.

· Prompt to reload plan if you want to be prompted whether to reload each

time the plan is updated.

· Reload plan without prompting if you want to automatically display any

changes to the plan you are reading. You will still be prompted if you have
modified the plan since you opened it. This option is very useful if you are
reading a plan file from another computer to display seating changes in real
time on a VDU chart.

The At start-up drop-down list allows you to choose how to open plan files at
start-up. If you wish to open the most recently accessed plan each time you

start PerfectTablePlan, select Open last plan. If you wish to show the Most
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Recently Accessed window each time you start PerfectTablePlan, select Open
'Most recent' window. If you wish to start with a new empty plan, select
Don't open anything.

Set Default units according to whether you want newly created plans to default
to Metres or Feet.

Set User interface style according to how you want the user interface to
appear. The Windows and Windows 11 styles do not work well with Windows
dark mode.

Set Export/copy image margin to the % margin you want around Floor

Plan or Table Plan images created by exporting or copying to the clipboard.

Select Floor/Table Plan pane mouse wheel behaviour according to whether
you want the mouse wheel to zoom in, zoom out or scroll when you move the

mouse wheel backwards in the Floor Plan pane and Table Plan pane .
Hold down the Ctrl key while moving the mouse wheel to get the alternate
(zoom->scroll, scroll->zoom) behaviour.

Note Hold down the Alt key to scroll horizontally instead of vertically.

Select Allow seat assignment with RSVP according to which RSVP statuses
you wish to allow guests to be assigned with. Changing the selection can cause
guests to be unassigned from their seats if their RSVP status is incompatible
with the new setting.

Set User name for stamp to include a user name each time you click on a
Stamp>> button. This can be useful to seeing who made changes to a shared
plan. You can leave it blank.

Set User interface scaling according to how you want to handle display
scaling. This typically affects high resolution displays, such as 4K displays. If
your operating system scaling is set to 100%, then this setting will have no
effect.

· Standard keeps the operating system scaling. E.g. If the display scaling is set

to 150% then the user interface is scaled 150%.

· Round up rounds up the scaling to a whole number. E.g. If the display scaling

is set to 150% then the user interface is scaled 200% (looks bigger).

· Round down rounds down the scaling to a whole number. E.g. If the display

scaling is set to 150% then the user interface is scaled 100% (looks smaller).
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You need to exit and re-start PerfectTablePlan for the change to take effect.

Select Automatically check for software updates depending on how
frequently you wish to check online for updates to PerfectTablePlan.

Set Store these preferences in according to how you wish to store your
preferences. Saving to a .ini file is useful if you want to run PerfectTablePlan
from a portable device, such as a USB drive.

Auto assign

Select in any order if you want the auto seating to assign to tables in any
order. This is recommended if according to guest proximity is checked, to
get the best (highest scoring) seating. Select in the order shown in the
schematic pane to assign guests to tables in the order in which the tables are

displayed in the Schematic pane (top to bottom). 

Select according to guest proximity if you want the auto seating to assign

guests according to the proximities set in the Proximity pane. Select in the
order shown in the Guests pane to assign guests in the order they are listed

in the Guests pane. Select randomly to assign guests to seats completely
randomly (this may be useful for some types of events). 

Check animate in Floor Plan if you want to see the auto seat assignment
animated. Note that this slows down the auto seat assignment a little.

Select decided by PerfectTablePlan to let PerfectTablePlan choose when to
stop the automatic assignment. PerfectTablePlan will try to calculate a good
seating arrangement without taking too much time.

Select seconds if you wish the automatic assignment to stop after the specified
number of seconds. We recommend at least 30 seconds. If you have a lot of
guests, or a very slow PC, you may have to increase this time considerably.

Select generations without improvement if you wish the automatic
assignment to stop after a specified number of generations without improving
the score. We recommend you allow at least 50 generations without
improvement. If you set this number very high, and have a lot of guests or a
very slow PC, the automatic assignment may run for a long time.

Select whichever of the above 2 happens first to stop when either of the
above two criteria is met, e.g. the automatic assignment has run for x seconds
or y generations without an improvement.
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Note You can stop the automatic assignment at any time by pressing the Stop
button or the Esc key. This will keep the best assignment so far.

See automatic assignment for a discussion of automatic assignment times.

Check social distancing if you want the automatic assignment to try not to put
guests from different groups next to each other. Only works if there are more
seats than guests.

Check alternate males and females if you want the automatic assignment to
try to alternate males and females around each table (e.g. M-F-M-F-M-F...).

Select from On narrow tables prefer near to/next to guests seated
depending on whether you prefer to seat guests opposite or left/right of each
other on narrow (e.g. banquet and E-shaped) tables. Seats are considered
opposite if they are less than 2 metres (approx 6 feet) apart and there are the
same number of seats on each side.

Select Prefer next to guests seated depending on whether you want 'next to'
proximity couples with the female to the left or right of the male. This also
affects the order in which groups of guests are placed on tables by drag and
drop.

Proximity

You can set the default proximity for couples, families and groups. This only
applies when the couple, family or group is first created e.g. using
Insert>Guest Couple or during import. Changes here will not affect existing
guest proximities.

Names

Check automatically capitalise new guest names to automatically capitalise
guests titles, first names, last names and suffixes as they are typed (e.g.
convert mr john smith phd automatically to Mr John Smith Phd). This

only works when adding new guests through Insert>Single Guest...,
Insert>Guest Couple... etc, not for editing existing guests. 

Set New table name format according to how you would like new tables to be
named. See below for examples. You can rename the tables at any point using
the Table Properties window.
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Example table name format Example table names

Table {next_table_num} “Table 1”, “Table 2”, “Table 3”

{next_table_num} “1”, “2” , “3”

{next_table_letter} "A", "B", "C"

table “table” , “table”

Use New seat row name format to set the default name for rows of seats.
Similar to above, but using {next_row_num} or {next_row_letter} to

substitute in the number or letter of the next row.

If you change the New table name format or New seat row name format
you will be given the option to update table names for existing tables.

Use Anonymous guest name format to set the name format for anonymous
guests.

Use Default display name format to change the default display name for new
guests. The guest title, first name, first name initials, last name, last name
initials and suffix are substituted into {title}, {first}, {f}, {last}, {l}
and {suffix}, respectively. 

For example:

Default display name format Default display name for Mr John
Smith Phd

{title} {first} {last} {suffix} Mr John Smith Phd

{last}, {title} {first} Smith, Mr John

{last}, {title} {f} Smith, Mr J.
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Advanced and Professional edition only

You can also use custom fields in the Default display name format.

You can use the HTML tags to control how the Display name field appears in

the Floor Plan, Table Plan, Table chart and Guest chart panes.

If you change the Default display name format you will be given the option to
update display names for existing guests.

Use Display group members as to set how group member names are
displayed in the follow situations:

· listing by group in the Table chart or Guest chart panes

· substituting into {group_members} in the Stationery pane

· exporting members (formal) in the Export Data window

Particules is a comma separated list of last name prefixes (e.g. the 'da' in
'Leonardo da Vinci' is a particule). 

· particules are matched regardless of case (e.g. 'da' matches 'da', 'Da' and

'DA')

· particules can be combined (e.g. 'van de' will be recognized as a particule if

'van' and 'de' are listed)

· particules are used to split names into first name and last name when

importing (e.g. to split 'Leonardo da Vinci' into first name = 'Leonardo' and last
name='da Vinci').

· particules are ignored when sorting by last name or group name if ignore

particules when sorting is checked (e.g. 'da Vinci' is sorted as 'V' instead of
'd')

Titles
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Titles that you add here will be available in the guest Title field for all plans.
They will also be used when importing full names to determine which parts of the
name are titles. Titles vary widely between different countries and types of
event. Add titles appropriate to your usage.

Note This is intended for titles that come before the name (e.g. Dr, Herr, Colonel
etc). Titles that come after the name (e.g. PhD, MBE) should be added as
Suffixes. 

You can also specify a default gender, age and VIP status. This is used when
inserting new guests. It is also used when importing to set guest gender, age
and VIP status (if not supplied) from their title.

Click Add to add a new title.

Click Delete to delete the selected title(s).

Click Up to move the selected title(s) up one row.

Click Down to move the selected title(s) down one row.

Click Sort to sort the titles alphabetically.

Click Clear to delete all of the titles in the list.

Click Import from plan to import titles from the current plan into the
preferences.

Click Add text list... to add a list of titles in text form.

Select from Add pre-defined... to add lists of pre-defined titles/ranks.

Set Sort titles in 'Guests' and 'Groups' panes depending on whether you
want titles to be sorted alphabetically or according to the order in this tab (any
titles not listed will be sorted alphabetically, after those listed).

Set Default couple to the titles you wish to use as the default when adding a
couple or family.

Suffixes

Suffixes that you add here will be available in the guest Suffix field for all plans.
They will also be used when importing full names to determine which parts of the
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name are suffixes. Suffixes vary widely between different countries and types of
event. Add suffixes appropriate to your usage.

Click Add to add a new suffix.

Click Delete to delete the selected suffix(es).

Click Up to move the selected suffix(es) up one row.

Click Down to move the selected suffix(es) down one row.

Click Sort to sort the suffixes alphabetically.

Click Clear to delete all of the suffixes in the list.

Click Import from plan to import suffixes from the current plan into the
preferences.

Click Add text list... to add a list of suffixes in text form.

Set Sort suffixes in 'Guests' and 'Groups' panes depending on whether you
want titles to be sorted alphabetically or according to the order in this tab (any
suffixes not listed will be sorted alphabetically, after those listed).

Status bar

You can customize the numbers that appear in the status bar.

Set Numbers displayed to the numbers and associated text you want to
appear. Use the substitution text shown, e.g. {guests} to show the total

number of guests. Substitution text is not case sensitive.

See a preview of what the numbers will look like for the current plan in the
Preview field.

Click Reset to set Numbers displayed back to the default.

Terms

You can change words that appear in the Table Plan pane, Guest Chart

pane and Report pane here. For example, you might want to use the German
"Tisch" instead of the English "Table".
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To change which terms are shown, select from the Show terms for drop-down list.
To change a term just click on the appropriate term in the Change to column and
edit it. To restore all the terms to the default settings click the Reset defaults
button.

Note These changes only affect words inside panes. The user interface is
currently only available in English.

Backups

Check when saved to create a backup file each time you save a plan.

Check on auto assign to create a backup file each time you run an auto
assignment.

Check on export to create a backup file each time you export.

Check on print to create a backup file each time you print.

Check automatically every to create a backup file at the specified time
interval. The plan will only be backed-up if it has been changed during this time.

Set In folder to an existing folder that you want to create the backup files in.

Check at startup check for unsaved changes in backup files if you wish to
check whether backup files may contain unsaved changes at startup.

Warnings

You can turn various warnings on and off here.

Transfer

You can copy your Preference settings from one computer to another using a
.tpp file. This can be useful for transferring PerfectTablePlan to a new computer
or for just storing a set of Preferences.

Click Export Preferences... to export the current preferences to a .tpp file.

Click Import Preferences... to import preferences from a .tpp file.

The following are not exported or imported:
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· Preferences>General>User interface scaling

· Preferences>General>Store these preferences in

· your licence key

Buttons

Click OK to accept the changes. Click Cancel to discard the changes. Changes
to this window affect all plans.

2.1.20.44 Print window

The Print window is displayed when you print the front pane. To display this
window select File>Print or the equivalent Main tool bar button. You can only

print the Floor Plan, Table Plan, Table Chart, Guest Chart, 

Stationery and Report panes. The exact controls visible in the window will
depend on the type of pane being printed.

Change the Size field to change the size of the print out.

Click Fit to page to set the print size to fit on a single page.

Check Centre to centre the print on the page(s).

If you are printing across more than one page the Page control will be
displayed. Click on a page or one of the arrows to change the previewed page.

The page navigation control

Click on the  button to show additional controls.

Change Horizontal fine adjust and Vertical fine adjust to make small
adjustments to the position of the printout on the page. This can be useful to
ensure that multi-page prints are correctly paginated (e.g. a line of text does not
get split by a page boundary).
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Select landscape or portrait to change the orientation of the print out.

The current printer settings. Click the Setup button to select a different printer,
page size or set-up using the Print Setup window. You can also change the
number of pages to be printed through the Setup button, e.g. just print the first
2 pages of 10.

See also:

· Page Setup window

· Print legible plans on a small format printer

· Print to poster size

· Export to PDF format

2.1.20.45 Print Setup window

The Print Setup window allows you to change printer settings. To display the

Print Setup window click the Setup... button in the Print window.

Click on the appropriate printer icon in Select Printer.

Check Print to file if you wish to print to a file, instead of a printer.

Click on the Preferences button to change printer preferences, for example to
change from portrait to landscape. A Printer Preferences window will appear.
The Printer Preferences window will vary with the type of printer.

Set Number of copies to the number of copies you want to print.

Click on the Print button to confirm the change to printer settings or Cancel to
abandon the changes (this button should be named OK, but it is a system
window and we are unable to change it).

See also:

· Print window

· Page Setup window

· Export to PDF format
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2.1.20.46 Quick Add Guests window

The Quick Add Guests window allows to quickly enter guest names in free
text. It is simpler (but less powerful) than importing. To display this window
select Insert>Quick Add Guests or the equivalent Insert tool bar button.

Click on the Titles... and Suffixes... buttons to set-up standard titles and

suffixes in the Preferences window. This will help PerfectTablePlan make
better guesses about how to split names correctly into titles, first names, last
names and suffixes and set gender and age.

Enter the names, one guest/couple/family/group per line and click Next. Some
examples of allowed formats are shown in the window.

The proximities for groups of guests are set according to your Preferences.

Click Back to go back and make corrections to the text.

Click OK to add the guests to your plan.

Click Cancel to discard your changes.

See also:

· Importing

2.1.20.47 Renumber/Rename tables window

Professional edition only

The Renumber/rename table window allows you to quickly rename lots

of tables. To display this window click on the  button in the Floor Plan
pane.

While the Renumber/rename table window is displayed you can
rename tables by just clicking on them. The table will be renamed to the text
in Table name format with Next table number substituted for
{next_table_num} and the alphabetic equivalent of Next table number

substituted for {next_table_letter}. E.g. if Table name format is

Table #{next_table_num} and Next table number is 10 clicking on a
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table will rename it to Table #10. Next table number is incremented by 1

for each click.

Selecting Edit>Undo will undo all the renumbering since the 
Renumber/rename table window was first displayed.

When the window is first opened Next table number is set to 1 and Table
name format is set to the value of New table name format in the

Names tab of the Preferences window. You can reset these values by
clicking the corresponding Reset buttons. 

See also:

· Fast table renumber (video with audio, 0:44 minutes)

· Create a floor plan (video with audio, 10:27 minutes)

· Rename/renumber tables

· Change the seat numbering

2.1.20.48 Replace Text window

Use this window to change 1 or more text properties for guests, groups and

tables. To display this window select Edit>Replace Text....

Professional edition only

You can also replace text in custom fields of type Text or Tags.

Set the Replace drop-down list and text according to what you want to replace:

· Select Part text to replace any part(s) of text that match the Replace text by

the text in With. E.g. 'Mr' matches 'Mr' and the first 2 letters of 'Mrs'.

· Select Whole text to replace text that matches the whole of the Replace text

by the text in With. E.g. 'Mr' matches 'Mr' but not 'Mrs'. 

http://www.screencast.com/t/MTdhOWYzN
https://www.perfecttableplan.com/video/floorplanv7.html
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· Select Empty text to replace empty text by the text in With. Text containing

white space is not considered empty.

Professional edition only

· Select Regex to replace any parts of text that match the Replace regular

expression by the text in With. 

Regular expressions are an esoteric pattern matching language. If you
haven't come across regular expressions before, you can probably ignore
this!

Check case sensitive for case sensitive text matching.

Check the appropriate check boxes for the properties you want to replace text
in.

A preview of any changes is shown. If you mess things up, you can Edit>Undo
the changes after closing the window.

Note that changing guest properties may also update any guest default display
names, depending on Preferences>Names>Default display name format.

See also:

· Edit a property for multiple guests

· Edit a property for multiple tables

2.1.20.49 Save Stationery Layout window

The Save Stationery Layout window allows you to save the layout of
stationery so you can use it again. It appears when you change the stationery

layout in the Stationery Layout window.

Name is the name of the new stationery, e.g. "My address labels".
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Manufacturer is the manufacturer of the stationery, e.g. "Office Depot". You
can type or select from the list.

Type is the type of stationery, e.g. "Tent card". You can type or select from the
list.

You need to supply a Name, Manufacturer and Type before you can save the
layout.

Click OK to save the stationery layout and close the window. You will be
prompted before overwriting an existing layout. Click Cancel to discard any
changes and close the window.

See also:

· Add a new stationery layout

· Load sample stationery

2.1.20.50 Select Gradient window

The Select Gradient window allows you to define a simple linear gradient (a
smooth transition from one colour to another). The window appears when you
edit a gradient or change from a colour to a gradient.

The Preview shows the gradient as currently selected.

The gradient transitions linearly from Colour 1 to Colour 2 in the direction set
by the Direction dial.

Click OK to accept the changes and close the window. Click Cancel to discard
the changes. 

See also:

· Set transparent as colour

2.1.20.51 Select Groups window

The Select Groups window allows you select as many groups as you like. It is

displayed when you set the For drop-down list to Selected... in the Guest

Chart or Stationery panes. 
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Unselected groups are shown in the left list. Selected groups are show in the
right list.

Click Add> to add the group(s) currently selected in the left list to your
selection.

Click Add all>> to add all group(s) to your selection.

Click <Remove to remove the group(s) currently selected in the right list from
your selection.

Click <<Remove all to remove all groups(s) from your selection.

You Ctrl+click and/or Shift+click to select multiple groups. You can also double-
click a group to move it from one list to another.

Click OK to accept the changes and close the window.

Click Cancel to discard the changes.

2.1.20.52 Select Guests window

The Select Guests window allows you select as many guests as you like. It is

displayed when you set the For drop-down list to Selected... in the Guest

Chart or Stationery panes or the For drop-down list in the Export Data
window. 

Unselected guests are shown in the left list. Selected guests are show in the
right list.

Click Add> to add the guest(s) currently selected in the left list to your
selection.

Click Add all>> to add all guest(s) to your selection.

Click <Remove to remove the guest(s) currently selected in the right list from
your selection.

Click <<Remove all to remove all guest(s) from your selection.

You Ctrl+click and/or Shift+click to select multiple guests. You can also double-
click a guest to move it from one list to another.

Click OK to accept the changes and close the window.
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Click Cancel to discard the changes.

2.1.20.53 Select Texture window

The Select Texture window allows you to use textures for tables, chairs,

shapes and the background (floor) in the Floor Plan and Table Plan
panes. Textures can be used to create a more realistic representation of features
such as wooden or tiled floors. 

To display this window either:

· Click on the Fonts and colours window with the Floor Plan or Table

Plan pane at the front. Then select texture from the Table, Seat or Drawing
area drop-down lists.

· Double-click on a table in the Floor Plan and Table Plan pane and select

texture from the Inside drop-down list.

· Double-click on a shape in the Floor Plan pane and select texture from the

Inside drop-down list.

A preview of the currently selected texture is displayed (if any). You can drag
and drop a new image here, e.g. from Windows Explorer or a web browser.

If you have already added images to this plan you can select them from the
Select texture drop-down list.

Click on the Browse... button to select an image file to load. PNG, JPEG and
BMP image file formats are supported.
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Name is the name of the original image file.

Pixels is the size of the texture image in pixels (the preview may be displayed
smaller in this window).

Set the Repeat every fields to how often you want the texture to repeat, e.g.
every 2.00 metres. Note that the texture preview will not change.

Set the Units drop-down list to your preferred units.

Mirror alternate tiles can be useful if you have a non-seamless texture, e.g.
where the top of the texture does not matchless seamlessly with the bottom of
the texture.

Click OK to accept the changes and close the window. Click Cancel to discard
the changes.

The texture is stored inside your plan file, so you can move the plan file to
another computer without losing your image data.

See also:

· Find free textures

2.1.20.54 Shape Properties window

The Shape Properties window allows you to show/edit shape properties. To

display this window select a single shape in the Floor Plan pane and select
Edit>Properties or the equivalent Main tool bar button.

Name is the name of the shape (optional). You can change it to anything you
like.

Click the Name colour button to set the colour for the shape name text.

Change the Shape drop-down list to change the shape.

Set Angle to the rotation angle of the shape.

Use the Inside colour drop-down list and colour button to set a colour, gradient
or texture for the inside of the shape.

Use the Edge colour button to set a colour for the outside of the shape.
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Set the Size field(s) to the dimensions of the shape.

Set the Units drop-down list to your preferred units.

Notes can be used to store any relevant notes for the shape. Click on Stamp
>> to add a time and date stamped comment to the top of the Notes.

Click OK to accept the changes and close the window. Click Apply to apply the
changes without closing the window. Click Cancel to discard the changes.

See also:

· Set transparent as colour

2.1.20.55 Show Guest Details window

Professional edition only

The Show Guest Details window allows you to select which guest

properties to display in the Check-In Guests window. To display this
window:

1. Select File>Check-In Guests... .

2. Check show guest details.

3. Select Selected... from the adjacent drop-down list

Click OK to accept the changes and close the window. Click Cancel to
discard the changes.

See also:

· Checking-in guests 

· Check-in guests tutorial
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2.1.20.56 Shuffle Seats window

Use this window to move 1 or more selected guests 1 or more seats clockwise
or anti-clockwise on the same table. This is different to rotating the table
because guests change seats, but the table and seats are not changed. To
display this window select Edit>Shuffle Seats....

Set seats(s) to the number of seats you want to move the selected guests.

Set Clockwise/Anti-Clockwise to the direction you want to move them.

For example shuffling guests A, B, D and H by 2 seats clockwise:

Will have the following end result:
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Advanced and Professional editions only

The shuffle function can be very useful when you have resized an E-shaped
table.
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Locked seats are ignored (flowed around) when calculating the seat shuffled to.

If you want to select a number of seats to shuffle, but not a whole table:
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· Left-click and drag a 'rubber box' in the Floor Plan pane to select the seats.

· Use Ctrl+Click to unselect any seats or tables you didn't intend to select.

If shuffling seats is slow, trying hiding the legend in the Table Plan pane.

Hint You can also use keyboard accelerators Ctrl+} and Ctrl+{ to shuffle
selected guests 1 seat clockwise or anti-clockwise.

2.1.20.57 Split Columns window

The Split Columns window allows you to split columns of data in the 
Import Data window. This can be very useful for modifying input data into an
appropriate format to import into PerfectTablePlan. To display this window click

on the Split column(s)... button in the Import Data window (you may need

to click the  button to make the Split columns.. button visible).

Set the separator to the text you wish to split the column(s) at.

Select every to split at every occurrence of the separator token and the first to
only split at the first occurrence.

Click OK to split the column(s) and close the window.

Click Cancel to discard the changes.

Splitting creates new columns to the right of the column(s) being split. The new
columns are selected. The original column(s) is/are not changed. 

For example "John Smith, CEO, Smith industries - UK" could be split into
columns as follows:

Separator Occurrence New columns

, every "John Smith" "CEO" "Smith industries -
UK"

, first "John Smith" "CEO, Smith industries -
UK"
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- every "John Smith, CEO, Smith industries"
"UK"

You can carry out as many split and join operations as you need to get your
data into appropriate columns.

See also:

· Edit guest list data during import (video with audio, 1:16 minutes)

· Join Columns window

2.1.20.58 Stationery Layout window

The Stationery Layout window allows you to change the size of a page and

the items on the page. To display this window click the Stationery layout

button in the  Stationery pane.

The Preview tab shows the shape of the page and the size and position of the
stationery items.

The Nomenclature tab shows the meaning of the dimension fields in this
window (shown a bit larger below).

https://www.screencast.com/t/wNAWDGOug
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Change Units to change between mm and inches.

Click on a Pre-defined stationery type to set the layout accordingly. Type a text

into the Search field to hide non-matching stationery types, e.g. type J8161
to find Avery J8161 address labels. Use the Manufacturers, Types and Paper
sizes drop-down lists to filter which pre-defined stationery are listed. 

Change the Orientation between Portrait and Landscape, depending on how
you wish to print the stationery.

Click Centre items to centre the items in the page (i.e. Left margin to Right
margin and Top margin to Bottom margin).

If you create your own layout you will be prompted to save it by the Save
Stationery Layout window.

Note Right margin and Bottom margin are set automatically based on the
other dimensions.

Click OK to accept the changes and close the window. Click Cancel to discard
any changes and close the window.

See also:
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· Create place cards and other stationery (video with audio, 10:08 minutes)

· Add a new stationery layout

· Load sample stationery

· Print stationery on blank sheets

· Print stationery on press-out sheets

2.1.20.59 Table Layout window

Professional edition only

The Table Layout window allows you quickly layout large numbers of
tables in a wide range of different layouts and orderings. To display this

window click the  button at the top of the Floor Plan pane. You need to
select at least 2 tables and not have the Freeze floor plan box checked for
this button to be enabled.

Grid allows you to set the size and alignment of the grid.

Aligned grid

Offset grid

https://www.perfecttableplan.com/video/stationeryv7.html


235

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

Spacing allows you to set the horizontal and vertical distance between table

centres. If Snap to grid is set on (in the Dimensions window) then you
can only set the spacing in multiples of the snap grid.

Ordering allows you to specify in what order the tables are laid out: left to
right/right to left, top to bottom/bottom to top, horizontally/vertically,
typewriter/snake.

Horizontally/Typewriter Horizontally/Snake
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Vertically/Typewriter Vertically/Snake

Click the Table Order... button to change the order in which the tables are

laid out in the Table Order window. Note that this will also affect ordering

in other panes, e.g. the Table Chart pane.

Preview shows you what the new table layout will look like. Check show
table order to easily see the layout order of the tables.

Click OK to accept the changes. Click Cancel to discard the changes.

You can drag the selected tables to any position in the floor plan after you
close this window.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Dimensions window

· Table Order window

· Space tables correctly

· Edit a property for multiple tables

2.1.20.60 Table Order window

The Table Order window allows you to change the order of tables, as they

are displayed in the Table Chart pane and Schematic pane. To display this

window click the Table order... button at the top of the Table Chart or  
Schematic pane panes.

Select a table and use the Top,  Up,  Down and Bottom buttons to
change its order.

https://www.perfecttableplan.com/video/stationeryv7.html
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Click on the Sort button to order tables. The sort is basically alphabetic, but it
will try to intelligently handle numbers and mixes of numbers and letters. E.g. to
sort "Table 10" after "Table 2". The sort is not case sensitive.

Note You can also change the table order in the Schematic pane by dragging
and dropping tables or by using the buttons at the top of the pane.

See also:

· Change the table order

2.1.20.61 Table Properties window

The Table Properties window allows you to show/edit table properties. To

display this window select a single table in the Floor Plan , Table Plan or

Schematic panes and select Edit>Properties or the equivalent Main tool
bar button.

Name is the name of the table. You an change this to anything you like. The
name doesn't have to be unique and can be blank. 

Set Angle to the desired angle of the table in the Floor Plan and Table
Plan panes.

Select solid, gradient or texture to choose the colour, gradient or texture of

the table in the Floor Plan and Table Plan panes. This overrides any table

colour set for the pane in the Fonts and colours window. Click Default to
set the table colour back to the default.

Shape is the shape of the table. The available shapes of table are:

Table Icon Meaning

E-shaped a head (top) table + 2 or
more sprigs (legs)
(Advanced and
Professional editions
only)
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Rectangular a rectangular or square
table with seats on four
sides

Banquet a long table with seats
on two sides

Head a long table with seats
on only one side, for
example a head (top)
table at a wedding or
banquet

Custom a rectangular or square
table with potentially
different numbers of
seats on each of the 4
sides

can have rounded ends

Circular a circular table with
seats all around it

Semi-circular a semi-circular table with
seats around the straight
side and/or curved sides

Oval an elliptical table with
seats all around it

Serpentine a 180 degree curved
table (Advanced and
Professional editions
only)

Half Serpentine a 90 degree curved table
(Advanced and
Professional editions
only)
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Row of seats a row of seats (no
table), can be curved

Seats is the number of seats. For a circular or head table you specify the total
number of seats. For a banquet table you specify the number of seats across.
For a rectangular table you specify the number of seats across and the number
of seats down. For a custom or serpentine table you specify the number of seats
on each of the 4 sides.

Note For a square table create a rectangular table and set the number of seats
across and down the same. You can specify a table with no seats for a cake,

gift or serving table - it will not be shown in the Table Chart pane.

Advanced and Professional editions only

You can change the seat numbering:

· If you set Seat numbers to sequential you can change the number of

the first seat and whether the seats are ordered clockwise or anti-
clockwise.

· If you set Seat numbers to custom... you can change them to anything

you like (including letters or names) in the Custom seat numbering
window.

For E-shaped tables you can check the by section check box to number
each table section separately, start from 1.

Set the Display drop-down to Seat number at the top of the Floor Plan

or Table Plan panes to see seat numbers in these panes.

Size is the size of the table. Check the auto check box to automatically size the

table according to the number of seats and the seat size (as set in the 
Dimensions window). Uncheck the auto check box to set your own table size.

Note The automatic table size is calculated to avoid gaps and overlaps between
seats, partly on aesthetic grounds. Click here to find out about 'industry
standard' table sizes.

https://www.perfecttableplan.com/html/table_size__shape_and_layout.html
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If you have a circular table bigger than the auto size you can uncheck space
seats evenly to group all the seats together. This is useful for 'sweetheart' or
'cabaret' style seating.

VIP is used to designate tables for VIPs to sit at. The automatic assignment will
attempt to seat VIPs on VIP tables.

Advanced and Professional editions only

An E-shaped table is a single table composed of a horizontal section (the top
or head) plus between 2 and 9 vertical sections (the sprigs or legs). Each
section has its own size, number of seats, name and VIP status. Click on the
Sections... button to configure the sections in the Table Section
Properties window.

Notes can be used to store any relevant notes for the table, e.g. details of table
decorations. Click on Stamp >> to add a time and date stamped comment to
the top of the Notes.

Click on the     buttons to display the properties of the first, previous,
next or last table. The tables are ordered in the same sequence as they are in

the Schematic pane.

Click OK to accept the changes and close the window. Click Apply to apply the
changes without closing the window. Click Cancel to discard the changes.
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See also:

· Add/remove a single seat to/from a table

· Change the seat numbering

· Create rectangular tables with seats on 1,2 or 3 sides

· Create an E-shaped table

· Create a horseshoe shaped table

· Create sweetheart/cabaret style tables

· Edit a property for multiple tables

· Set transparent as colour

2.1.20.62 Table Section Properties Window

Advanced and Professional editions only

The Table Section Properties window allows you to configure the sections
of an E-shaped table. To display this window click the Sections... button on
the Table Properties window for an E-shaped table.

An E-shaped table has 1 horizontal ('top' or 'head') section and between 2
and 25 vertical ('sprig' or 'leg') sections. Use the Configuration field to set
the number of sprigs.

Uncheck the all sections left-right symmetrical box if you want to put
different numbers of seats on the left and right side of any section.

Units are the units set in the Table Properties window.
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The first section listed is always the top section. The remaining sections are
the sprigs, from left to right. Each section has the following properties:

· Name: The section name. Can be left blank.

· Seats across: The number of seats horizontally. For the top section the

seats are at the top, for the sprig sections the seats are at the bottom.

· Seats down (all sections left-right symmetrical checked): The

number of seats vertically on each side.

· Seats down left (all sections left-right symmetrical unchecked): The

number of seats vertically on the left side.

· Seats down right (all sections left-right symmetrical unchecked):

The number of seats vertically on the right side.

· Auto size: Check to set the size of the section automatically.
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· Size across: The size of the section horizontally in Units. Uncheck Auto

size to set this manually.

· Size down: The size of the section vertically in Units. Uncheck Auto size

to set this manually.

· VIP: Check if you want the automatic seat assignment to seat VIP guests

preferentially in this section.

Click Add to add a new section.

Click Delete to delete the selected section.

Click Up to move the selected section up one row.

Click Down to move the selected section down one row.

Preview shows what the table will look like.

Total size is the size of the bounding rectangle containing the table (but not
the chairs) in Units.

Total seats is the total number of seats for the table.

See also:

· Create an E-shaped table

2.1.20.63 Text Properties window

The Text Properties window allows you to show/edit text properties. To

display this window select a single text item in the Floor Plan pane and select
Edit>Properties or the equivalent Main tool bar button.

Text is the content of the text.

Set Angle to the rotation angle of the text.

Click the Font... button to set the font for the text.

Use the Colour button to set a colour for the text.
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Click OK to accept the changes and close the window. Click Apply to apply the
changes without closing the window. Click Cancel to discard the changes.

See also:

· Add a title or text into the floor plan

2.1.20.64 Visualization Colours window

When you use colours to visualize gender, meal, group and custom fields in the 

Floor Plan and Table Plan panes, PerfectTablePlan selects the colours

automatically using 12 default colours. The Visualization colours window
allows you to change these colours. E.g. you can change the colour used to
display a vegetarian meal to green.

To display this window in the  Floor Plan or Table Plan pane:

1. Click the  button at the top of the pane.

2. Click the Visualization... button in the Fonts and Colours window.

To display this window in the Stationery pane:

3. Click on a colour code spot in the Design tab.

4. Click the Colours... button that appears at the bottom of the pane.

Set Field to the name of the field whose colours you wish to change.

Set Colours per value depending on the number of colours you wish to use to
represent a value. 2 colour schemes can be useful if you are trying to distinguish
between lots of different values. E.g. if you have 100 groups, it is hard to choose
100 visually distinct colours. 2 colour schemes are only available for Groups
and custom fields of type Selection. 

Click on a colour button to edit the colour.

Click Set colours automatically to automatically set the colours. This is
particularly useful if you change from a 1 colour scheme to a 2 colour scheme.

Click OK to accept the changes and close the window. Click Apply to apply the
changes without closing the window. Click Cancel to discard the changes and
close the window.
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Note Changes to the colours only affect the current plan. If you wish to use
these colours in other plans you will need to create a re-usable template plan.

See also:

· Changing visualization colours (video with audio, 1:20 minutes)

· Show custom fields

· Show gender

· Show groups

· Show meals

2.1.21 Drag and drop

The following drag and drop operations are supported:

Item Modifier key From To Result

 group(s) or

guest(s)

none Guests

pane, 
Groups pane,

Schematic

pane, Floor
Plan pane or

Table Plan
pane

seat, table or
background in

Floor Plan

pane, Table
Plan pane or

Schematic
pane

guest(s) (re)
assigned/unas
signed

 guest(s) Shift Guests

pane, 
Groups pane,

Schematic

pane, Floor
Plan pane or

Table Plan
pane

seat, table or
background in

Floor Plan

pane, Table

Plan pane or 
Schematic
pane

all members of
group(s) (re)
assigned/unas
signed

 group(s) or

guest(s)

none Groups
pane

Groups
pane

group
membership

http://www.screencast.com/t/MddBzk7Q0
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changed

background none Floor Plan

pane or 
Table Plan
pane

different
position (right
mouse button)

scrolls

 table none Floor Plan
pane

Floor Plan
pane

table moved

 table none Schematic
pane

Schematic
pane

table order
changed

 plan (.tp)
file

none operating
system

Guests

pane, 
Groups pane,

Schematic

pane, Floor

Plan pane, 
Table Plan

pane, Table

Chart pane, 
Guest Chart

pane or 
Report pane

open plan

 vCard (.vcf)
file

none operating
system

Guests

pane, 
Groups pane,

Schematic

pane, Floor

Plan pane, 
Table Plan

pane, Table

Chart pane, 
Guest Chart

pane or 
Report pane

import vCard
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Excel/CSV/text
file

none operating
system

Guests

pane, 
Groups pane,

Schematic

pane, Floor

Plan pane, 
Table Plan

pane, Table

Chart pane, 
Guest Chart

pane or 
Report pane

import
Excel/text/CS
V file

 image file none operating
system or web
browser

Floor Plan
pane

import image

 group(s) or

 guest(s)

none Guests

pane, 
Groups pane,

Schematic

pane, Floor
Plan pane or

Table Plan
pane

operating
system or
other
application

export vCard

2.1.22 Keyboard accelerators

Using keyboard accelerators can greatly improve your productivity. If you are
using PerfectTablePlan a lot we suggest you find the time to learn at least some
of them. The following keyboard accelerators are available for the Windows
version of PerfectTablePlan:

Key Accelerator Action

1 Ctrl+1 Add guests task

2 Ctrl+2 Proximity task
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3 Ctrl+3 Add tables task

4 Ctrl+4 Assign seats task

5 Ctrl+5 Print task

A Ctrl+A Select all (but not hidden items)

B Ctrl+B Numbers and Budget 

C Ctrl+C Copy

Alt+C Collapse all in Groups pane or 
Schematic pane

D Ctrl+D Show selected in Floor Plan pane

Ctrl+Alt+D Show selected in Table Plan pane

Ctrl+Alt+Shift+
D

Show selected in Schematic plan pane

Ctrl+Shift+D Show selected in Guests plan pane

Alt+Shift+D Show selected in Groups plan pane

E Ctrl+E Export

F Ctrl+F Find in Guests, Groups, Floor plan,

Schematic or Proximity pane

G Ctrl+G Insert single guest

Ctrl+Alt+G Insert guest couple

Ctrl+Shift+G Insert guest family
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Ctrl+Alt+Shift+
G

Insert guest group

H Ctrl+H Insert E-shaped table

Ctrl+Alt+H Insert half serpentine table

Ctrl+Shift+H Insert serpentine table

I Ctrl+I Import

Ctrl+Shift+I Event Information 

J Ctrl+J Quick insert guests 

K Ctrl+K Lock selected guests

Shift+Ctrl+K Unlock selected guests

L Ctrl+L Auto Assign Seats

M Ctrl+Shift+M Insert custom table

N Ctrl+N New plan

O Ctrl+O Open plan

Ctrl+Shift+O Open Recent

P Ctrl+P Print

R Ctrl+R Insert rectangular table

Ctrl+Alt+R Insert banquet table

Ctrl+Shift+R Insert head table
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S Ctrl+S Save plan

Ctrl+Shift+S Save plan as

T Ctrl+T Insert circular table

Ctrl+Alt+T Insert semi-circular table

Ctrl+Shift+T Insert oval table

Ctrl+Alt+Shift+
T

Insert row of seats

U Ctrl+U Unassign guest

V Ctrl+V Paste

W Ctrl+W Close window

X Ctrl+X Cut

Alt+X Expand all in Groups pane or 
Schematic pane

Y Ctrl+Y Redo

Z Ctrl+Z Undo

F1 F1 Context sensitive help

F4 Ctrl+F4 Close window

Alt+F4 Close window

F5 F5 Refresh
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F12 Ctrl+F12 Credits

Alt Alt Move focus to menu bar

Plus/Minus Ctrl++/Ctrl+- Zoom in/zoom out

Asterisk Ctrl+* RSVP declined

Back slash Ctrl+\ RSVP unset

Backspace Backspace Delete

Bracket Ctrl+[/Ctrl+] Previous/next table, guest, group in the 

Floor Plan pane, Table Plan pane, 
Proximity pane, Table Properties window,
Guest Properties window or Group
Properties window

Ctrl+{/Ctrl+} Shuffle the selected guests 1 seat anti-
clockwise/clockwise

Comma Ctrl+, Preferences

Del Del Delete

Escape Escape Close window

Forward slash Ctrl+/ RSVP accepted

Home/End Home/End Start/end of line

Left/Right Left arrow/Right
arrow

Move selected items in Floor Plan pane.
Moves 1 grid position if grid snap on.
Otherwise moves 5 cm / 2 inches per key
press.
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Shift-Left
arrow/Shift-
Right arrow

Move selected items in Floor Plan pane.
Moves 1 grid position if grid snap on.
Otherwise moves 1 cm / 0.4 inch per key
press.

Alt+Left
arrow/Alt+Right
arrow

Select next/previous table in Floor Plan

or Table Plan pane

Menu Menu Show context menu

Period (Full
stop)

Ctrl+. Globally add/remove "." from titles e.g. "Mr"
<-> "Mr."

Ctrl+Shift+. Rotate selected item 45 degrees clockwise in

Floor Plan 

Semi-colon Ctrl+; Add an extra seat in the position of the
selected seat(s)

Space Alt+Space Window menu

Space Toggle current checkbox/press  current
button

Tab Tab/Shift-Tab Next/previous field

Ctrl+Tab/Ctrl+
Shift+Tab

Next/previous tab

Up/Down Up arrow/Down
arrow

Move selected items in Floor Plan pane.
Moves 1 grid position if grid snap on.
Otherwise moves 5 cm / 2 inches per key
press.
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Shift+Up
arrow/Shift+Do
wn arrow

Move selected items in Floor Plan pane.
Moves 1 grid position if grid snap on.
Otherwise moves 1 cm / 0.4 inch per key
press.

Alt+Up
arrow/Alt+Dow
n arrow

Select next/previous seat in Floor Plan or

Table Plan pane

You can also use keyboard menu accelerators. For example you can access
File>Open without using the mouse by typing Alt+F+O.

2.1.23 Gestures

If your device supports gestures, you can 'pinch' to zoom in the Floor Plan

and Table Plan panes.

2.2 Importing

2.2.1 Importing

If you already have guest details (for example in an email or organizer address
book, spreadsheet or text file) you can import the data directly into
PerfectTablePlan, rather than re-typing it.

PerfectTablePlan can import information in 4 major formats:

· Excel™ .xls/.xlsx - Excel's proprietary format.

· CSV (Comma Separated Value ) - A text file that can be produced by Excel

(select File>Save As and choose .csv as the file type) and many other types
of applications. Columns and rows are delimited by commas and carriage
returns, respectively. " and , characters are quoted.

· Delimited text data - A text file with the user's choice of delimiters

(separators). Many applications can produce data in this form. CSV is a special
form of delimited text data.

· vCard file - vCard files be exported from most applications with address

books, including Outlook, Palm Pilot desktop and the Apple Mac Address Book.

As a simpler (but less flexible) alternative to importing you can also use the 
Quick Add Guests  window.
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See also:

· Import your guest list (video with audio, 11:59 minutes)

· Import window

· Importing guests from Excel files

· Importing guests from text and CSV files

· Importing guests from vCard files

· Import guests tutorial

· Example import formats

· Merge import

2.2.2 Importing guests from Excel files

PerfectTablePlan can import guest and group information directly from Excel™
.xls/.xlsx files.

To import an Excel file either:

· drag the file onto the Guests pane or Groups pane; or

· select File>Import, choose Excel/CSV/text file, click OK and select a .xls/

.xlsx file to import

The Import Data window will appear. For more information see Import
Data window and the Import guests tutorial.

See also:

· Import your guest list (video with audio, 11:59 minutes)

· Example import formats

· Import guests in couples/families/groups

· Import proximity data

https://www.perfecttableplan.com/video/importv7.html
https://www.perfecttableplan.com/video/importv7.html
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· Import seating data

· Importing guests from text and CSV files

· Import guest details from Outlook

· Import guest details from Outlook Express

· Quick Add Guests window

2.2.3 Importing guests from text and CSV files

Many types of applications can export data as text files, for example Excel can
export CSV (comma separated value) files. PerfectTablePlan can import guest
and group information from these files.

To import a text/CSV file either:

· drag the file onto the Guests pane or Groups pane; or

· select File>Import, choose Excel/CSV/text file, click OK and select a file

to import

The Import Data window will appear. For more information see Import
Data window and the Import guests tutorial.

See also:

· Import your guest list (video with audio, 11:59 minutes)

· Example import formats

· Import guests in couples/families/groups

· Import proximity data

· Import seating data

· Importing guests from Excel files

· Import guest details from Outlook

· Import guest details from Outlook Express

https://www.perfecttableplan.com/video/importv7.html
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· Quick Add Guests window

· Import guests tutorial

2.2.4 Importing guests from vCard files

PerfectTablePlan can import guest information from vCard files. Many types of
applications can export contact information in vCard format, including personal
organizers and email packages such as Outlook and OutlookExpress.

To import guest information from a vCard file:

· drag the vCard(s) files (extension .vcf) onto the Guests pane or Groups

pane; or

· select File>Import, choose vCard file and click OK. Select the vCard file to

import and click Open

In some applications you can even drag vCards direct from the application into

the Guests or Groups pane.

PerfectTablePlan will attempt to preserve groups defined in the vCard. Guests in
the same group will have their proximity set to 'near to'.

To change the group and proximity of imported guests:

1. bring the Groups pane to the front

2. drag and drop couples/families/groups into the same group (you can rename
the group if required)

3. right-click on each group and set the appropriate proximity

4. delete the empty groups

PerfectTablePlan has been tested with vCard version 2.1, 3.0 and 4.0 formats. It
expects version 2.1 vCards to be encoded in ASCII and version 3.0 or 4.0
vCards to be encoded in UTF-8.

See also:

· Importing guests from Excel files

· Importing guests from text and CSV files
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2.2.5 Example import formats

Spreadsheets and CSV files can be supplied with guest data organized into
columns in a multitude of different ways. Below we give examples of some of the
more common formats and how to deal with them. We recommend setting up

common titles and suffixes in the Preferences window before importing.

A single guest name per row in a single column

If you have commas, the word "and" or other things that might be interpreted as

there being more than one name in a column, then you should click on the 
button and check single guest per cell.

If you want to import multiple guests per group you should add a group column.

A single guest name per row in multiple columns

If you have commas, the word "and" or other things that might be interpreted as

there being more than one name in a column, then you should click on the 
button and check single guest per cell.

If you want to import multiple guests per group you should add a group column.

Multiple guest names per row in a single column
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 Various naming formats are handled, including:

Mr & Mrs John Smith
John Smith, Jane Smith
John and Jane Smith
Mr John Smith + 1

The guests will all be placed into a single group.

Multiple guest names per row in multiple columns

The guests will all be placed into a single group.

Column for number of additional guests

The guests will all be placed into a single group.

Column for number of total guests
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The guests will all be placed into a single group.

If you get stuck on importing, contact support.

See also:

· Import your guest list (video with audio, 11:59 minutes)

· Import guests tutorial

· Import Data window

· Import guests in couples/families/groups

· Import proximity data

· Import seating data

· Joining and splitting columns

2.2.6 Merge import

Professional edition only

If guest information changes outside of PerfectTablePlan (for example in a
CRM or event registration system) you can merge these changes into your
current plan in various ways, rather than creating duplicate guest records.

Set New guests to:

· Import if you want to import guests that aren't already in the plan.

https://www.perfecttableplan.com/video/importv7.html
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· Don't import if you want to ignore imported guests that aren't already in

the plan.

Set Existing guests re-imported to:

· Import as updates (merge) to merge guest records with matching

guests already in the plan.

· Import as duplicates to create new guest records for every imported

guest.

· Don't import to ignore guest records with matching guests already in the

plan.

Set Existing guests not re-imported to:

· Keep if you want to keep guests that are already in the plan, but not re-

imported.

· Delete if you want to delete guests that are already in the plan, but not

re-imported.

If you import into a plan with existing guests, guests and groups are colour
coded:

· Pink: Newly imported guests.

· Purple: Existing guests that are being re-imported.

· Blue: Existing guests that are not being re-imported.
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Matching between existing and imported guests can be by either:

· unique guest ID, matching that previously imported; or

· guest first name + last name (case insensitive)

If you don't import an ID column, then the first name + last name will be
used. Unique guest Ids are preferred, as it allows you to merge changes in
guest names and also handles guests with duplicate names (you might
legitimately have two guests with the same name).
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It is recommended to import a Group column, to control how guests are
merged into new and existing groups.

During merge import, any imported values will overwrite previous values.
Existing proximity values that are not overridden are kept. You should delete
all proximities before import if you want to import proximities from scratch.

Guest fields that will be updated from a merge import are shown in a darker
purple. Hover over the field to see what the change is. E.g. if Andrew Adams
has meal ‘beef’ and then Andrew Adams is re-imported with meal ‘fish’, then
the existing Andrew Adams guest will have their meal value updated from
‘beef’ to ‘fish’. This will be shown with a darker colour and a tooltip.

Guests that will be deleted after the import is complete, e.g. due to setting
New Guests to Don’t import, are shown with strikeout text.
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2.3 Names and titles

2.3.1 Names and titles

Title is the part of the guest's title (e.g. Mr) or rank (e.g. Captain) that comes

before their name. 

First name(s) is the guest's first (given) name(s). You can also record middle
names or initials, if you wish.

Last name(s) is the guest's last (family) name(s). If the last name contains
particules (e.g. the 'da' in 'da Vinci') these can be specially handled. 

Suffix can be used for anything that appears after the guest's name, such as a:
job title (e.g. 'Director of sales'), role (e.g. 'Master of ceremonies'), qualification
(e.g. 'BSc') or post-nominal title (e.g. 'OBE').

You can configure titles and suffixes in the Preferences window - this can be
particularly useful for military ranks, Masonic titles etc.

If you don't know the name of your guest you can check the Anon check box. If
you find out their name later just uncheck the box.

Note The Title, First name, Last name and Suffix will be automatically
capitalised (e.g. mr john smith converted to Mr John Smith) if you are

adding guests via the Insert menu and have checked automatically capitalise

new guest names in the Names tab of the Preferences window.

Display name is the name in the format you want to display it, e.g. Mr John
Smith Phd, Master of Ceremonies. PerfectTablePlan sets a default display

name from the Title, First name, Last name and Suffix (according to the

Default display name format field in the Names tab of the Preferences
window), but you can override this for each guest. 

You can use HTML tags to control the appearance of the guest Display name
field. For example:

John <b>Smith</b><br><small><i>Director</i></small>
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See also:

· Adding and removing dots at the end of titles

· Customize standard guest titles

· Handle post-nominal titles

· Use particules in names

· Turn on/off guest name capitalisation

2.4 HTML tags

2.4.1 HTML tags

You can use the following HTML tags to control how the guest Display name

field appears in the Floor Plan, Table Plan, Table chart and Guest
chart panes:

HTML tag Syntax

Line break <br>

Bold <b>...</b>

Italic <i>...</i>

Big <big>...</big>

Small <small>...</small>

Only the <br> tag is taken account of in the Stationery pane.

For example:
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Is shown in the Floor Plan pane as:

2.5 Groups

2.5.1 Groups

Every guest belongs to a group, even if they are the only member of the group,
and each group has a single set of contact details. We therefore recommend
that guests are grouped according to their address, e.g. by family or work-
place. 
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You can easily reassign guests between groups by dragging them to another

group in the Groups pane or using Edit>Change Group....

You can drag a whole group to the Floor Plan, Table Plan or Schematic
panes by either:

· dragging a group from the Groups pane; or

· holding down the Shift key and dragging any guest from that group from the

Guests, Groups, Floor Plan, Table Plan or Schematic panes

Whether guests should sit together is determined by the proximities set in the 
Proximity pane and not by group. This gives you the flexibility to use the
automatic assignment to separate members of a group (e.g. if you don't want to
sit couples and work colleagues next to each other). However couples, families

and groups are set to sit next to or near to each other by default.

You can easily see where different members of a group are seated by clicking on

the Groups button in the Floor Plan pane.

Different groups are shown in different colour combinations. You can change the

colours used in the Visualization colours window.

See also:

· Import guests in couples/families/groups
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· Change the order of guests in a group

· Move guests from one group to another

· Organize guests by company/organization

2.6 RSVP status

2.6.1 RSVP status

RSVP stands for "Répondez s'il vous plaît", French for "Respond please".
PerfectTablePlan allows you to track the RSVP status for each guest.

RSVP status Description

Unset No RSVP status has been
set.

Sent An invitation has been
sent and a reply is
awaited.

Accepted The guest has accepted
their invitation and will
attend.

Declined The guest has declined
their invitation and will
not attend.

Cancelled The guest originally
accepted and later
declined.

Arrived The guest has arrived at
the event.
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RSVP workflow

You can (re)set the RSVP status in a number of ways, including selecting one or

more guests or groups in the Guests or Groups pane and selecting
Edit>Guest Property>RSVP.

Whether you can assign a guest to a seat depends on their RSVP status and the

settings in the Preferences window.

You can show the RSVP status of guests in most panes, for example by clicking

on the  button at the top of the Floor Plan pane.

You can see a summary of the RSVPs in the Report pane or Dashboard pane.

You can estimate guest numbers and budget from RSVP status in the 
Numbers and Budget window.

See also:

· Edit a property for multiple guests

2.7 Meal selection

2.7.1 Meal selection

You can record guest meal selections in the Meal field of the Guest
properties window. You can either select an existing meal choice from the
drop-down list or type a new meal choice.

If you have multiple courses you can separate them by commas.
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The drop-down list is created automatically from all the meal choices in the
current plan and you cannot edit it directly. 

If guests  have allergies or other special dietary requirements you can record
this in the Special requirements field.

Meal selection can be displayed in the Floor Plan, Table Plan, Table

Chart, Guest Chart, Stationery and Report panes. You can change the

colours used in the Visualization colours window.

Displaying meal selection using colour coding in the Floor Plan pane

Displaying meal selection as text in the Floor Plan pane
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Advanced and Professional editions only

Displaying the meal as part of custom naming in the Floor Plan pane
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Displaying meal selection in the Table Plan pane (you can also click the Meal icon or select Meal
from the Display drop-down list)
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Displaying meal selection in the Guest Chart pane

Displaying meal selection in the Stationery pane

You can add coloured spots representing meal choices to place cards and other
stationery.
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Summarising meal selections in the Report pane

Professional edition only

You can report meal by table, group or other property in the Report pane.

Summarising meal selections by table in the Report pane

See also:

· Edit a property for multiple guests

2.8 Special requirements

2.8.1 Special requirements

You can record guest special requirements, such as food allergies or mobility

restrictions, in the Special Req. field of the Guest properties window. You
can either select an existing special requirement from the drop-down list or type
a new special requirement.

The drop-down list is created automatically from all the special requirements in
the current plan and you cannot edit it directly. 

Special requirements can be displayed in the Floor Plan, Table Plan, 

Table Chart, Guest Chart, Stationery and Report panes. 
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Displaying special requirements using icons in the Floor Plan pane

Displaying special requirements as text in the Floor Plan pane
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Displaying special requirements in the Stationery pane

Professional edition only

You can report special requirements by table, group or other property in the

Report pane.
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Summarising special requirements by table in the Report pane

See also:

· Edit a property for multiple guests

2.9 Custom fields

2.9.1 Custom fields

Advanced and Professional editions only

PerfectTablePlan comes with a number of standard fields: First name(s),
Last name(s), RSVP, meal choice etc. You can also add custom field
appropriate to your type of event.  For example you can add properties to
define: which organization a guest belongs to, which languages they speak
and how much they have paid for their ticket. 

There are 6 types of custom field:
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Field type Allowed values Example usage

Yes/No Yes or No. Is table sponsor

Text Any text. Job title

Number Any whole number
(integer).

Bottles of wine ordered

Currency Any floating point
number. Accurate to two
decimal places.

Amount owing

Selection One of a comma
separated list of items.

Employer

Tags 0, 1 or many comma
separated items.

Languages spoken

For example you might create a:

· Selection custom field called "affiliation" with values "wedding party",

"bride's family", "groom's family", "bride's friends", "groom's friends" and
"other". Each guest can then be categorised by their affiliation into exactly
one of the allowed values.

· Tags custom field called "languages spoken". For each guest you can then

list 0, 1 or many languages they speak separated by commas, e.g.:
"English", "English,Spanish" or "English,French,Spanish".

Select Edit>Custom fields... to change the custom fields in the Custom
fields window.

Custom fields affect PerfectTablePlan in the following ways:

Guests pane and Groups pane
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An additional column appears for each custom field. You can show/hide

these fields by clicking on the  button and checking/unchecking the
appropriate box.

Import window

Values can be imported into custom fields. Any £, $ or € characters will be
stripped from currency values during importing. You can create custom
fields during import by selecting <custom field> from the drop-down menu
at the top of an import column.

Floor Plan pane

Visualization buttons are added for each custom field of type Yes/No, Tags
and Selection. If you click one of these buttons the guests will be coloured
appropriately. For Tags types a separate colour band is shown for each
value. For Selection types you can use combinations of 2 colours. You can

change the colours used in the Visualization colours window.

A custom field property can be displayed instead of the guest name by
selecting the custom field from the Display drop-down list.

Custom field values are shown when you hover over a guest.
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Table Plan pane

Similar to the Floor Plan pane, but custom fields can also be shown in
the legend text by checking the appropriate box. You can show/hide these

fields by clicking on the  button and checking/unchecking the appropriate
box.

Table Chart pane and Guest Chart pane

A check box is shown for each custom field. You can show/hide these fields

by clicking on the  button and checking/unchecking the appropriate box.

Stationery pane

A substitution text is added for each custom field, e.g. if the custom field
name is "Languages spoken" the substitution text will be
{languages_spoken}.

Report pane

Custom fields are included in reports. Number and currency fields are
summed.

Professional edition only

Automatic seat assignment

You can set proximities for fields of type Yes/No and Selection. For
example, you could create a custom field 'department' with allowed
values: 'sales', 'marketing', 'engineering' and 'admin'. You could then set

the proximity in the appropriate Custom field proximity pane so
that guests from the same department are seated together (or apart) by
the automatic seat assignment.

Export window
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Custom fields values can be exported.

See also:

· Add custom fields

· Edit a property for multiple guests

2.10 Table shapes

2.10.1 E-shaped table

Advanced and Professional editions only

An E-shaped table comprises a top section and between 2 and 25 sprig
sections. 

Add an E-shape table using Insert>E-shaped Table... .

Click on the Sections button in the Table Properties window to change the
number of sprig sections and/or the size of sections in the Table Section
properties window.
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Uncheck all sections left-right symmetrical if you want to set different
numbers of seats down 2 sides of a section.

Check by section if you want to number the seats in each section
separately.
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If auto is checked the table size will be automatically adjusted to the
number and size of seats.

See also:

· Create an E-shaped table

2.10.2 Rectangular table

A rectangular table has seats on 4 sides, with the same number of seats on
opposite sides. 

Add a rectangular table using Insert>Rectangular Table... .

Set seats across = seats down for a square table.
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If auto is checked the table size will be automatically adjusted to the number
and size of seats.

If you want different numbers of seats on opposite sides, use a custom table.

2.10.3 Banquet table

A banquet table is a rectangle with an equal number of seats on 2 opposite
sides.

Add a banquet table using Insert>Banquet Table... .
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If auto is checked the table size will be automatically adjusted to the number
and size of seats.

If you want different numbers of seats on opposite sides, use a custom table.

2.10.4 Head table

A head table is a rectangle with seats on 1 side.

Add a head table using Insert>Head Table... .

If auto is checked the table size will be automatically adjusted to the number
and size of seats.
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2.10.5 Custom table

A custom table is a rectangle where you can set the number of seats on each of
the 4 sides independently. It can also have curved table ends.

Add a custom table using Insert>Custom Table... .

To add round ends set End 1 curve and End 2 curve to the appropriate degree
of curvature (0 degrees=no curve, 180 degrees=maximum curve).
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If auto is checked the table size will be automatically adjusted to the number
and size of seats.

2.10.6 Circular table

A circular table is a circle with seats all around.

Add a circular table using Insert>Circular Table... .
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If auto is checked the table size will be automatically adjusted to the number
and size of seats. 

Set the table diameter larger than the auto size and uncheck space seats
evenly for cabaret style seating.
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See also:

· Create sweetheart/cabaret style tables

2.10.7 Semi-circular table

A semi-circular table is a semi-circle (D-shape) with seats on 2 sides.

Add a semi-circular table using Insert>Semi-Circular Table... .

If auto is checked the table size will be automatically adjusted to the number
and size of seats.

See also:

· Serpentine table

2.10.8 Oval table

An oval table is an ellipse with seats all around.
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Add an oval table using Insert>Oval Table... .

If auto is checked the table size will be automatically adjusted to the number
and size of seats.

2.10.9 Serpentine table

Advanced and Professional editions only

A serpentine table is a 180 degree curved table (C-shape) where you can
set the number of seats on each of the 4 sides independently.

Add a serpentine table using Insert>Serpentine Table... .
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If auto is checked the table size will be automatically adjusted to the
number and size of seats.

See also:

· Half serpentine table

· Semi circular table



291

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

2.10.10 Half serpentine table

Advanced and Professional editions only

A half serpentine table is 90 degree curved table (half of a serpentine table)
where you can set the number of seats on each of the 4 sides independently.

Note that diameter is the diameter the table would have if it was a full circle.

Add a serpentine table using Insert>Half Serpentine Table... .

If auto is checked the table size will be automatically adjusted to the
number and size of seats.
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See also:

· Serpentine table

2.10.11 Row of seats

A row of seats is a straight or curved row of seats with no table.

Add a row of seats using Insert>Row of Seats... .

To drag a seat row, click on either end of the row (not the seats).

For a curved row of seats set Curve to a non-zero value.
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The curvature can vary between 0 and 180 degrees.
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If auto is checked the seat row will be automatically adjusted to the number
and size of seats.

2.11 Proximity

2.11.1 Proximity

You can use proximity to tell PerfectTablePlan where you want pairs of guests to
sit, relative to each other.

The available proximities are:

Proximity Meaning

 Next to Try to place in descending order of
preference: 1) in adjacent seats, 2) on
the same table, 3) on a nearby table.

 Near to The same as Next to, but not as
strongly weighted (Next to gets
priority).

 Near not next to Try to place in descending order of
preference: 1) on the same table, but
not at adjacent seats, 2) on a nearby
table.

Neutral It isn’t important where these guests
are placed relative to each other.

 Not Next to The same as Not near to, but not as
strongly weighted (Not near to gets
priority).

 Not Near to Try to place in descending order of
preference: 1) on a different table that
isn’t nearby, 2) on a different table.

Professional edition only
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You can also set proximity rules for custom fields of type Selection or
Yes/No. E.g. to put guests of particular types or categories together or
apart.

See also:

· Automatic assignment by guest proximity

· Proximity pane

· Proximity Preferences

2.12 Seat assignment

2.12.1 Seat assignment

Guests can be assigned to seats by:

· automatic seat assignment; and/or

· dragging and dropping guests or groups onto seats

You can check you have enough seats by looking at the Status bar.

To get the best results it is often advisable to use the automatic seat assignment
and then fine-tune with drag and drop.

Note If you drop a guest onto a seat that is already assigned to a guest, the
seats of the two guests will be swapped.

Assigning multiple seatings

PerfectTablePlan Professional edition can assign multiple seatings in a single
operation (e.g. when you have an event where you want guests to sit with
different people for every meal or course).

Locking guests

If you wish to  lock a guest to a seat, so they can't be re-assigned by drag
and drop or automatic seat assignment:
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· select the guest(s)/group(s)/table(s)

· select Edit>Guest Property>Locked>Yes

Toggle the lock off in the same way.

Note You can lock a guest who has no seat assigned.

RSVP status and assigning

Generally you won't want guests who have cancelled or declined their invitations
to be assigned a seat. You can control which RSVP status guests are allowed to

be assigned to seats in the Preferences window.

Assigning to tables (not seats)

If you wish to assign guests to tables, rather than seats, you should still assign
seats but not include seat numbers in your final table chart, guest chart or
stationery.

Unassigning

To unassign guests from seats:

· select the guest(s)/group(s)

· select Edit>Unassign

You can also drag a guest from their seat and drop them on the Floor Plan or

Table Plan pane background to unassign them.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

· Assign (or reassign) seats in real time

· Check where a guest is seated across multiple seatings

· Check who a guest was seated next to at previous events

· Arrange multiple seatings for an event

https://www.perfecttableplan.com/video/assignv7.html
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2.12.2 Automatic seat assignment

PerfectTablePlan will do an automatic seat assignment if you select File>Auto
Assign Seats or the equivalent Main tool bar button.

Set the Auto assign tab of the Preferences window to automatically assign
seats:

· according to proximities you have set; or

· according to the current order of guests in the Guests pane; or

· randomly

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

https://www.perfecttableplan.com/video/assignv7.html
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2.12.3 Automatic assignment by guest proximity

If you have set Auto assign seats to according to guest proximity in the

Auto assign tab of the Preferences window, then PerfectTablePlan will try to
automatically assign guests to seats according to their proximities. This is useful
when trying to seat particular groups of people together.

It will attempt to:

· put people near to (or not near to) each other, according to your settings in

the Proximity pane

· not leave empty seats between guests (depending on your choice for social

distancing in the Preferences window)
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· alternate males and females (depending on your choice for alternate males

and females in the Preferences window)

· seat guests opposite or next to each other on narrow (e.g. banquet and E-

shaped) tables (depending on your choice for On narrow tables prefer near

to/next to guests seated in the Preferences window)

· seat males to the left/right of females (depending on your choice for Prefer

next to guests seated in the Preferences window)

· assign VIP guests to VIP tables

· prioritise VIP guests

It does this by assigning a score to each plan and using a genetic algorithm to
try to find the highest scoring plan. The higher the score, the better the seating
fulfils the proximities you have defined.

You can run File>Auto Assign Seats as often as you like. Each new run will
attempt to improve on the previous one. Click on the Stop button at any time
during calculation to keep the best (highest scoring) plan so far. Select
Edit>Undo to go back to the previous plan.

Note Guests who have been  locked by you or have the wrong RSVP status

(depending on the Allow seat assignment with RSVP settings in the 
Preferences window) will not be (re)assigned by automatic assignment.

Professional edition only

You can also set proximity using custom fields. For example, you can set all
guests (not) to sit next to other people in the same company. 

Note The automatic assignment may try to put 2 'near to' proximity guests next
to each other if no 'next to' proximity guests are available.

Table assignment order

The order in which guests are assigned to tables/rows is set in the Auto assign

tab of the Preferences window:
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· Set in any order to try filling the tables in different orders. This gives the

automatic seat assignment the best chance to maximize the score, so is
usually recommended.

· Set in the order shown in the Schematic pane to fill tables in the order

shown in the Schematic pane. You can change this order.

Scoring

A plan is scored as follows:

Criterion Score

 Next to proximity guests on
adjacent seats [1]

+20 [2]

 Near to proximity guests on
adjacent seats [1]

+5 [2]

 Near not next to proximity guests on
adjacent seats [1]

-5 [2]

 Not Next to proximity guests on
adjacent seats [1]

-10 [2]

 Not Near to proximity guests on
adjacent seats [1]

-40 [2]

 Next to proximity guests on same
table (or same section of an E-shaped
table)

+10

 Near to proximity guests on same
table (or same section of an E-shaped
table)

+2

 Near not next to proximity guests on
same table (or same section of an E-
shaped table)

+4
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 Not Next to proximity guests on
same table (or same section of an E-
shaped table)

-5

 Not Near to proximity guests on
same table (or same section of an E-
shaped table)

-20

 Next to proximity guests on
adjacent tables [3]

+2

 Near to proximity guests on
adjacent tables [3]

+1

 Near not next to proximity on
adjacent tables [3]

+1

 Not Next to proximity guests on
adjacent tables [3]

-2

 Not Near to proximity guests on
adjacent tables [3]

-4

Guest with at least one  or 
proximity, but none next to

-10

Guest with at least one  or 
proximity, but none on the same table
(or same section of an E-shaped table)

-20

Male next to female +2 [4]

 Next to proximity male to right/left
of female

+3 [5]

 VIP guest assigned to VIP table +10
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 VIP guest not assigned to VIP table
(if there is one)

-10

Guest with no-one sat next to them -9

Guest next to one empty seat -3

Guests from different groups on
adjacent seats to each other [1]

-30 [6]

Guest not assigned a seat (apart from
locked guests and guests who aren't
seated due to their RSVP status)

-100

[1] 2 seats are considered adjacent if they next to (left/right) of each other or if
they are directly opposite each other and less than 2 metres (approx 6 feet)
apart.

[2] May be only 75% of this on narrow tables depending on the setting of On

narrow tables prefer near to/next to guests seated in the Preferences
window.

[3] 2 tables are considered adjacent if their centres are within 5m/15ft of each
other.

[4] 0 if alternate males and females is unchecked in the Preferences
window.

[5] Depending on the setting of Prefer next to guests seated in the 
Preferences window.

[6] 0 if social distancing is unchecked in the Preferences window.

In addition  VIP guests have their scores multiplied by 3.

Once all the scores have been totalled a 'smoothing' function is applied to
moderate the more extreme guest scores. The smoothing function spreads the
happiness around - avoiding the situation where the best score is one with a few
deliriously happy guests and lots of slightly miserable ones! 
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The scoring only takes account of whether guests are seated next to each other,
on the same table (or the same section of an E-shaped table) or on adjacent
tables. It doesn't allow for whether the guests might be able to see each other or
are within talking distance. This simplification allows the genetic algorithm to
search the vast space of possible solutions reasonably quickly. You may have to
tweak the automatic assignment a little 'by hand' to get the best possible result.
For example you might have to move/rotate tables so that people who don't like
each other aren't sat back to back. However you should find that the automatic
assignment will be quite close to ideal, and this will save you a great deal of
time.

Time

You can set the stopping criteria for the automatic assignment in the 
Preferences window. The automatic assignment time goes up rapidly with the
number of guests. This is in the nature of combinatorial problems.

The longer the automatic assignment is run, generally the better it will be. Select
Edit>Preferences and on the Auto assignment tab click on seconds and set
an appropriate number of seconds (1 hour = 3600 seconds). Then select
File>Auto Assign Seats.

Note The auto assignment will only run on 1 'core' of your computer CPU, so you
should still be able to do other things while it is running.

Checking seat assignment by proximity

You can check how good your seat assignment by proximity is using the

proximity buttons in the Floor plan pane. For example:

· Hold down the  button to show all guests that should be sitting next to each

other.

· Hold down the  and  buttons to show potential and critical seating issues,

e.g. guests that should be sitting next to each other that aren't.



304

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

Reference

You can also see non-optimally seated guests in the Troubleshooting report

in the Report pane.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

· Improve the auto seat assignment

· Proximity

2.12.4 Automatic assignment by guest order

If you have set Auto assign seats to in the order shown in the Guests

pane in the Auto assign tab of the Preferences window, then
PerfectTablePlan will try to automatically assign guests to seats according to

their current order in the Guests pane and the order of the tables. This can be
useful for seating guests by precedence or rank at formal events.

https://www.perfecttableplan.com/video/assignv7.html
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For example:
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Guest assignment order

The guests are assigned in the order they are currently shown in the Guests
pane, top to bottom.

To sort guests by a single column, click on the column header in the Guests
pane.

To sort guests by multiple levels in the Guests pane, click on the  button at

the top of the Guests pane to show the Multi-Level Sort window.

Generally text values are sorted alphabetically and numerical values are sorted
numerically. But you can also arrange non-alphabetic sorting by guest title or
suffix.
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Advanced and Professional editions only

Ordering by custom fields

You can use custom fields to store the precedence of each guest. 

· Use a custom field of type currency if you wish to use a numeric scale.

You can use decimal points. E.g. if a guest has a rank of '7.0' you could
give their spouse a rank of '7.1'.

· Use a custom field of type selection if you have a limited number of

classifications you want to rank by. You can colour-code these classes in
the floor plan.

· Use a custom field of type text if to wish to store seniority. You should use

a YYYY-MM-DD date format so that the dates are sorted in date order
when sorted alphabetically. E.g. 2018-01-07 for 7th January 2018.

You can sort the Guests pane by multiple custom fields if there is more
than one criteria. For example, you might want to sort by a numeric
precedence value and then by seniority date.
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Table assignment order

The order in which guests are assigned to tables/row is set in the Auto assign

tab of the Preferences window. Typically you will want to set in the order

shown in the Schematic pane to fill tables in the order shown in the 
Schematic pane. You can change this order.

The order in which seats are filled depends on whether Seat numbers is set to
clockwise or anti-clockwise for each table/row.

Other

You can run File>Auto Assign Seats as often as you like. However there is no
random element and the result will always be the same for a given guest order,
guest locking/RSVP properties and table order.
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Note Guests who have been  locked by you or have the wrong RSVP status

(depending on the Allow seat assignment with RSVP settings in the 
Preferences window) will not be (re)assigned by automatic assignment.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

· Assign seating by order of precedence

2.12.5 Automatically assign guests randomly

If you have set Auto assign seats to randomly in the Auto assign tab of the

Preferences window, then PerfectTablePlan will try to automatically assign
guests to seats at random. Guest proximity, group membership, VIP status and

order in the Guests pane are ignored. This is useful in some type of events
when you want to mix things up.

The order is which guests are assigned to tables/row is set in the Auto assign

tab of the Preferences window:

https://www.perfecttableplan.com/video/assignv7.html
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· Set in any order to try filling the tables in different orders. 

· Set in the order shown in the Schematic pane to fill tables in the order

shown in the Schematic pane. You can change this order.

You can run File>Auto Assign Seats as often as you like. Each new run will
create a new random layout.

Note Guests who have been  locked by you or have the wrong RSVP status

(depending on the Allow seat assignment with RSVP settings in the 
Preferences window) will not be (re)assigned by  automatic assignment.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

2.12.6 Genetic algorithm

You don't need to know how a genetic algorithm works to use PerfectTablePlan.
This section is just included in case you are interested.

When assigning guests by proximity, it isn't possible to try every combination of
guests and seats, because there are so many. Even just 25 guests can be
assigned to 25 seats in a staggering 15,511,210,043,330,985,984,000,000
different ways. So we have to find an efficient way to search though the possible
assignments to find a good one in a reasonable time. PerfectTablePlan does this
using a 'genetic algorithm'.

A genetic algorithm works by my mimicking the Darwinian process of natural
selection over successive generations:

1. An initial population of assignments is created using various rules of thumb
('heuristics').

2. The assignments are randomly mutated and spliced to produce new layouts.

3. Weak assignments (those with low scores) are eliminated from the
population.

4. If the best assignment isn't satisfactory go to step 2.

Because of the way a genetic algorithm works, it cannot be guaranteed to give a
mathematically optimal answer. But if we were to use an approach that was
guaranteed to give a mathematically optimal answer, it might take years to run!

https://www.perfecttableplan.com/video/assignv7.html
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The PerfectTablePlan genetic algorithm will usually get close to an optimal
solution very quickly.

Problem size

The number of combinations for seating n guests in n seats is n! ( n factorial).
3! is 3x2x1. 10! is 10x9x8x7x6x5x4x3x2x1. This means that the difficulty of the
problem rises very rapidly with the number of guests. For example:

25! = 15511210043330985984000000

50! =
30414093201713378043612608166064768844377641568960512000000000
000

100! =
93326215443944152681699238856266700490715968264381621468592963
89
52175999932299156089414639761565182862536979208272237582511852
109168640
00000000000000000000000

200! =
78865786736479050355236321393218506229513597768717326329474253
32
44359449963403342920304284011984623904177212138919638830257642
790242637
10506192662495282993111346285727076331723739698894392244562145
166424025
40332918641312274282948532775242424075739032403212574055795686
602260319
04170324062351700858796178922222789623703897374720000000000000
000000000
000000000000000000000000000

500! =
12201368259911100687012387854230469262535743428031928421924135
88
38584537315388199760549644750220328186301361647714820358416337
872207817
72004807852051593292854779075719393306037729608590862704291745
478824249
12726344305670173270769461062802310452644218878789465754777149
863494367
78103764427403382736539747138647787849543848959553753799042324
106127132
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69843277457155463099772027810145610811883737095310163563244329
870295638
96628911658974769572087926928871281780070265174507768410719624
390394322
53642260523494585012991857150124870696156814162535905669342381
300885624
92468915641267756544818865065938479517753608940057452389403357
984763639
44905313062323749066445048824665075946735862074637925184200459
369692981
02226397195259719094521782333175693458150855233282076282002340
262690789
83424517120062077146409794561161276291459512372299133401695523
638509428
85592018727433795173014586357570828355780158735432768888680120
399882384
70215146760544540766353598417443048012893831389688163948746965
881750450
69263653381750554781286400000000000000000000000000000000000000
000000000
00000000000000000000000000000000000000000000000000000000000000
000000000
000000

1000! = a number 2568 digits long (if you printed it out 5
digits per centimetre it would be more than 5 metres long).

4000! = a number 12674 digits long (if you printed it out 5
digits per centimetre it would be more than 25 metres long).

So don't be surprised if PerfectTablePlan takes a while to do an automatic
assignment for 1000+ guests.

See also:

· online factorial calculator

2.13 Copying to the clipboard

2.13.1 Copying to the clipboard

You can copy the contents of the Floor Plan, Table Plan, Table Chart,

Guest Chart and Report panes to the clipboard for pasting into other
applications (such as Microsoft Excel). Bring the appropriate pane to the front of
the Right pane and select Edit>Copy or the equivalent Main tool bar button.

The Floor Plan and Table Plan will be copied to the clipboard as an image.

http://www.calculatorsoup.com/calculators/discretemathematics/factorials.php
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The Table Chart, Guest Chart and Report panes will be copied to the
clipboard as both plain text (no formatting) and HTML (some formatting). Which
one is used will depend on the capabilities of the application you paste into, for
example Word will use HTML and Notepad will use plain text.

Note You can click the  or  buttons at the top of the Table Chart, 

Guest Chart or Report panes to paste the chart into Microsoft Word or
Excel. You must have Microsoft Word or Excel installed.

Font size is not preserved when you copy a Table Chart or Guest Chart as
HTML, as there is no reliable way to map between point size and HTML font size.
You should be able to reset the font size easily enough in the other application.
The chart layout can look cramped if the chart is too big for the page you paste
it into. You may be able to fix this by reducing the font size, changing the page
orientation to landscape and/or reducing the number of columns in the chart.

You can also use File>Export to transfer data to other applications via a file.

See also:

· Exporting

2.14 Printing

2.14.1 Printing

You can print the contents of the Floor Plan, Table Plan, Table Chart,

Guest Chart, Stationery and Report panes. Bring the appropriate pane
to the front of the Right pane and select File>Print or the equivalent Main tool

bar button. The Print window will appear.

The controls displayed will depend on the pane that you are printing.

If you only have a standard size (e.g. A4) printer you might find that text on the

Floor Plan pane isn't very legible when printed to a single A4 sheet. You may
have to span multiple sheets or print it on a larger format printer. See printing
legible plans on a small format printer.

Click on the Setup button to change printer settings such as the page size.

You can also copy or export your floor plan, table chart or guest chart to other
applications, and print them from there, by using Edit>Copy or File>Export.

See also:
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· Print to poster size

· Print window

· Print Setup window

· Change the print pagination

· Change the printer or page size

 

2.14.2 Stationery

In addition to floor plans, table charts and guest charts PerfectTablePlan can
print various types of stationery, including:

· save the date cards

· invitations

· address labels

· place cards

· table cards

· escort cards

· badges

· tickets

· personalised wine bottle labels and menus

· thank you cards

You can easily personalise the stationery for each guest, group or table using
substitution text. For example, if you wish to add the display name and seat
number of each guest to a place card you just add the substitution text
{guest_display_name} and {guest_seat} to your design. This text will then

be replaced by the appropriate values for each guest.
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See also:

· Merge guest names into stationery

· Ordering place cards

· Stationery pane

· Print stationery tutorial

· Show one stationery item per couple/family/group

· Change the order of guests in a group

2.15 Emailing

2.15.1 Emailing

You can email your plan using File>Email Plan or the equivalent Main tool

bar button. This will add your plan to an email as an attachment.
PerfectTablePlan will attempt to use your standard email application. If you can't
use the integrated email, just compose an email as usual and attach the plan
file.

2.16 Exporting

2.16.1 Exporting

Data in PerfectTablePlan can be exported in a variety of formats for use in other
applications, such as image editors, spreadsheets, wordprocessors and web
browsers.

Select File>Export... to display the Export window.

data

Select guest and seating data to Excel/CSV/delimited text file to export
data in a flexible, text form for import by other applications, such as

spreadsheets. The Export Data window will appear. This window allows you
to specify which guest properties to export and what file format to use. For
export to a database or other application you would typically export a CSV file.

See the Export Data window page for more details.
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vCard file

Select guest data to vCard file to export guest data in a form that can be
imported into most applications with address books, including Outlook, Palm

Pilot desktop and Apple Address Book. The Export VCard window will appear.
This window allows you to specify which guests to export and whether to export

each guest to a separate vCard file. See the Export VCard window page for
more details.

image

Select a pane to export to PDF to create a vector image file. Select a pane to
export to PNG, JPG or BMP format to create a raster image file. 

PDF format gives the best quality when you need to enlarge an image. PNG is a
good compromise between size and quality. JPEG files are small, but are of low
quality. BMP files can be very large and are not usually recommended. To export
a BMP, JPEG or PNG image as large as possible check export image as large

as possible in the Preferences window.

Usage Recommended format

Large and/or high quality prints PDF

Outputting an image for modification in
Photoshop/PaintShop/Paint

PNG

Small file size/low quality images JPEG

text

Select a pane to export to CSV, text or HTML to export the appropriate pane as
text. 

HTML retains some of the formatting, but not the font size as there is no direct
way to translate point size into HTML. You should be able to reset the font size
easily enough in the other application. Also the chart layout can look cramped if
the chart is too big for the other application. You may be able to fix this by
reducing the font size, changing the page orientation to landscape and/or
reducing the number of columns in the chart.
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web

Export to web to upload a simplified version of the Guests and Floor plan
panes to our server. You can email a link to this page to anyone you want to be
able to look at your plan. Any device with an Internet connection and a
reasonably modern web browser should be able to access it, including iPads. But
please note that:

· You cannot make changes to the plan from your web browser. However you

can modify the plan from your desktop computer and upload it again. If you
re-export the plan, anyone looking at it in a web browser will be prompted if
they wish to reload it.

· Your plan is not password protected and we cannot guarantee that your

uploaded data will remain confidential. Anyone who knows (or guesses) the
location of the page on our server will be able to look at your plan. Confidential
plans should not be exported to our web server.

· You can export either detailed or minimal information. The minimal option does

not include some of the more detailed data, such as guest notes, VIP status
and special requirements.

· The web export service is provided 'as is' free of charge and with no warranty

of any kind. We cannot guarantee 100% availability of our server and can
withdraw the service at any time.

· We will delete uploaded plans from time to time to make space (typically after

30 days without being accessed).

See also:

· Export formats

· Export window

· Export Data window

· Export VCard window

· Export to PDF format

· Export a chart/report to Excel/Word
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· Export guest and seating data to Excel

· Export to web, iPad, Android and other devices

· Copying to the clipboard

2.16.2 Export formats

PerfectTablePlan exports information in 8 major formats:

· Excel - Microsoft Excel's proprietary format.

· CSV (Comma Separated Value ) - A text file readable by many applications

including Microsoft Excel. Columns and rows are delimited (separated) by
commas and carriage returns, respectively. " and , characters are quoted.

· Delimited text data - A text file with the user's choice of delimiters. Useful

for importing into a wide range of applications. CSV is a special form of
delimited text data.

· vCard file - vCard files can be imported into most applications with address

books, including: Outlook, Palm Pilot desktop and the Apple Mac Address
Book.

· Raster image (e.g. .PNG, .JPG and .BMP) - An image described as a 2

dimension array of coloured cells (pixels) that can be read by many graphics
packages, such as Photoshop and Microsoft Paint.

· Vector image (e.g. PDF) - An image described in terms of primitive shapes,

e.g. a circle of a given radius and position, that can be read by some drawing
packages such as Adobe Acrobat.

· HTML text (e.g. .HTML) - A textual representation with layout and formatting

that can be read by a web browser, such as Internet Explorer, Mozilla Firefox
or Safari. Many wordprocessors, such as Microsoft Word, can also read HTML.

· plain text (e.g. .TXT) - A textual representation without layout and formatting

that can be read by a wide range of applications.

· web - XML and binary data that is uploaded to

http://webexport.perfecttableplan.com .

Different formats are useful for different things. However there are important
things to bear in mind when deciding whether to use raster or vector images:

http://webexport.perfecttableplan.com
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· Raster images can degrade when resized, for example when printed to poster

size. Vector images can normally be resized without problems.

· Raster images are much harder to edit than vector images, because a table is

drawn as an array of many separate cells rather than a circle or a rectangle.

· Vector image formats are less widely supported than raster formats and can

therefore be harder to modify.

See also:

· Choosing a format to export to

2.17 Checking-in guests

2.17.1 Checking-in guests

You can check-in guests at an event by changing their RSVP status to Arrived

as they check-in. You can visually track how seats are filling up in the Floor
plan pane by:

· displaying the RSVP status icon; and/or 

· show the number of arrived/unarrived guests for each table

The total number of arrived guests is also shown in the Status bar.

Professional edition only
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You can check in guests by printing a barcode of their unique guest ID on
their invitation, ticket or badge and then scanning this barcode into
PerfectTablePlan as they arrive. This is much faster and less error prone
than trying to find and update guest records by typing into PerfectTablePlan.
You will need a barcode scanner and to install a barcode font. For more
information see the Check-in guests tutorial.

See also:

· Assign (or reassign) seats in real time

2.18 IDs

2.18.1 IDs

Items, such as guests, groups and tables, have associated Ids. The ID is a
globally unique identifier for that item. 

PerfectTablePlan creates 15 character hexadecimal codes. But any unique string
of characters is permitted. 
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The ID is automatically assigned when an item is created and will not change.
E.g. it will be the same value when exported/saved as it was when first
created/imported/read in. 

You cannot edit an ID through the PerfectTablePlan user interface.

You can check for duplicate guest Ids using the Troubleshooting report.

Advanced and Professional editions only

· If you create a guest 'Mr John Smith' in plan myplan1.tp and then

File>Save As... the plan to myplan2.tp, then the guest will have the

same ID in both plan files, even if you subsequently change their name in
either plan. Which means you can run Multi-plan reports by ID.

· If you create a guest 'Mr John Smith' in plan myplan1.tp then File>New

and create another 'Mr John Smith' in plan myplan2.tp., then the guest

will not have the same ID in both plan files. So you will have to run Multi-
plan reports by name.

Running Multi-plan reports by ID is preferred, because running Multi-plan
reports by name causes issues if:

· The Title, First name or Last name is altered in any of the plans.

· 2 people in a plan have the same Title+First name+Last name (case

insensitive).

Professional edition only

You can import and export guest Ids. This is useful for integrating
PerfectTablePlan with other systems, such as event registration and CRM
systems. 

Guest Ids are also very useful for:
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· merge imports 

· importing proximity data

· guest barcodes

2.19 Backup files

2.19.1 Backup files

There are many ways you can lose your work on a computer including: power
outages; hardware failure; human error; and software errors. To guard against
this PerfectTablePlan can create backups of your plan files. This saves you from
continually saving to a new name file, e.g. plan1.tp, plan2.tp etc.

Depending on the choices in the Preferences window the software can create
automatic backups of the software:

· every time you File>Save the plan

· every time you do an auto assignment, export or print

· every n minutes (assuming the plan has been changed in that n minutes)

Note Plans with more than 30 guests will only be backed up if you have
purchased a licence key.

Backup files are created by default in a 'backup' folder in your plans folder. You

can change the backup folder in the Preferences window.

Backup files are created with the extension .tpb (Table Plan Backup) and include
a time and date stamp. For example, if you save myplan.tp at 17:42:05 on 11th
February 2005 it will create a backup file myplan_2005-02-11T17-42-05.tpb
. If some problem occurs with myplan.tp (or you just want to compare it with

the older version) you can open myplan_2005-02-11T17-42-05.tpb and

File>Save As it as a new .tp file.

To open a backup file either:
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1. Select File>Backups, the Find Plan Files window will appear listing
backups in date/time order.

2. Double-click on the appropriate backup.

or

1. select File>Open or the equivalent Main tool bar button, the Open window
will appear

2. select Table planner backup (*.tpb) in the Files of type drop-down.

3. navigate to the folder containing the backup files, usually
Documents\PerfectTablePlan\backups .

4. select the backup file you want and click the Open button

Check at startup check for unsaved changes in backup files in the

Backups tab of the Preferences window to check automatically for unsaved
changes in backup files when PerfectTablePlan starts.

Note Any number of backup files on your harddisk will be useless if your
harddisk dies. Make sure you backup your precious plan files to separate storage
devices, e.g. to another computer, CD, memory stick or DropBox account. You
can even email them to yourself.

See also:

· Find a missing plan file
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2.20 Creating a good table plan

2.20.1 Creating a good table plan

For an up-to-date list of tips on how to create a good table plan see our tips web
page.

2.21 Multiple user/computer access

2.21.1 Multiple user/computer access

PerfectTablePlan does not support multiple users editing the same plan at the
same time. 

On Windows PerfectTablePlan uses file locking to ensure that only one user can
open a plan file to write (even across a network). Any number of users can open

the same plan file with read-only access. You can disable file locking in the 
Preferences window, but this is not recommended.

If you open a plan with read-only access then PerfectTablePlan will prompt you if
it is modified by another application (e.g. by PerfectTablePlan on another
computer) and give you the option to update. You can disable checking for

updates in the Preferences window.

There are various different ways you can share a plan file between multiple
computers with one or more users. Which is best depends on your
circumstances:

Approach Advantages Disadvantages

Copying plan files
backwards and forwards by
email attachment

No effort to set up.
Time taken to email plans.

Requires careful
coordination if more than
one person is editing a
plan.

https://www.perfecttableplan.com/html/tips.html
https://www.perfecttableplan.com/html/tips.html
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You have to be careful not
to lose changes by copying
an old file over a new one.

Storing the plan file on a
USB memory stick

No synchronization
problems.

Requires a USB memory
stick.

Only one person can be
accessing the plan at any
time.

Shared network drive. A plan will be locked when
one user has it open to
write. Other users will only
be able to open it as ‘read
only’, preventing conflicting
changes.

Users that have opened
the plan as read-only will
be notified of any
changes and be given the
option to update.

Requires access to a
shared network drive.

File locking can be
restrictive when you have
multiple users trying to
access a file.

Store your plan files in a
DropBox, synchronised
across all your machines.

(Do not synchronise your
Program
files\PerfectTableP
lan folder, this could
cause all sort of problems)

Changes on one machine
are automatically synched
to all other machines.
Conflicts (.e.g. two users
making changes to the
same file at the same time)
are handled automatically.

Easily manage sharing
with other users on a plan
by plan basis.

You can still access your
plan even if you have no
Internet access.

DropBox keeps a 1 month
history of changes and
allows edits and deletions
to be undone.

Requires a small amount of
effort to set-up.

Changes only sync to other
machines when you have
Internet access.

If 2 users simultaneously
edit the same plan on
different machines at the
same time you will end up
with 2 versions of the plan.

An encrypted copy of your
data is transmitted to and
stored on the DropBox
server. This may not be
appropriate for highly
confidential plans.

http://db.tt/LgLLuIG
https://www.dropbox.com/help/topics/syncing_and_uploads
http://www.dropbox.com/help/36
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Works across Windows
and Mac.

DropBox requires a
payment if you want to
store more than 2GB of
file.

Note You can store PerfectTablePlan and its preferences on a USB key as a
portable application, along with your plans. This makes it easy to move between
computers.

If you have multiple users then please ensure you have the appropriate number
of PerfectTablePlan licences.

See also:

· Export to web, iPad and other devices

· Using on a USB drive

2.22 Using on a USB drive

2.22.1 Using on a USB drive

You can store your preferences in a .ini file in the same folder as your
PerfectTablePlan .exe. This allows you to store your preferences, along with your
plans, on a portable device (e.g. a USB drive/memory stick). It is even portable
between Windows and Mac computers.

To use PerfectTablePlan portably:

· Install PerfectTablePlan into an appropriate folder on the portable device, to

which you have write permission.

· Start PerfectTablePlan.

· Open the Preferences window.

· In the General tab select a portable .ini file for the Store these

preferences in field.

· Click OK.

· Save your plans to the portable device.

https://www.perfecttableplan.com/html/licensing.html
https://www.perfecttableplan.com/html/licensing.html
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If you are storing your preferences in a perfecttableplan.ini file, then recent files
are stored with paths relative to the current executable. This means they should
still work for plans stored on the device even after you have moved the device to
another computer.

It is possible to have Windows and Mac versions of Hyper Plan on the same
device sharing a single perfecttableplan.ini file and common plan files. Just make
sure you install the Windows .exe and Mac .app into the same folder. We also
recommend that they are the same version of PerfectTablePlan.

Note If you install PerfectTablePlan Windows .exes into 2 different folders and
set them to use .ini files, they will each store their preferences in their own .ini
file. 

2.23 Integrating with PerfectTablePlan

2.23.1 Integrating with PerfectTablePlan

You may wish to use PerfectTablePlan to create a table plan from data produced
by another software package, for example an event registration or CRM system.
There are two ways you can do this.

Integrate via text/CSV file

If your software package can create a delimited text file (e.g. CSV file) you can
output this and import it into PerfectTablePlan. If you are able to script/program
the package you can get it to start PerfectTablePlan with the input file from the
command line.

For example to start up importing the file export.csv using the predefined
'theknot.com' mapping :

c:\program files\perfecttableplan\tableplanner.exe -import
export.csv -import_type theknot

Please email sales@perfecttableplan.com if you are interested in us adding a
mapping for your import file format.

Integrate via XML file

The above approach is sufficient for most needs, however it only allows you to
supply guest details, not details of tables or seating. If you need to do this you
can generate your own PerfectTablePlan plan file and start PerfectTablePlan to
open it.

mailto:sales@perfecttableplan.com
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For example to start up PerfectTablePlan and open a myplan.tp file:

c:\program files\perfecttableplan\tableplanner.exe myplan.tp

PerfectTablePlan associates a unique and unchanging ID with each record (e.g.
each guest). This can be very useful if you want to write a CSV/XML file, make
some changes in PerfectTablePlan and then read back the changes.

PerfectTablePlan plan (.tp) files are in a simple text/XML format. Please email
sales@perfecttableplan.com if you need help with the format.

See also:

· PerfectTablePlan integration partners

2.23.2 Command line arguments

PerfectTablePlan recognises the following command line syntax:

argument Comments Example

<plan file> The location of the .tp file
to load at start-up.

myplan.tp

-import <import file> The location of the data
file to import on start-up.

-import import.csv

-import_type <import
type>

A pre-defined import file
type. PerfectTablePlan
will look through the list
of pre-defined types until
it finds one that contains
the string passed in. For
example -import_type
evite will match the

pre-defined type
"evite" (case is
unimportant). This
argument is ignored if -
import is not specified.

-import_type evite

See also:

mailto:sales@perfecttableplan.com
https://www.perfecttableplan.com/html/integration_partners.html
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· Integrating PerfectTablePlan

2.23.3 PerfectTablePlan file format

PerfectTablePlan plan (.tp) files are stored as text in an XML format.

The format is fairly straightforward and you should be able to work out most of
the details by creating a few .tp files from PerfectTablePlan and examining them.
A few important points are noted below.

Indexing

Where different records in the XML reference each other they do so by numerical
indexes starting from 0.

<version>

For PerfectTablePlan v7.1.0 or later you should set the version to 19, e.g.:

<version value="19"/>

Advanced and Professional editions only

<guest_custom_fields>..</guest_custom_field
s>

Contains information about custom fields.

The index is the 0 based index into data values. E.g. if index is 2 then the
data for this field is the third custom data value stored in each guest record.

Type Meaning

0 Yes/No

1 Text

http://en.wikipedia.org/wiki/Xml
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2 Number

3 Currency

4 Selection

5 Tags

ID attribute

Many of the items have a unique ID attribute. The ID can be very useful if you
want to write a PerfectTablePlan XML file from another application, make some
edits in PerfectTablePlan and then read the modified information back.

<images>...</images>

The image is encoded in data according to format, which must be either PNG
or JPG.

<guest_images>...</guest_images>

The image is encoded in data according to format, which must be either PNG
or JPG.

<textures>...</textures>

The texture is encoded in data according to format, which must be either PNG
or JPG.

<guests>..</guests>

This section contains details of all the guests.

The guest group attribute is the index of the corresponding group record.

The meaning of the accepted attribute is given below:
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Accepted attribute Meaning

0 RSVP Unset

1 RSVP Accepted

2 RSVP Sent

3 RSVP Declined

4 RSVP Cancelled

<groups>..</groups>

This section contains details of all the groups.

<tables>..</tables>

This section contains details of all the tables.

The meaning of the shape attribute is given below:

Shape attribute Meaning

0 Circular

1 Rectangular

2-5 no longer used

6 Custom

7 Head

8 Banquet
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9 Semi-circular

10 Oval

11 Row of seats

12 E-shaped

13 Serpentine

14 Half serpentine

The position of the centre of a table is recorded in metres using attributes
"X_metres" and "Y_metres". For backward compatibility you can also set the
position of a table in pixels using attributes "X" and "Y", where there are 167
pixels to a metre. The use of pixel measurements is deprecated and may not be
supported in future versions.

The table assigned attribute is a url encoded list of guests assigned to the seats
of the table, e.g. an unencoded attribute "9,0,-1" means:

· seat 0 contains the guest with index 9

· seat 1 contains the guest with index 0

· seat 2 contains no guest

<floorplan_shapes>..</floorplan_shapes>

This section contains details of the shapes added to the floor plan.

The meaning of the shape attribute is given below:

Shape attribute Meaning

0 Circle

http://en.wikipedia.org/wiki/Url_encoding
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1 Ellipse

2 Square

3 Rectangle

<floorplan_text>.. </floorplan_text>

This section contains details of the free text added to the floor plan.

<floorplan_walls>..</floorplan_walls>

This section contains details of the walls/lines added to the floor plan.

<floorplan_images>..</floorplan_images>

This section contains details of the images added to the floor plan.

<affinities>..</affinities>

This section contains details of all the guest proximities (who should sit next to
who).

The affinity guest1 and guest2 attributes correspond to the 2 guests who the
affinity is set for. If no affinity is set, neutral is assumed.

The meaning of the affinity value attribute is given below:

Value attribute Meaning

0 Next to

1 Near to

2 Neutral
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3 Not next to

4 Not near to

5 Near not next to

<stationery>..</stationery>

This section contains details of the current stationery design.

<selection_filters>..</selection_filters>

This section contains the indexes of guests and groups currently included in the

Selected... list in The Guest Chart pane, Stationery pane and Export
Data window.

<viz_colours>..</viz_colours>

This section contains the colours used for visualizing gender, meal, group and

custom fields in the Floor Plan, Table Plan and Stationery panes.

2.24 Uninstalling

2.24.1 Uninstalling

To uninstall PerfectTablePlan:

· click on the Windows Start button.

· select Control panel, the Control panel window will appear

· double-click on Add or Remove programs, the Add or Remove Programs

window will appear.

· ensure PerfectTablePlan and its help window are closed.

· select PerfectTablePlan, click on the Remove button and click Yes.

Note You may require Windows Administrator rights to uninstall applications.



How do I?
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3 How do I?

3.1 How do I?

This section covers common tasks that you might want to achieve. If you can't
find the answer to your question here or in the rest of the Help try the
PerfectTablePlan FAQ page . Most of these topics are available in a context-
sensitive form from the How do I? button in the main tool bar.

Add a chart title/footer

Add a colour coded spot to the stationery

Add a dance floor, stage etc to the floor plan

Add a graphic/image/clipart to the floor plan

Add a graphic/image/clipart to the stationery

Add a guest image to the stationery

Add a new stationery layout

Add a personalised map to the stationery

Add a special character not on my keyboard

Add a title or text into the floor plan

Add/remove a single seat to/from a table

Add walls to the floor plan

Add custom fields

Add or remove dots at the end of titles

Align tables

Align printing with my stationery

Arrange multiple seatings for an event

Assign guests to seats

https://www.perfecttableplan.com/html/faq.html
https://www.perfecttableplan.com/html/faq.html
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Assign seating by guest type/category

Assign seating by order of precedence

Assign table captains

Assign (or reassign) seats in real time

Change fonts and/or colours

Change how seats and guest names are displayed

Change proximity for multiple guests

Change table colour

Change table size or shape

Change text inside panes

Change the order of guests in a group

Change the print pagination

Change the printer or paper size

Change the size of the room

Change the seat numbering

Change the table order

Check social distancing

Check where a guest is seated across multiple seatings

Check who a guest was seated next to at previous events

Check-in guests

Close the current plan

Choose a format to export to
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Copy guests from one plan to another

Create address labels

Create a horseshoe shaped table

Create a non-rectangular room

Create a re-usable template plan

Create an E-shaped table

Create a rounded ended table

Create a serpentine table

Create rectangular tables with seats on 1,2 or 3 sides

Customize standard guest titles

Display seating on a VDU or plasma screen

Edit a property for multiple guests

Edit a property for multiple tables

Email my plan

Estimate numbers and budget

Export a chart/report to Excel/Word

Export guest and seating data to Excel

Export to iPad, Android and other devices

Export to PDF format

Find a missing plan file

Find free clipart

Find free textures
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Handle guests with unknown names

Handle multiple rooms

Handle post-nominal titles

Handle sponsored tables

Hide empty seats

Import guest details from a website or application

Import guest details from Apple Address Book

Import guest details from Excel spreadsheets

Import guest details from Outlook

Import guest details from Outlook Express

Import guests in couples/families/groups

Import proximity data

Import seating data

Improve the auto seat assignment

Insert a new guest into an existing group

Joining and splitting columns

Keep groups together

Liaise with caterers

Load sample stationery

Lock guests to seats

Make all names have the same font size

Merge guest names into stationery
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Move guests from one group to another

Only assign guests who have accepted

Order guests by title or suffix

Organize guests by company/organization

Order place cards

Print a guest list

Print invitations, place cards, badges, labels etc

Print legible plans on a small format printer

Print stationery on blank sheets

Print stationery on press-out sheets

Print to poster size

Remove a stationery border or fold line

Rename/renumber tables

Retrieve old versions of the plan

Rotate tables

Seat couples on the same table but not adjacent

Select multiple items

Set transparent as a colour

Show custom fields

Show gender

Show groups

Show meals
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Show one stationery item per couple/family/group

Show seat numbers

Show the proximity for one group at a time

Show unassigned seats

Show VIP/Special/RSVP/locked

Space seats correctly

Space tables correctly

Track details of non-seated guests

Turn off guest name capitalisation

Turn the floor plan grid on/off

Use and image of the venue

Use social distancing

Use particules in names

Zoom in/out of the floor plan

3.2 Assigning seats

3.2.1 Arrange multiple seatings for an event

If you have an event that includes several seatings, you might wish to have each
person sit with different people at each seating. PerfectTablePlan can help you
achieve this.

Professional edition only

Select File>Auto Assign Multiple.... The Auto Assign Multiple Seatings
window will appear. Set Number of seatings, how you want the guest



342

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

How do I?

proximities to change after each seating and the multi-plan report you wish
to display, then click OK. The seatings will then all be calculated in a single
operation and the report shown.

Example 1

We are planning a 3 course charity dinner and want to mix up the couples
so they sit with different people each course, but still stay in their couples. 

1. Create a plan with all the guests and the floor plan. 

2. Give all the couples 'Next to' proximity (you can do this during import).

3. Select File>Auto Assign Multiple... .

4. Set:

a. Number of seatings to 3.

b. set guests next to each other with proximity to Neutral or Not

next to and Not near to.

c. set guests at same table/section with proximity to Neutral or

Not next to and Not next to.

5. Click OK.

This will set the proximity of guests sat next to each other as 'Not near to'
and on the same table as 'Not next to' for the next seating, but preserve
the initial 'Next to' and 'Near to' proximities. This means the couples should
be kept together for every seating.

Example 2

We are planning 5 consecutive business dinners with a mix of investors and
founders. We want to sit investors next to different founders for each
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dinner. Each founder has also expressed a preference for 3 investors they
would most like to sit next to at one of the dinners. 

1. Create a plan with all the guests and the floor plan.

2. Create a custom field 'guest type' of type 'selection' with possible values
'founder' and 'investor'. Set the values for the guests appropriately (you
can do this during import).

3. For each founder set proximity 'Next to' for the 3 investors they would
most like to sit next to (you can do this during import).

4. Create a custom proximity to sit guests of type 'founder' 'Next to' guests
of type 'investor'.

5. Select File>Auto Assign Multiple... .

6. Set:

a. Number of seatings to 5.

b. set guests next to each other with proximity to Any and Not
near to.

c. set guests at same table/section with proximity to Neutral or

Not next to and Not next to.

7. Click OK.

This will set the proximity of guests sat next to each other as 'Not near to'
for the next seating, regardless of their initial proximity. This means a
founder should only be sat next to a preferred investor once.

If a guest is unable to attend a particular seating, you can open that plan,
unassign them and set their RSVP to Declined after you have generated all
the plans.

It is also possible to do it step-by-step, however it is a lot more work.



344

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

How do I?

1. Do the first seating plan as usual and File>Save the plan.

2. Right-click on each table and select the Proximity>Not Near to.

3. Recreate any Next to or Near to proximities (e.g. for couples) using
Ctrl+click and then selecting the proximity from the right-click menu. This
may be easier if you display groups.

Professional edition only

Instead of steps 2 and 3 above, in the Bulk Edit Proximity window:

· Set Change proximity for to Guests seated next to each other,

Guests seats at same table or (if you have 1 or more E-shaped tables)
Guests seated at same table section, according to your preference.

· Set With proximity to Neutral (so you don't overwrite existing

proximities).

· Set To Proximity to Not Near to.

· Click OK.

4. Select File>Auto Assign Seats.

5. Use drag and drop to fine-tune the seating plan as required.

6. Select File>Save As... to save the plan to a new file.

7. If another seating is required go to 2.

Advanced and Professional editions only

You can check who each guest is seated next to across multiple plans using

the Summary, Pairs, Matrix and Guest seating Multi-plan reports in the 
Report pane.
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Note If you have guests you don't want moved you can lock them to their seat.
If a guest isn't attending a particular seating you can lock them to no seat:
Ctrl+click to select these guests, Edit>Unassign, Edit>Guest
Property>Locked>Yes.

See also:

· Check where a guest is seated across multiple seatings

· Check who a guest was seat next to at previous events

3.2.2 Assign guests to seats

You can assign guests to seats by drag and drop, automatic seat assignment or
a combination of both.

For more details see seat assignment.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

· Improve the auto seat assignment

· Assign seats by guest type/category

· Assign seating by order of precedence

· Only assign guests who have accepted

· Arrange multiple seating for an event

· Creating a good table plan

3.2.3 Assign seating by guest type/category

Professional edition only

https://www.perfecttableplan.com/video/assignv7.html


346

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

How do I?

You can use custom fields to control the how the automatic seat assignment
by proximity places different categories of guests. E.g. whether it should
place guests from different departments or geographical areas together or
apart. You can use Weighting to set different levels of importance to
different custom proximities and Bulk Edit to set multiple values quickly.

Note If you set the Weighting to 1.0, this means that it is as important as
individual proximity and couples, families and groups might be separated to
satisfy the custom proximity. So you might want to set it to, say, 0.3 (30%
as important).

See the Custom field proximity pane for more details.

See also:

· Custom proximity (video with audio, 1:04 minutes)

· Assign guests to seats (video with audio, 13:01 minutes)

· Show custom fields

3.2.4 Assign seating by order of precedence

'Order of precedence' seating is where guests are sat according to their
precedence, rank, name of their organization or some other criteria. It is often
used at more formal events, such as military and diplomatic events. 

http://www.screencast.com/t/kDCh3c4oWuNo
https://www.perfecttableplan.com/video/assignv7.html
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To seat by order of precedence, set the Auto assign tab of the Preferences
window as shown below:
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Click on the Sort button at the top of the Guests pane and order your
guests in the order you want them to be assigned. You can set a special, non-
alphabetic ordering by title or suffix.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

Advanced and Professional editions only

You can order by custom fields, such as precedence or seniority.

https://www.perfecttableplan.com/video/assignv7.html
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Lock any guests you don't want to (re)assigned.

Set the order of the tables/rows in the Schematic pane to the order you want
them to be assigned. 

The order in which seats are filled depends on whether Seat numbers is set to
clockwise or anti-clockwise for each table/row.

Select File>Auto Assign Seats.

See also:

· Automatic assignment by guest order
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3.2.5 Assign table captains

Sometimes you want to assign 'table captains' to particular tables. For example,
at business or charity events where these people have sponsored tables. 

If you want to assign particular table captains to particular tables, you can do
that by:

· Manually dragging each table captain from the Guests pane to their seat in

the Floor Plan pane.

· Locking them to the assigned seat.

It might help to set table captains to have VIP status.

Once you have all the table captains assigned and locked, you can fill in all the
other guests around them using automatic seat assignment.

Professional edition only

If you want to space out table captains, one per table, but don't care which
tables they sit on:

· Add table captain as a type of guest using a custom field.

· Set guests of type table captain to sit Not near to each other.
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The automatic seat assignment will then try to space them out, one per
table.

See also:

· Handle sponsored tables

3.2.6 Assign (or reassign) seats in real time

If you have an event where it is uncertain how many people will arrive, you may
have to assign (or reassign) seats 'on the fly'. Standard paper seating charts
and place cards aren't very useful in such cases. However the PerfectTablePlan

VDU Chart pane can help you to display and update the seating on a large
screen at the venue and/or export to web can display the seating on any web-
enabled devices (e.g. iPads issued to assistants). 

Example real time seat assignment setup
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Displaying seating assignments on a large screen

Before the event:

1. Create a plan. Mark any guests you expect to attend as having RSVP=
Accepted. Optionally assign them seats.

2. Set up the appropriate colours, fonts, number of columns etc in the VDU
Chart pane.

At the venue:

1. Set up 2 computers at the event. Ideally they should both have the same
version of PerfectTablePlan installed. One is the 'master' and will be used to
assign seats. The other is the 'slave' and will be used to display scrolling text
on a large screen (e.g. a plasma display). 

2. Ensure you have networking set up so the 'slave' can read files in a shared
folder on the 'master'. Or you can use a shared DropBox folder to share a
folder via the Internet.

3. Ensure that the 'slave' is able to display on a large screen.

4. On the 'slave' set When read-only plan updated to Reload without

prompting in the General tab of the Preferences window. 

5. On the 'master' select View>Output, bring the VDU Chart pane to the
front and File>Save the plan file. 

6. On the 'slave' File>Open the plan file from the shared folder as read-only.

Press the  button at the top of the VDU Chart pane if the text isn't

scrolling. Then press the  button to display full screen. 

Note Read-only plans and automatic updating only works on the Windows
version of PerfectTablePlan, so the 'slave' must be running Windows. The
'master' can be running Windows or Mac.

During the event:

1. As guests arrive use the 'master' to: 

http://db.tt/LgLLuIG
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a. Change their status to RSVP= Arrived. You can do this more quickly if
you print a barcode on their ticket/invitation/badge and check them in
using a barcode scanner. 

b. Assign them to seats (using drag and drop or automatic seat assignment)
if they don't already have a seat and lock them in place. 

c. File>Save your changes on the 'master'.

2. The 'slave' should pick up your changes and refresh the VDU Chart pane
automatically.

3. You can monitor seat assignments in the Floor Plan pane on the 'master'.

Displaying the seating on iPads or other web-
enabled devices

Before the event:

1. Create a plan. Mark any guests you expect to attend as having RSVP=
Accepted. Optionally assign them seats.

At the venue:

1. Set up a laptop with the plan. Ensure the laptop and all the web-enabled
devices have Internet access (e.g. through wifi).

2. Select File>Export. 

3. Select guests and floor plan (detailed) to
http://webexport.perfecttableplan.com (or guests and floor plan
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(minimal) to http://webexport.perfecttableplan.com if you don't want
to export personal data such as VIP states and guest notes).

4. Check Create a new email with the document added.

5. Click OK. Accept the terms of use, if they appear.

6. Email a link to the plan to everyone who is going to access it from their iPad
or other web-enabled device. 

7. Have all the people with web-enabled devices click on the link they have been
emailed to display the plan in a web browser.

During the event:

1. As guests arrive use the laptop to: 

a. Change their status to RSVP= Arrived. You can do this more quickly if
you print a barcode on their ticket/invitation/badge and check them in
using a barcode scanner. 

b. Assign them to seats (using drag and drop or automatic seat assignment)
if they don't already have a seat and lock them in place. 

c. File>Save your changes.

d. Re-export the plan to web.

2. The web-enabled devices should pick up your changes and refresh the plan.
They can use the up-to-date information to guide guests to their seats.

Contingency planning

If you are going to attempt either of the above at a sizeable event, we
recommend you try practising it first! You also need to have plans in place in
case a laptop, the network or a plasma screen fails. In the unlikely event of
PerfectTablePlan crashing, you should be able to retrieve previous version from
the automatic backups.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

https://www.perfecttableplan.com/video/assignv7.html
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· VDU Chart pane

· Display seating on a VDU or plasma screen

· Export to web, iPad and other devices

· Multi-user/computer access

3.2.7 Check where a guest is seated across multiple seatings

Advanced and Professional editions only

You can check which table a guest is seated on across multiple plans using

the Multi-plan (guest seating) report in the Report pane. You can
File>Print or File>Export this report to give to people for networking
events.

See also:

· Check who a guest was seat next to at previous events
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3.2.8 Check who a guest was seated next to at previous events

Advanced and Professional editions only

Multi-plan report

You can use the summary, pairs and matrix Multi-plan reports to see who
a guest was sat next to (or on the same tables as) across multiple events. 

See also:

· Arrange multiple seatings for an event

· Check where a guest is seated across multiple seatings

3.2.9 Improve the auto seat assignment

PerfectTablePlan scores each seating arrangement on how good it is according
to various factors, including: whether guests are seated according to their next
to/near to/not next to/not near to proximities, whether guests have empty seats
next to them, whether males are sat next to females etc. The total score is
shown in the Status bar.

When you run the auto seat assignment it tries to find the highest possible
scoring seating arrangement using a genetic algorithm. If you don't like the
results you can Edit>Undo them.

The longer it runs for, the more combinations it can try, and the better your
seating arrangement is likely to be. A few seconds is probably enough for 50
guests. But you might want to run it for an hour or more if you have >2000
guests, especially if your computer isn't very fast. 

In the Auto assign tab of the Preferences window you can change:

· how long the auto assign runs for
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· whether to alternate males and female

· whether to seat guests opposite or left/right of each other on narrow tables

· whether to sit female partners to the left or right of their male partners

You can run the auto seat assignment as often as you like. Each time you run it,
it will start with the current plan and try to improve on it. You can stop at any
time and the best solution found so far will be displayed.

You can colour code guests according to their seating score. Happy guests (e.g.
those sat next to guests with 'next to proximity') are shown in green. Unhappy
guests are shown in red.

No matter how long you run it for, PerfectTablePlan can't guarantee to find the
mathematically optimal (highest scoring) solution. This is because the number of
combinations for even a small table plan is mind-bogglingly large. However
PerfectTablePlan will usually get quite close, fairly quickly. Also the auto seat
assign is only as good as the proximities you provide. 
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A combination of auto seat assignment and drag and drop often gives the best
results. Lock any guests that you don't wish the auto seat assignment to move
next time you run it.

You can also select a seat and choose Edit>Guest Suggestions to get a
ranked list of guests to place in this seat. The difference that assigning this
guest will make to the overall seating score is shown in brackets. Select a guest
if you want to place them in the seat (swapping them with any existing guest). 

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

· Automatic seat assignment

· Keep groups together

· Only assign guests who have accepted

· Assign seating by guest type/category

· Assign multiple seatings for an event

3.2.10 Keep groups together

Sometimes you want to keep groups together and sometimes you want to split
them up.

To keep a group together when manually dragging them to a seat either:

· hold down the Shift key and then drag any guest in the group; or

https://www.perfecttableplan.com/video/assignv7.html
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· drag the group icon from the Groups pane

To keep a group together during automatic seat assignment, make the guests in

the group have Next to proximity to each other. Also, each guest can sit next

to a maximum of 2 people, so don't over-specify the seating with too many 
Next to proximities per guest.

Even with proximities correctly set, the automatic seat assignment will
sometimes split up groups. This might be because it is trying to balance lots of
different factors (such as alternating gender, minimizing empty seats and
custom proximity) not just guest proximity. But it may also be because
combinatorial problems, such as seating, are really hard, even for a computer!
Often you can improve the automatic seat assignment by running it again.
Maybe set it to keep running while you have a long lunch.

Once a group is assigned to seats you can lock them, to prevent them being
accidentally moved.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

· Improve the auto seat assignment

 

3.2.11 Lock guests to seats

You can lock guests to a seat (or to no seat) to stop them being re-assigned by
drag and drop or automatic seat assignment.

To lock (or unlock) the seat assignment for a guest:

1. Select the guests.

2. Right-click and select Guest Property>Locked>Yes (No) from the pop-up
menu or use the keyboard accelerators Ctrl+K/Shift+Ctrl+K.

https://www.perfecttableplan.com/video/assignv7.html
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You can also lock all the guests in a group or at a table by right-clicking on the
group/table and selecting Guest Property>Locked>Yes from the pop-up
menu.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

3.2.12 Only assign guests who have accepted

To assign to seats only those guests who have accepted your invitation:

1. Select Edit>Preferences. The Preferences window will be displayed.

2. Select Accepted in the Allow seat assignment with RSVP drop-down
menu.

3. Click OK.

https://www.perfecttableplan.com/video/assignv7.html
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4. If you have unaccepted guests assigned you will have the option to unassign
them. Click Unassign.

5. If you have unassigned guests select File>Auto Assign Seats. Only guests
who have accepted will be assigned to seats.

See also:

· Assign guests to seats (video with audio, 13:01 minutes)

· RSVP status

3.2.13 Seat couples on the same table but not adjacent

If you want to automatically assign couples to sit on the same table, but not on

adjacent seats, you should set them to have Near not next to proximity.

You can set this to be the default for couples in Preferences.

3.2.14 Use social distancing

The PerfectTablePlan automatic seating algorithm will usually try to minimize the
number of empty seats between guests. If you want it to socially distance guests
(by putting empty seats between different groups) you can check social
distancing in the Auto assign tab of the Preferences window.

https://www.perfecttableplan.com/video/assignv7.html
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For social distancing to work you need to have more seats than guests. Ideally,
at least one extra seat per group.
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See also:

· Check social distancing

3.3 Charts

3.3.1 Add a chart title/footer

To add a title/header/footer to the Table Chart, Guest Chart or VDU
Chart pane:

1. Click on the  button at the top of the pane.

2. Click on the Title or Footer button.

3. Set the title/footer text, size and colour.
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4. Click OK.

3.4 Exporting

3.4.1 Choose a format to export to

· To create an electronic version that can be accessed by a standard web

browser but is not guaranteed to be confidential, choose web export.

· To create a high quality image suitable for printing to large sizes, choose PDF.

· To create a medium quality image suitable for printing to smaller sizes, choose

PNG.

· To create a low quality image suitable for emailing (but not printing), choose

JPG.

· To import into Word or create a web page, choose HTML.

· To import into Excel choose Excel.

· To import into a database or other application, choose CSV.

For more details see exporting.

3.4.2 Export a chart/report to Excel/Word

To export the contents of the Guest Chart, Table Chart or Report pane
to Microsoft Excel or Word:

1. Bring the Guest Chart , Table Chart or Report pane to the front.
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2. Select Edit>Copy from the menu bar (not Ctrl+C, this only copies selected
text).

3. Start Excel/Word.

4. Select Edit>Paste in Excel/Word.

Alternatively just click the  or  buttons at the top of the pane.

See also:

· Export guest and seating data to Excel

3.4.3 Export guest and seating data to Excel

To export guest and seating data into a form that can be used in Excel:

1. Select File>Export. The Export window will appear.

2. Select guest and seating data to Excel/CSV/delimited text file and click

OK. The Export Data window will appear.

3. Select whether you want to export a record per guest or per group and
check/uncheck the appropriate check boxes. Leave the format as Excel.

4. Edit the Export file field or click on the Browse... button to set the output
file.

5. Click OK.

Excel can also read CSV format files.

See also:

· Export a chart/report to Excel/Word
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3.4.4 Export to web, iPad, Android and other devices

You can export to web and access your plan via any web-enabled device,
including an iPad. The web version of the plan contains all the information about
guests, groups and tables. For example, you could have a single laptop running
PerfectTablePlan at a venue and 5 people viewing the plan using a web browser
on their iPads via wifi. Any changes you make on the laptop and export to the
web are then pushed out simultaneously to all 5 iPads.
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Hovering over a guest in the left pane shows where they are seated in the right
pane. You can also search guests and groups.

You can’t edit the plan from a web browser, but you can re-export your plan to
web and anyone looking at the plan in a browser will automatically be prompted
on whether they wish to load the updates.

Note Web export is via our server. We provide this as a free service. We do not
guarantee 100% availability.
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If the device has an email connection and can display PDFs you can also export
to PDF and then email it to the device as an attachment. You can also share
PDFs with an iPad using DropBox or iTunes + the free iBooks app.

See also:

· Export to web or tablet (video with audio, 2:29 minutes)

3.4.5 Export to PDF format

PDF is a vector image format popularised by Adobe Acrobat. Many print shops

will prefer PDF format if you want to print the Floor Plan, Table Chart , 

Guest Chart or Stationery pane to poster size. For example, to export the

Floor Plan pane as a PDF:

1. Select File>Export, the Export window will appear.

2. Select floor plan to PDF/PNG/JPG/BMP image file.

3. Click OK, the Export Floor Plan window will appear.

4. Select the file type as PDF, choose a file name and location and click Save,
the Export PDF window will appear.

5. Select the appropriate Size and Orientation for the PDF and click OK.

If you have problems with built-in PDF export you can also export PDFs
indirectly, as described below.

Creating PDFs indirectly on Windows

On Windows you can use the free PDF-Creator software. Once installed PDF-
creator appears as a another printer, but when you print to it creates a PDF
document.

· PDF-creator home page

· PDF-creator download page

· PDF-creator readme file

Note that PDFs produced by PDF Creator are likely to be lower quality than PDFs
produced by exporting. However the PDF file may also be significantly smaller.

http://db.tt/LgLLuIG
http://www.screencast.com/t/1GyQVEmy6M
http://sourceforge.net/projects/pdfcreator/
http://prdownloads.sourceforge.net/pdfcreator/PDFCreator-0_9_0_GPLGhostscript.exe?download
http://prdownloads.sourceforge.net/pdfcreator/readme-0_9_0.txt?download
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We are not able to offer any support for third party software. Use of third party
software is entirely at your own risk.

Checking the output

You can check that the PDF output is acceptable using the free Adobe Acrobat
reader. Many web browsers can also read PDF files.

3.5 Floor plan

3.5.1 Add a dance floor, stage etc to the floor plan

You can use rectangular, square, elliptical or circular shapes to represent floor

plan features such as dance floors and stages. Click on the Shape button at

the top of the Floor Plan pane to add a shape to the floor plan.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

http://www.adobe.com/products/acrobat/readstep2.html
http://www.adobe.com/products/acrobat/readstep2.html
https://www.perfecttableplan.com/video/floorplanv7.html
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· Add a graphic/image/clipart to the floor plan

· Add walls to the floor plan

· Add a title or text into the floor plan

3.5.2 Add a graphic/image/clipart to the floor plan

To add an image to the Floor plan pane either:

1. Drag the image from Windows Explorer or a web browser onto the Floor
plan pane.

2. Double-click on the image to change its size, rotation etc.

Or:

1. Click on the Insert Image button at the top of the Floor plan pane. The

Insert Image window will appear.

2. Click on the Browse... button and select an image file.

3. Set the image Size on the floor plan.

4. Click Add.

5. Click on the image and drag it to the appropriate position.
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See also:

· Floor plan images (video with audio, 1:11 minutes)

· Create a floor plan (video with audio, 10:27 minutes)

· Find free clipart

· Find free textures

· Use an image of the venue

· Add a dance floor, stage etc to the floor plan

· Add a title or text into the floor plan

3.5.3 Add a title or text into the floor plan

To add a title or text into the floor plan:

1. Click the Insert text button at the top of the Floor Plan pane. The 
Insert Text window will appear.

2. Set the text, angle, font and colour.

3. Click OK. The new text item will be added.

http://www.screencast.com/t/63rHBbXX
https://www.perfecttableplan.com/video/floorplanv7.html
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4. Drag the new text item to the appropriate position.

Double-click on the text item if you wish to edit it later.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Add a dance floor, stage etc to the floor plan

· Add a graphic/image/clipart to the floor plan

3.5.4 Add walls to the floor plan

Click on the Insert Line button to draw a wall. Click on each corner in turn
and double-click to finish. Press the Escape key to cancel. You may find it easier
to place the lines with grid snap on. You may also need to zoom in.

https://www.perfecttableplan.com/video/floorplanv7.html
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See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Add a dance floor, stage etc to the floor plan

3.5.5 Align items

You can easily align the centres of tables and other items to a grid by turning on
grid snap.

You can also align selected items into a vertical or horizontal line using the 

Align vertical and Align horizontal buttons in the Floor plan pane.

https://www.perfecttableplan.com/video/floorplanv7.html
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You can move selected items using the mouse or keyboard arrow keys. If you
press an arrow key when grid snap is on, the item will be moved one grid
position. If you press an arrow key when grid snap is not on, the item will be
moved 5 cm/2 inches (1 cm/0.4 inch if the Shift key is held down).

If you depress the  button at the top of the Floor plan pane, guides lines
will be drawn when you move a single floor plan item. 

Professional edition only

You can use the Table Layout window to quickly lay out tables in a wide
range of configurations.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Space tables correctly

· Select multiple items

3.5.6 Change how seats and guest names are displayed

To change how the names of guests are displayed in the Floor plan and 
Table plan panes (e.g. J. Smith or Mr John Smith):

https://www.perfecttableplan.com/video/floorplanv7.html
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1. Click the  button at the top left  of the pane.

2. Select the appropriate entry from the Display drop-down list.

To change how seats are displayed in the Floor plan and Table plan
panes:

1. Click the  button at the top left of the pane.

2. Select the appropriate entry from the Seats drop-down list.
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Example layouts for different Seats settings:

Circular+name

Rectangular+na
me

Chair+name
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Square
image+name

Circular
image+name

Circular

Rectangular
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Chair

Square image

Circular image

Name only
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Name only
(radial)

Name only
(banquet)

None

Circular seats are the easiest to drag onto. You can always change to a more
aesthetic layout later.

Note If the name of a guest can't be fitted into the space available in the 

Floor Plan or Table Plan pane, the font will automatically be scaled smaller
for that name to make it fit. 

See also:

· Names and titles

· Show unassigned seats

· Show VIP/Special/RSVP/Locked
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3.5.7 Change the size of the room

To change the size of the floor plan:

1. Click on the Dimensions button at the top of the Floor Plan pane.

2. Set the Size across and down of the room in the appropriate Units.

3. Click OK.

You can also change the size of the floor plan by dragging the bottom-right
corner.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Create a non-rectangular room

· Handle multiple rooms

· Space tables correctly

3.5.8 Check social distancing

To show social distancing between groups in the Floor Plan pane:

1. Click on the  button at the top-left of the pane.

2. Click on the  button to show the Table/Seat Spacing window. 

3. Set Space to Seats.

https://www.perfecttableplan.com/video/floorplanv7.html
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4. Set Units and Spacing between seats according to the minimum social
distance spacing.

A coloured guide will appear around each seat according to the parameters in
the Table/Seat Spacing window. The guide will have a diameter equal to
Spacing between seats. This makes it easy to see whether seats are too close
to each other as their circles will overlap. You can control the Colour and
Transparency of these guides. No guides will be drawn for empty seats if
empty seats are hidden.

The guide is centred approximately on the position of the occupant's nose and
mouth, so it is suitable for calculating social distancing.

Press and hold down the Check Social Distancing button to see any guests
from different groups that are sat closer than the Spacing between seats
distance.

You can colour guests by group so you can see if guests close to each other are
in the same group.

Click the  button again to turn off the spacing guides.

See also:

· Use social distancing

· Space seats correctly
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· Space tables correctly

3.5.9 Create a curved row of seats

To create a curved row of seats,  Insert>Row of Seats... and then set the
Curve angle to greater than 0.

See also:

· Row of seats

3.5.10 Create a non-rectangular room

To create a non-rectangular room (e.g. 'T' shaped or 'L' shaped) you can either:

1. Add Walls to the Floor Plan pane.

or

1. Click the Dimensions icon at the top of the Floor Plan pane.
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2. Set Size across and down to the maximum dimensions of the room and
click OK.

3. Click the Insert shape icon at the top of the Floor Plan pane.

4. Create a shape equal to the same size as an unusable area of the room, set it
to the same colour as the outside of the floor plan and click OK.

5. Drag the shape to the appropriate position.

6. Repeat 3, 4 and 5 as necessary.

Advanced and Professional editions only

If you have a scale image of the venue you can use it as the background to
the floor plan.
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See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Create a re-usable template plan

· Add walls to the floor plan

· Change the size of the room

· Handle multiple rooms

3.5.11 Find free textures

We install a range of textures with PerfectTablePlan. Usually these are installed
into sub-folders of your Documents\PerfectTablePlan\textures folder.

https://www.perfecttableplan.com/video/floorplanv7.html
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These textures all tile seamlessly, i.e. you can't see the joins where one tile ends
and the next begins. There should be no need to mirror them.

Storing large texture images in your plan will make your plan file large and may
slow down PerfectTablePlan.
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You can use tools such as Google image search to find textures. Many are
available free of charge. Search for terms such as "seamless textures". You can
also find good quality free textures on a number of web sites, including:

http://www.goodtextures.com/

http://www.3d-diva.com

http://textures-seamless.blogspot.it/

http://seamless-pixels.blogspot.co.uk/

http://textures101.com

http://zooboingreview.blogspot.co.uk

Ideally a texture image should be in PNG or high quality JPG format and should
have at least 40 pixels for each cm (100 pixels for each inch) that you want to
print it at. E.g. If you want to repeat your texture every 2.5 cm (1 inch) across
on your printout, it should be at least 100 pixels across.

Make sure you comply with the copyright/licensing terms of any textures you
use. See the .txt file in the textures folder for more details on licensing of the
textures we install with PerfectTablePlan.

See also:

· Select Texture window

· Find free clipart

3.5.12 Handle multiple rooms

If you have multiple rooms you can simulate this by adding an appropriately
sized rectangle shape to the floor plan for each room. 

1. Click on the Dimensions button to change the floor plan size.

2. Click on the Insert shape button to add shapes to the floor plan.

3. Click on the Move to Back button to move the rectangle shape behind any
tables. 

Setting each room to a different colour may be a useful visual cue.

http://www.goodtextures.com/
http://www.3d-diva.com
http://textures-seamless.blogspot.it/
http://seamless-pixels.blogspot.co.uk/
http://textures101.com
http://zooboingreview.blogspot.co.uk
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Alternatively you can add walls.

See also:

· Change the size of the room

· Add walls to the floor plan

· Create a non-rectangular room

· Use an image of the venue

3.5.13 Hide empty seats

You can hide empty seats in the Floor plan and Table plan panes by
checking Hide empty seats. This can be useful if you want to show gaps in
your seating.
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Note Hiding seats makes no difference to the automatic seat assignment
algorithm.

See also:

· Create rectangular tables with seats on 1,2 or 3 sides

· Create sweetheart/cabaret tables

3.5.14 Make all names have the same font size

Some times you will see that different names have different font sizes. This is
because we can't display all the names at the font size you have chosen. So we
automatically set the longer names to a smaller font, to stop them being
truncated.
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If you want the names to use the same font size, you need to either:

1. Shorten the names (e.g. use initials); or

2. Reduce the font size.

You can automatically set the biggest font size that doesn't require any scaling

by clicking the Auto size button in the Fonts and Colours window.

You might also find that it helps to change the name layout to Name only
(radial) or Name only (banquet).

Changing the font family can also help sometimes.

See also:

· Print legible plans on a small format printer

3.5.15 Show custom fields

Advanced and Professional editions only

To show custom field values of type Yes/No, Selection or Tags in the 

Floor Plan or Table Plan pane:

1. Click on the  button at the top-left of the pane. 

2. Click on the appropriate custom field button. You can change the colours

used in the Visualization colours window.
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Note that this is only possible if a seat is displayed (e.g. not for Seats set to
Name only).

Depress the  button at the top of the pane to show a colour key.

You can also set the Display drop-down list to show the values of a custom
field.

See also:

· Add custom fields

· Show gender

· Show groups

· Show meals

· Show VIP/Special/RSVP/locked

· Add a colour coded spot to the stationery

3.5.16 Show gender

To show gender in the Floor Plan or Table Plan pane:

1. Click on the  button at the top-left of the pane.

2. Click on the Gender button. Males will be shown in blue and females in

pink. You can change the colours used in the Visualization colours
window.
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Note that this is only possible if a seat is displayed (e.g. not for Seats set to
Name only).

Depress the  button at the top of the pane to show a colour key.

See also:

· Show custom fields

· Show groups

· Show meals

· Show VIP/Special/RSVP/locked

· Add a colour coded spot to the stationery

3.5.17 Show groups

To show groups in the Floor Plan or Table Plan pane:

1. Click on the  button at the top-left of the pane.

2. Click on the Groups button. Each group will be shown in a different colour

(or combination of colours). You can change the colours used in the 
Visualization colours window.
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Note that this is only possible if a seat is displayed (e.g. not for Seats set to
Name only).

Depress the  button at the top of the pane to show a colour key.

See also:

· Groups

· Show custom fields

· Show gender

· Show meals

· Show VIP/Special/RSVP/locked

· Add a colour coded spot to the stationery

3.5.18 Show meals

To show meal selection in the Floor Plan or Table Plan pane:

1. Click on the  button at the top-left of the pane.
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2. Click on the Meals button. Each meal will be shown in a different colour (or
combination of colours if you have multiple courses separated by commas).

You can change the colours used in the Visualization colours window.

Note that this is only possible if a seat is displayed (e.g. not for Seats set to
Name only).

Depress the  button at the top of the pane to show a colour key.

You can also set the Display drop-down list to Meal.

See also:

· Meal selection

· Show custom fields

· Show gender

· Show groups

· Show VIP/Special/RSVP/locked

· Add a colour coded spot to the stationery

3.5.19 Show unassigned seats

To show unassigned seats in the Floor Plan or Table Plan pane:

1. Click on the  button at the top-left of the pane.
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2. Set the Tables drop-down list to Name+unassigned. The number of
unassigned seats will be shown in the centre of each table and unassigned
seats will be shown with a red cross.

3.5.20 Show VIP/Special/RSVP/locked

To show VIP/Special/RSVP/locked status in the Floor Plan or Table Plan
pane:

1. Click on the  button at the top-left of the pane.

2. Click on the appropriate button.

Note that this is only possible if a seat is displayed (e.g. not for Seats set to
Name only).

See also:
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· RSVP status

3.5.21 Space seats correctly

To show spacing guides around seats in the Floor Plan pane:

1. Click on the  button at the top-left of the pane.

2. Click on the  button to show the Table/Seat Spacing window. 

3. Set Space to Seats.

4. Set Units and Spacing between seats.

A coloured guide will appear around each seat. The guide will have a diameter
equal to Spacing between seats. This makes it easy to see whether seats are
too close to each other as their circles will overlap. You can control the Colour
and Transparency of these guides. No guides will be drawn for empty seats if
empty seats are hidden.
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The guide is centred approximately on the position of the occupant's nose and
mouth, so it is suitable for calculating social distancing.

You can colour guests by group so you can see if guests close to each other are
in the same group.

Click the  button again to turn off the spacing guides.

Note The circular seats are not a realistic size. You may be better off using
rectangular seats, chairs or not displaying the seats.

See also:

· Check social distancing

· Space tables correctly
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· Change how seats and guest names are displayed

3.5.22 Space tables correctly

To show spacing guides around tables in the Floor Plan pane:

1. Click on the  button at the top-left of the pane.

2. Click on the  button to show the Table/Seat Spacing window. 

3. Set Space to Tables.

4. Set Units, Spacing from side with seats and Spacing from side without
seats.

A coloured guide will appear around each table. This makes it easy to see
whether tables have been placed too close to each other. You can control the
Colour and Transparency of these guides. 

Click the  button again to turn off the spacing guides.

Typically it is reckoned that the following spacings are a minimum for allowing
guests and staff to move between tables:
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These equate to values for Spacing from side with seats and Spacing from
side without seats of 0.75m and 0.3m respectively. These are set as the
default values.

Note The circular seats are not a realistic size. You may be better off using
rectangular seats, chairs or not displaying the seats.

If most of your tables are the same size and shape and you want to space them
evenly, you can create a snap grid of the appropriate size. For example, if your
tables are 2m in diameter and you want 1.5m between them, you can create a
3.5m snap grid to snap the table centres to.

Spacings are not shown for rows of seats.

Professional edition only

You can use the Table Layout window to quickly lay out tables in a wide
range of configurations with a choice of horizontal and vertical spacings.
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Important Don't forget about emergency exit routes and fire regulations when
you set-up your floor plan.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Check social distancing

· Space seats correctly

· Change the size of the room

· Turn the floor plan grid on/off

· Align tables

3.5.23 Turn the floor plan grid on/off

The floor plan has 2 separate grids - a drawn grid (for display only) and a snap
grid (which 'snaps' the centres of items to a discrete position). Every fifth line of
the drawn grid is shown darker to make it easier to count grid squares. To turn
these grids on/off:

1. Click the Dimensions button at the top of the Floor Plan pane. The 
Dimensions window will be displayed.

https://www.perfecttableplan.com/video/floorplanv7.html
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2. Check/uncheck the Draw grid check box to turn the drawn grid on/off.

3. Check/uncheck the Snap to grid check box to turn the snap grid on/off.

4. Change the Units drop-down list or Size fields to change the grid sizes.

5. Click OK.

Note If you want to print or export the grid you have to check Draw grid and

include in print/copy/export in the Dimensions window.

See also:

· Create a floor plan (video with audio, 10:27 minutes)

· Dimensions window

· Align tables

· Space tables correctly

3.5.24 Use an image of the venue

Advanced and Professional editions only

If you have a scale image of the venue you can use it as the background to
your floor plan. This can save you a lot of time drawing walls, doors and
other features.

Note If your image is in PDF format, you will need to convert to an image
format (such as PNG) before you can import it to PerfectTablePlan. There
are various ways to do this, for example you can use an online PDF to PNG
converter such as zamzar.com, easypdf.com or pdf2png.com (use of third
party websites is at your own risk). Our you can do a screen capture of the
PDF and save it as a PNG image file.

1. Click on the Dimensions button at the top of the Floor plan pane.

The Dimensions window will appear.

2. Click on the Browse... button and select an image file.

https://www.perfecttableplan.com/video/floorplanv7.html
https://www.zamzar.com/convert/pdf-to-png/
https://easypdf.com/pdf-to-png
http://www.pdf2png.com
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3. Set the Background image size to the size the image should be in the
floor plan (in metres or feet). It is important you get this correct or the
floor plan won't be to scale (see below).

4. Click OK.

5. You can now place tables and other floor plan items on top of the floor
plan image.

scaled floor plan image image used as floor plan background with
tables added

Scaling the image correctly

If you are using an image of the venue as a background image, it is
important to scale it correctly. This is easy as long as you know the size of a
feature on the floor plan:

· Add a background image, if you haven't done so already (see above).
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· Identify a feature in the floor plan that you know the size of. This might be

a scale marked on the floor plan or a wall or stage whose dimensions are
known. For accuracy, the bigger the feature the better. Zoom in/out so
this feature fills most of the screen.

· Click the  button at the top of the Floor plan pane.

· The Scale Background Image window will appear. Choose Free,

Horizontal or Vertical depending on the orientation of the feature
identified.

· Click on one end of the feature. Release the mouse button (it isn't a drag

operation).

· Move the mouse pointer to the other end of the feature. An arrow will be

drawn between the mouse position and the first position clicked.

· Click on the other end of the feature.
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· The Feature Measurement window will appear. Enter the size of the

feature on the background image in the appropriate units. E.g. if the
feature should be 5 metres in size, enter 5.00 metres. Generally you will
want to leave auto size room to image checked, so that the room is
sized to the image.

· Click OK. The background image will now be scaled so that the feature you

identified is the correct size.

· If you aren't happy with the results you can Edit>Undo the changes.

You can verify the feature is now the correct size by creating a rectangle of
an appropriate size and comparing it to the feature in the background
image.

Hint When the Feature Measurement window appears, it shows the
length of the arrow on the floor plan. This can be useful for measuring the
distance between two points. Click Cancel if you don't want to change the
scale.

See also:

· Scaled venue images (video with audio, 2:06 minutes)

See also:

http://www.screencast.com/t/JMiQZoXZa
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· Create a floor plan (video with audio, 10:27 minutes)

· Change the size of the room

· Add walls to the floor plan

· Turn the floor plan grid on/off

3.5.25 Zoom in/out of the floor/table plan

To zoom so all items are visible click the Zoom all button at the top of the
pane.

To zoom in click the Zoom in button at the top of the pane.

To zoom out click the Zoom out button at the top of the pane.

If your device supports gestures, you can also use a 'pinch' gesture to zoom in
and out.

Toggle the  button on/off to magnify the area under the mouse cursor.
Magnification allows you to read a large plan without having to zoom in and out.

You can pan from side to side while zoomed in by left-clicking on the Floor
Plan pane background and dragging it.

You can also zoom and pan using the wheel on your mouse (if you have one)
depending on the Floor/Table Plan pane mouse wheel behaviour settings

in the Preferences window.

3.6 Groups

3.6.1 Change the order of guests in a group

To change the order in which guests are displayed within a group, for example in

the Table Chart , Guest Chart or Stationery pane:

· Double-click on a group in the Groups pane (or a guest belonging to that

group in the  Guests or Groups pane).

· In the Group tab, change the guest order by:

o Selecting 1 or more guests and clicking the Up or Down buttons; or

https://www.perfecttableplan.com/video/floorplanv7.html
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o Dragging the guests to new positions

Note Guest order in the Groups pane depends on how the pane is sorted, not
on the order in the Group tab.

3.6.2 Insert a new guest into an existing group

To add a guest to an existing group:
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1. Select Insert>Single Guest, the Insert Guest window will appear.

2. Choose Add to existing from the Group drop-down list in the Group tab.

See also:

· Move a guest from one group to another

· Change the order of guests in a group

· Groups

3.6.3 Move guests from one group to another

Select the guest in the Groups pane and drag them to the appropriate group. 

Alternatively you can use Edit>Change Group or set the Guests pane Mode
to Edit and edit the Group column.
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Note that changing does not change a guest's proximity for the automated

seating. You can change the proximity of a couple to Next to by selecting
both guests and then selecting Edit>Proximity>Next to.

You can delete any empty groups from the Groups pane once you have
finished.

See also:

· Insert a new guest into an existing group

· Change the order of guests in a group

· Groups

3.7 Guests

3.7.1 Add custom fields

Advanced and Professional editions only

Sometimes you need to record information about a guest that does fit into
the standard fields. You can use a custom field to do this. To add a custom
field:

1. Select Edit>Custom fields... .

2. Click the Add button.

3. Select the Type (+Allowed values for selection type) and Default
value.

4. Click OK.
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You can also create custom fields during import by selecting <custom
field> from the drop-down menu at the top of an import column.

Custom fields are fully integrated into PerfectTablePlan. For more
information see Custom fields.

See also:

· Custom fields (video with audio, 1:52 minutes)

3.7.2 Add or remove dots at the end of titles

“Mr” (without a dot) is standard in the UK and “Mr.” (with a period) is standard
in the USA (ref: Longman Guide to English Usage 1988). In the interests of
international relations you can toggle between the two by using the Ctrl+period
(in the Main window hold down the Ctrl key and press the '.' (period) key). If
you don’t like the results you can undo them.

If you want to use “Mr.” (with a period) as standard you should edit the titles

available in the Titles tab of the Preferences window.

http://www.screencast.com/t/rmEExtrO
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See also:

· Customize standard guest titles

3.7.3 Check-in guests

You can use PerfectTablePlan to check-in guests electronically as they arrive at
an event. You can use barcodes and a USB scanner to speed up this process.
You can even (re)assign seats in real time as guests arrive.

3.7.4 Copy guests from one plan to another

Just drag the guests from one plan to the other:

1. Start 2 instances of PerfectTablePlan.

2. Select the guests you want to copy from the Guests or Groups pane of
the first instance of PerfectTablePlan (Ctrl+A to select all).

3. Drag the guests/groups to the Guests pane of the second instance of
PerfectTablePlan.

You can also export the guest data to a .csv file and re-import it, but drag and
drop is easier.

Custom fields are not copied when you drag guests between 2 plans. If you want
to preserve custom fields you need to export the guest data to .csv and import.

See also:

· Create a re-usable template plan

3.7.5 Customize standard guest titles

You can add your own custom titles to PerfectTablePlan. These could be military
or Masonic titles or foreign language equivalents of Mr/Mrs/Master/Miss. These
custom titles can have default gender, age and VIP status, which is particularly
useful when you are importing guests with known titles.

To add custom titles:

1. Open the Preferences window.

2. Select the Titles tab.
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3. Either:

· Click on Add, to add one title with a default gender, age and VIP status; or

· Click on Import from current plan to import all the titles in the current plan;

or

· Click on Add text list... to paste in a text list, one per line; or

· Click on Add pre-defined to add one of the pre-defined lists.

4. Click OK.

You may also wish to set the Default couple titles.

See also:

· Handle post nominal titles

· Edit a property for multiple guests

· Add or remove dots at the end of titles

· Assign seating by order of precedence

3.7.6 Edit a property for multiple guests

To change a property for multiple guests in a single operation:

1. Select multiple guests in the Guests,  Groups, Floor plan, Table

plan or Schematic panes using Ctrl+click/Shift+click (Ctrl+A to select all).
Note that you can select tables or groups to edit the properties of all guests
sat at those tables or belonging to those groups.

2. Select Edit>Guest Property and then choose the appropriate property and
value. Choosing ... will display the Edit Guest Property window.

Or

1. Use the Replace Text window (text properties only).

Note You can use menu keyboard accelerators to access this menu without using
the mouse. For example, you can type Alt+E+Y+G+M to change the selected 
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guests to Male. This is quicker than using the mouse to select Edit>Guest
property>Gender>Male. Hold down the Alt key to see the menu keyboard
accelerators.

See also:

· Edit multiple guest properties (video with audio, 1:48 minutes)

· Select multiple items

· Change proximity for multiple guests

3.7.7 Handle guests with unknown names

If you don't know the name of a guest you can just check the Anon check box.
A name will then be created for them automatically, based on their group name.

Or you can import anonymous guests using a Num. guests or Num. in group

column in the Import Data window:

Or use "+n" in the Quick Add Guests window:

http://www.screencast.com/t/yqNwB3wy
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You can uncheck the Anon box and add their name if you find it out later.

3.7.8 Handle post-nominal titles

Most titles come before the name, e.g. Dr, Herr, Colonel etc. These are handled

by the Title field in the Guest Properties window. 

However some titles come after the name, e.g. PhD or MBE (post-nominals).

These are best handled by adding them individually to the Suffix field in the 
Guest Properties window. For example you might have:

Field Example

Title Sir

First name(s) John

Last name(s) Smith

Suffix PhD
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Display name Sir John Smith PhD

You can add a list of standard suffixes to the Suffixes tab of the Preferences
window. These suffixes will then be available on the Suffix drop-down list in
every plan. PerfectTablePlan will also be able to recognize them as suffixes
during import.

See also:

· Names and titles

· Customize standard guest titles

3.7.9 Keep guests in import order

PerfectTablePlan doesn't preserve the order that guests are imported. 

Advanced and Professional editions only

If you want to keep the guests in the same order that you imported them:

1. Add a column with the numerical order to the guest list, before you
import it.
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2. Import this column as a custom field of type Number. 

3. Order guests by clicking on the header of the order column (click a

second time to reverse the order) or using the Multi-level Sort window.

See also:

· Assign seating by order of precedence
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3.7.10 Order guests by title or suffix

You can order guests non-alphabetically by their title or suffix in the Guests

pane and Groups pane. 

Order by title

Enter all the titles into the Titles tab of the Preferences window.

· If you have already imported guests with their titles use Import from

current plan.

· If you have a text list, you can paste it in using Add text list....

· Or you might be able to use one of the lists provided in Add pre-defined....

Sort your titles into order using the Up and Down arrows, with the highest
ranking at the top.

Set Sort titles in 'Guests' and 'Groups' pane to As shown above.
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Go to the Guests pane and click on the Title column The guests will now be
sorted by their title, in rank order. Click again to reverse the order.
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Order by suffix

Similarly you can order non-alphabetically by suffix using the Suffixes tab of

the Preferences window.

3.7.11 Organize guests by company/organization

You can place all the guests from the same organization in a group together.
Note however:

· you won't be able be able to further group couples within this group (groups

within groups are not supported)

· all guests within a group share a single set of contact details

If using groups isn't convenient you can list the organization in the guest Notes
field instead.

You can also list the organization on a separate line by using the HTML line
break tag <br> in the guest Display name field, e.g.:

Mr John Smith<br>Acme Ltd

See Names and titles for more details.

Advanced and Professional editions only
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Alternatively you can add a custom field of type Selection or Text and
store the organization name in this field. Using a custom field of type
Selection has several advantages, including: better reporting, the ability to
visualize the different organizations in different colours and (in the
Professional edition) the option to use it in custom seat assignment.

See also:

· Edit a property for multiple guests

· Handle sponsored tables

· Groups

3.7.12 Track details of non-seated guests

You may have guests that are attending your event, but won’t require a seat at
the dinner. We recommend that you track their RSVPs as normal but lock them
with no seat assigned to ensure they won’t be inadvertently assigned a seat. You
might also want to add a reminder in their Notes field, e.g. “evening only
guest”.

3.7.13 Turn on/off guest name capitalisation

To turn on/off the automatic capitalisation of new names typed in the Insert

Guest, Insert Couple, Insert Family or Insert Group window,
check/uncheck automatically capitalise new guest names in the Names tab

of the Preferences window.

3.7.14 Use particules in names

PerfectTablePlan can handle 'particules' (last name prefixes used in French,
Dutch, German, Italian and other languages). For example 'Johannes van der
Waals' has last name 'van der Waals' but can be optionally listed under

'W' (rather than 'v') in the Guest Chart pane. PerfectTablePlan will also know
to split 'Johannes van der Waals' into first name='Johannes' and last name='van
der Waals' when importing. You can specify particule behaviour using the
Particules and ignore particules when sorting fields in the Names tab of

the Preferences window.
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3.8 Importing

3.8.1 Import guest details from a website or application

PerfectTablePlan can import guest details from a wide range of websites and
applications, including:

· event registration websites (e.g. eventbrite.com)

· RSVP websites (e.g. evite.com and paperlesspost.com)

· wedding websites (e.g. theknot.com)

· CRM systems (e.g. Microsoft Dynamics)

· databases (e.g. Microsoft Access)
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You just need to export the data from the website as an Excel .xls/.xlsx file or in
text delimited form (e.g. rows separated by carriage returns and columns
separated by tabs, spaces or commas) - CSV (comma separated value) is
usually the easiest. Then you can import it into PerfectTablePlan.

We have already set-up a number of commonly used import mappings for you in

the Import Data window:

Advanced and Professional editions only

If you create a new import mapping you will be given the option to save it
for use as a new File type. This will then be available the next time you
import.

Note We are not able to offer any support for third party websites or software.
Use of third party software is entirely at your own risk.

See also:

· Import your guest list (video with audio, 11:59 minutes)

· Example import formats

· Import guests tutorial

3.8.2 Import guest details from Apple Address Book

Apple AddressBook is not available on Windows.

https://www.perfecttableplan.com/video/importv7.html
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3.8.3 Import guest details from Excel spreadsheets

If you already have guest information in a Microsoft Excel™ spreadsheet you can
import it, rather than re-typing it.

See Importing guests from Excel files.

See also:

· Import your guest list (video with audio, 11:59 minutes)

· Import guests tutorial

· Example import formats

3.8.4 Import guest details from Outlook

If you already have guest information in Microsoft Outlook™ you can import it,
rather than re-typing it.

Note The user interface of Outlook may differ between different versions.

Method 1: Drag and drop

1. Start Microsoft Outlook (we can accept no liability for you installing or using
third party software).

2. Select Tools>Address book to display the Outlook Address Book window.

3. Select one or more guests in the Address Book window.

4. Drag the guests to the PerfectTablePlan Guests pane or Groups pane.

Note You can easily rearrange guests into groups afterwards by dragging guests

between groups in the PerfectTablePlan Groups pane.

Method 2: Import CSV file

1. Start Microsoft Outlook (we can accept no liability for you installing or using
third party software).

2. Select File>Import and Export. The Import and Export Wizard window
will appear.

https://www.perfecttableplan.com/video/importv7.html
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3. Select Export to a file and click the Next button.

4. Select Comma separated values (Windows) and click the Next button.

5. Select Contacts and click the Next button.

6. Choose a name and location for the exported file e.g. outlook.csv and click
the Next button.

7. Click Finish.

8. Start PerfectTablePlan.

9. Select File>Import, select text/CSV file and click OK. An Open window
will appear.

10. Navigate to the Outlook export file and click the Open button. The Import
Data window will appear

11. In the table select First name(s) in the drop-down for the column with the
first name and Last name(s) in the drop-down for the column with the last
name. You can also choose other guest properties as appropriate.

12. Edit the text in the preview as appropriate.

13. Click the OK button. The guests will now be added to the plan.

If you wish to import guests as couples, families and/or groups you need to:

1. Have a groups column in your spreadsheet.
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2. Use the same name in the group column for each person in the couple, family
or group.

3. Make this column the Group field during import.

These guests will then be placed in the same group with the proximity you have
selected in the Proximity for guests in same group drop-down list. You can
easily change the proximity by right-clicking on the group and selecting the
appropriate proximity later.

For more information see Import Data window and Microsoft Outlook™
documentation. See also:

· Importing

· Example import formats

· Import guests tutorial

3.8.5 Import guest details from Outlook Express

If you already have guest information in Microsoft Outlook Express™ you can
import it, rather than re-typing it.

Note The user interface of Outlook Express may differ between different
versions.

Method 1: Drag and drop

1. Start Microsoft Outlook Express (we can accept no liability for you installing
or using third party software).
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2. Select Tools>Address book to display the Outlook Express Address Book
window.

3. Select one or more guests in the Address Book window.

4. Drag the guests to the PerfectTablePlan Guests pane or Groups pane.

Note You can easily rearrange guests into groups afterwards by dragging guests

between groups in the PerfectTablePlan Groups pane.

Method 2: Import CSV file

1. Start Microsoft Outlook Express (we can accept no liability for you installing
or using third party software).

2. Select File>Export>Address book. The Address Book Export Tool
window will appear.

3. Select Text file (Comma Separated Values) and click on the Export
button. The CSV Export window will appear.

4. Choose a sensible name and location for the export file and click the Next
button.

5. Check all the fields you wish to export. This should include First Name and
Last Name.

6. Click the Finish button.

7. Click the OK button.

8. Start PerfectTablePlan.

9. Select File>Import, select text/CSV file and click OK. An Open window
will appear.

10. Navigate to the Outlook Express export file and click the Open button. The

Import Data window will appear.

11. In the table select First name(s) in the drop-down for the column with the
first name and Last name(s) in the drop-down for the column with the last
name. You can also choose other guest properties as appropriate.
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12. Edit the text in the preview as appropriate. Use the Add row and Delete
row buttons to add and remove rows.

13. Click the OK button. The guests will now be added to the plan.

If you wish to import guests as couples, families and/or groups you need to:

· Have a groups column in your spreadsheet.

· Use the same name in the group column for each person in the couple, family

or group.

· Make this column the Group field during import.

These guests will then be placed in the same group with the proximity you have
selected in the Proximity for guests in same group drop-down list. You can
easily change the proximity by right-clicking on the group and selecting the
appropriate proximity later.

For more information see Import Data window and Microsoft Outlook™
Express documentation.
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See also:

· Importing

· Example import formats

· Import guests tutorial

3.8.6 Import guests in couples/families/groups

You can import guests in groups by using a 'group' column during import. For
more details see Importing groups here.

By default, guests imported in groups will have proximity set for that type of

group in the Preferences window.

See also:

· Import your guest list (video with audio, 11:59 minutes)

· Import proximity data

· Example import formats

· Import guests tutorial

3.8.7 Import proximity data

Professional edition only

https://www.perfecttableplan.com/video/importv7.html
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To import proximity data by guest:

1. Select File>Import.

2. Choose Excel/CSV/text file. 

3. Click OK.

4. Select a file to import. The Import Data window will appear.

5. Set guest name and other columns as usual.

6. Set the Next to, Near to, Near not next to, Not next to and/or Not
near to columns.

7. Click OK.

Note:

· Guests referenced during proximity import must already exist in the plan

or be created during the import (i.e. have their own row).

· Each cell in a Next to, Near to, Near not next to, Not next to or Not

near to column can contain 0 or more guest Ids, guest display names,
guest first + last names or group names. If there is more than 1, they
need to be separated by commas (,).
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· Proximities are set in the following order: Near not next to then Near to

then Not next to then Next to then Not near to. E.g. if 2 guests are set
to have both Near to and Next to proximity, the Next to proximity will
'overwrite' the Near to proximity.

· When cross referencing proximities against guests PerfectTablePlan will

match in the following order:

o cross reference=guest ID

o cross reference=guest display name

o cross reference=group name

o guest first and last name contained in cross reference

· If no case sensitive match can be found, then case insensitive matches will

be looked for.

· If you set guest A 'next to' guest B, then guest B 'next to' guest A will be

set automatically.

· These proximities override the default proximity for members of a group.

· If you have problems you can Edit>Undo the import and try again.

See also:

· Importing

· Example import formats

· Import guests tutorial

· Change proximity for multiple guests

3.8.8 Import seating data

Professional edition only
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To import seating data:

1. Add tables with the appropriate names and numbers of seats to your
plan.

2. Select File>Import.

3. Choose Excel/CSV/text file. 

4. Click OK.

5. Select a file to import. The Import Data window will appear.

6. Set guest name and other columns as usual.

7. Set the Table/Row name column.

8. Optionally set the Seat number column. 

9. Click OK.

Note:

· You must create tables with the appropriate names and numbers of seats

before you import guests (the names of tables are not case sensitive).

· The case of table names and custom seat names is ignored during import.

· If the table cell is left blank the guest will not be assigned a seat.



431

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

How do I?

· If you specify just the table or the seat cell is left blank, the guest will be

assigned to the first empty seat, starting with seat 1 and proceeding
clockwise. Guests will not be assigned to seats that are already assigned.

· If Allow seat assignment with RSVP is not set to Any in the 

Preferences window you will need to set the RSVP status of any guests to
be assigned seats to 'Accepted' during import or they cannot be assigned
seats.

· If you have problems you can Edit>Undo the import and try again.

See also:

· Import seating data (video with audio, 0:25 minutes)

· Import your guest list (video with audio, 11:59 minutes)

· Example import formats

· Import guests tutorial

3.8.9 Join and split columns

PerfectTablePlan can handle many different import formats for guest lists. But
sometimes you might need to join or split columns in your guest list to get it into
the correct format for importing. You can do this either in a spreadsheet before
you import or using PerfectTablePlan join and split operations after you import.

Joining and splitting columns in Excel

You can use the Excel concatenation operation (&) in Excel to join 2 columns.
For example:

http://www.screencast.com/t/R6x41pIA3bWU
https://www.perfecttableplan.com/video/importv7.html
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You can use the Text to Columns operation in Excel to split a column. 

Joining and splitting columns in PerfectTablePlan

To join or split columns in PerfectTablePlan you need to import the guest list and

then use the built in join and split functions. Click on the  button to reveal the
buttons.

To split, select on one or more columns you want to split and click on the Split

column(s)... button. The Split Columns window will appear.

To join, select two to four columns you want to join and click on the Join

columns... button. The Join Columns window will appear.
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Select multiple columns using Shift+click or Ctrl+Click.

Note Join and split create new columns. They don't change existing columns.

For example, you can use the Join feature to convert names in two columns into
a single column.
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See also:

· Edit guest list data during import (video with audio, 1:16 minutes)

· Example import formats

3.8.10 Merge updates when re-importing

See Merge import.

3.9 Plans

3.9.1 Close the current plan

To close the current plan and open an existing plan: select File>Open... or
File>Open Recent... .

To close the current plan and open a new, empty plan: select File>New.

3.9.2 Create a re-useable template plan

To create a template plan that you can re-use for similar events:

1. Create the plan that you want to be the template.

https://www.screencast.com/t/wNAWDGOug
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2. File>Save As to a new file, e.g. 'template.tp'.

Each time you need to create a new plan based on the template:

1. File>Open the template plan you created.

2. File>Save As to a new plan file, e.g. ‘event.tp’

3. Modify the plan for the new event.

4. File>Save.

Advanced and Professional editions only

1. Create the plan that you want to be the template, including any custom
fields.

2. File>Save As Template to a new template file, e.g. 'template.tpt'.

Each time you need to create a new plan based on the template:

1. File>Open the template plan you created.

2. Modify the plan for the new event.

3. File>Save.

If a guest in the template is not attending, you can set their RSVP status to
declined, rather than deleting them.

See also:

· Copy guests from one plan to another

· Find a missing plan file

3.9.3 Delete a plan

There is no way to delete a plan file from PerfectTablePlan. However a plan file is
just a text file. So you can delete it using Microsoft Windows Explorer. If you
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aren't sure where the file is stored you can quickly search your harddisk using
the Find plan files window.

3.9.4 Email my plan

To email a copy of your plan to someone with PerfectTablePlan:

1. File>Save your plan.

2. Select File>Email Plan. Your normal email program should now appear.

3. Send the email.

Note If they don't need to save, print or export your plan they can download and
use the free trial version of PerfectTablePlan.

To email a copy of your plan to someone without PerfectTablePlan:

1. Export your plan into the appropriate format (usually PDF).

2. In the Export window check create a new email with the document
added or compose an email and add the exported file as an attachment.

Alternatively you can export your plan to the web and email a link.

3.9.5 Find a missing plan file

If you are having difficulty remembering where you stored a file, you can search
your harddisk using the Find plan files window.

Note PerfectTablePlan never deletes plan files.

See also:

· Most Recently Accessed window

· Backup files

· Delete a plan

3.9.6 Retrieve old versions of the plan

You may be able to access old versions of your plan from automatic backup files
made by PerfectTablePlan.

https://www.perfecttableplan.com/html/download.html
https://www.perfecttableplan.com/html/download.html
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See also:

· Find a missing plan file

 

3.10 Printing

3.10.1 Change the printer or paper size

PerfectTablePlan can print to any size of paper that your printer supports. To
change the paper size select File>Page Setup... or click on the Setup... button

in the Print window.

If you have more than one printer you can change printer by clicking the

Setup... button in the Print window.

See also:

· Print window

· Page Setup window

· Print Setup window

· Print legible plans on a small format printer

3.10.2 Change the print pagination

To change the print pagination use the fine adjust controls in the Print

window. Click on the  button to show them.



438

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

How do I?

Note that you can also export the contents of the Guest Chart, Table

Chart or Report pane to Microsoft Excel or Word or similar applications and
print them from there.

See also:

· Print legible plans on a small format printer

3.10.3 Print a guest list

To print a list of all the guests (including unassigned guests):

1. Bring the Guest Chart pane to the front of the Right pane.

2. Select All from the For drop-down list at the top of the pane.

3. Select File>Print or the equivalent Main tool bar button.

Note You can't print the Guests pane. However you can print the Guest
Chart pane and it contains very similar information.

3.10.4 Print legible plans on a small format printer

If you only have access to a standard format (e.g. A4 or Letter) printer it can be
difficult to print a legible floor plan for lots of guests on a single sheet. Here are
some suggestions:

· Try printing in Landscape instead of Portrait mode (or vice versa) to better

match the aspect ratio (height to width ratio) of the paper to the aspect ratio
of your plan.
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· Try to modify the layout of the tables and other items in your Floor Plan so

the width:height ratio of the bounding box around them is approximately the
same width:height ratio as the page.

A floor plan with different width:height as page means lots of unused space and smaller text on
the printed page
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A floor plan with similar width:height as page means less unused space and bigger text on the
printed page

· Minimize the amount of empty space in the Floor Plan pane, for example by

moving the tables closer together. This may seem counter-intuitive, but will
allow text to appear bigger when the floor plan is scaled to fit the page. Below
you can see the same table plan output to a A4 page, with and without large
spacing between the tables:
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Tables spaced well apart means lots of unused space and small text on the printed page
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Tables spaced closer together means less unused space and larger text on the printed page

· Print the Floor Plan pane on multiple sheets of paper and join them

together (change the Size % in the Print window to span your printout
across multiple pages).

· Print each table on a separate page from the Table Plan pane.

· Set the Floor Plan pane to display seat numbers, instead of names, by

selecting Seat number from the Display drop-down. Set the Table Chart

pane to display seat numbers as well as names. Print out both Floor plan

and Table Chart panes. The floor plan can then be cross-referenced against
the table chart.

· Select Name only (radial) or Name only (banquet) from the Seats drop-

down list at the top of the Floor Plan pane. 

· Shorten the names displayed in the Floor Plan pane, e.g. by selecting F.

Last. from the Display drop-down list at the top of the pane. This will allow
you to increase the font size.
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· Increase the size of the fonts in the Floor Plan pane by clicking on the 

button. The size of table and seat fonts can be set separately. But note that
the text will be shrunk to fit so that it doesn't overlap other text.

· Try a more legible font, e.g. Arial, Georgia or Verdana.

Advanced and Professional editions only

· Use an E-shaped table type instead of making an E-shaped table from

individual head and custom tables (the E-shaped table is more intelligent
about how much space can be given to each name).

· For E-shaped tables

o Move longer names to the 'external' sides of  (i.e. not between 2 sprigs).

o Increase the distance between the 'legs' by making the 'top' sprig

longer. 

NB/ Doubling the size of the tables, seats and fonts won't help, because then
PerfectTablePlan will just scale them 50% smaller to fit on the page!

Alternatively:

· Export the floor plan as a PDF and send it to someone with a larger format

(e.g. A3 or A2) printer

· Order a digital poster print from one of our partners

https://www.perfecttableplan.com/html/order_plan.html 
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· Display the plan on a VDU or plasma screen

3.10.5 Print to poster size

To print a plan or chart to poster size:

· Print across multiple sheets of A4/Letter paper and join them together; or

· Export to PDF format and take it to your local print shop, e.g. a Fedex Kinko

(raster image formats such as PNG and JPG can degrade significantly when
enlarged); or

· Get it delivered to your door as an inexpensive digital poster print.

See also:

· Display seating on a VDU or plasma screen

· Print legible plans on a small format printer

3.11 Proximity

3.11.1 Change proximity for multiple guests

To set the proximity for all the guests in a group (e.g. to set all the guests in a
group to 'near to' each other):

1. Right-click on the group in the Groups pane.

2. Select the proximity from the pop-up menu.

To set the proximity for multiple guests (e.g. to set 5 guests to have proximity
'near to' each other):

1. Use click/Ctrl+click/Shift+click to select the appropriate guests in the 
Guests pane.

2. Right-click.

3. Select the proximity from the pop-up menu.

Professional edition only

https://www.perfecttableplan.com/html/order_plan.html
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To edit the proximities for one group at a time in the Proximity pane:

1. Click on the  button at the top-left of the pane.

2. Click on the Bulk Edit... button. The Bulk Edit Proximity window will be
displayed.

3. Set the drop-down list according to the changes you want to make.

4. Click OK. 

See also:

· Bulk edit proximity (video with audio, 1:08 minutes)

See also:

· Import proximity data

3.11.2 Show the proximity for one group at a time

To show the proximities for one group at a time in the Proximity pane:

1. Click on the  button at the top-left of the pane.

2. Set the Shown drop-down list to by group. Use the  and  buttons or the
drop-down list to change group.

See also:

· Proximity pane

3.12 Stationery

3.12.1 Add a colour coded spot to the stationery

Colour coded spots can be a useful way to convey information on stationery. For
example you can put colour coded spots on place cards to tell the serving staff
what meal has been ordered (e.g. red=beef, blue=chicken, green=vegetarian).
You can also use it to discretely convey information you might not wish to put in
text form, e.g. whether a guest has paid!

http://www.screencast.com/t/91mvOZ8WZ0
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To add colour coded spots to your stationery:

1. Ensure that the Design tab of the Stationery pane is at the front and
the Item per drop-down list is set to Guest.

2. Click on the Insert Colour spot button at the bottom of the Stationery
pane.

3. Click the cross hair cursor where you want to place the centre of the colour
spot.

4. Click on the drop-down list to choose which guest property you wish to
represent (Gender, Group, Meal or custom field of type Yes/No, Selection or
Tags).

5. Set the colour spot across and down size. Note that this is a bounding area
and the colour spots may not fill all of it. If you expect to have to have
multiple colour spots (e.g. because you have multiple meal selections) you
may need to set a rectangular (rather than square) bounding area.
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6. Click on the Preview tab of the Stationery pane to see how the spots
will appear when merged.

You can click on the Colours... button to change the colours used in the 
Visualization colours window.

The number of colour spots varies. E.g. If you are using colour spots to
represent meal selection or custom fields of type Tags, a colour spot will be
displayed for each comma separated value. So if the meal choice is listed as
"soup,fish,ice cream" then 3 colour spots will be displayed.

Colour coded spots are not shown in Preview tab or in print outs if the Item
per drop-down list is set to Group or Table.

See also:

· Colour coded dots (video with audio, 1:39 minutes)

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Print stationery tutorial

· Add a graphic/image/clipart to the stationery

· Add a guest image to the stationery

· Add a personalised map to the stationery

· Merge guest names into stationery

3.12.2 Add a graphic/image/clipart to the stationery

To add an image to your stationery:

1. Ensure that the Design tab of the Stationery pane is at the front.

2. Drag the image from Windows Explorer or a web browser onto the Design

tab of the Stationery pane.

3. Set the image across and down size.

4. Click  or  buttons to rotate the image as required.

http://www.screencast.com/t/JWm5m6Fmoej1
https://www.perfecttableplan.com/video/stationeryv7.html
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5. Click on the Preview tab of the Stationery pane to see how the images
will appear when merged.

Or:

1. Ensure that the Design tab of the Stationery pane is at the front.

2. Click on the Insert Image button at the bottom of the Stationery pane.

3. Click the cross hair cursor where you want to place the centre of the image.

4. Click on the Browse... button and select an image file (or select from the
drop-down list if the image has been added previously).

5. Set the image across and down size.

6. Click  or  buttons to rotate the image as required.

7. Click on the Preview tab of the Stationery pane to see how the images
will appear when merged.
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Advanced and Professional editions only

You can use the You are here button to insert a personalised location
map into each item of stationery.

See also:

· Stationery images (video with audio, 1:39 minutes)

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Find free clipart

· Load sample stationery

· Print stationery tutorial

· Add a guest image to the stationery

· Add a personalised map to the stationery

· Add a colour coded spot to the stationery

· Merge guest names into stationery

3.12.3 Add a guest image to the stationery

To add a guest image to your stationery:

1. Ensure that the Design tab of the Stationery pane is at the front.

2. Click on the Guest Image button at the bottom of the Stationery pane.

3. Click the cross hair cursor where you want to place the centre of the image.

4. Set the image size across and down.

5. Option change the image shape from Square to Circular.

http://www.screencast.com/t/ZZY9iEBwA
https://www.perfecttableplan.com/video/stationeryv7.html
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6. Click on the Preview tab of the Stationery pane to see how the guest
images will appear when merged.

See also:

· Print stationery tutorial

3.12.4 Add a personalised map to the stationery

Advanced and Professional editions only

You can use the You are here button to add a personalised map image
into each item of stationery. This map will show the appropriate seat, seats
or table, depending on whether the Item per drop-down list is set to
Guest, Group or Table.
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You may need to make the 'You are here' image quite large for it to be
legible, especially if you have lots of tables.

To add a 'You are here' image in the Stationery pane:

1. Ensure that the Design tab is at the front.

2. Click on the You are here button at the bottom of the Stationery
pane.
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3. Click the cross hair cursor where you want to place the centre of the
image.

4. Set the image across and down size.

5. Click  or  buttons to rotate the image as required.

6. Click on the Preview tab of the Stationery pane to see how the
images will appear when merged.

See also:

· You are here maps (video with audio, 0:49 minutes)

· Create place cards and other stationery (video with audio, 10:08

minutes)

· Print stationery tutorial

· Add a graphic/image/clipart to the stationery

· Add a guest image to the stationery

· Add a colour coded spot to the stationery

· Merge guest names into stationery

3.12.5 Add a new stationery layout

PerfectTablePlan comes with a comprehensive library of stationery templates.
This includes many sizes of labels and cards from leading stationery
manufacturers. If we don't provide a template for the type of stationery you
want to use:

1. At the top of the Stationery pane click the Stationery layout button.

The Stationery Layout window will appear.

http://www.screencast.com/t/IEHE0RkpOrVM
https://www.perfecttableplan.com/video/stationeryv7.html
https://www.perfecttableplan.com/video/stationeryv7.html


453

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

How do I?

2. Set the various fields to the appropriate dimensions. You can choose mm or
inches. Click on the Nomenclature tab for a visual representation of the
various parameters. The layout is shown in the Preview tab.

3. Click OK. The Save Stationery Layout window will appear.

4. Complete the details for the new layout and click OK if you want it to be
saved into the stationery database for next time.

See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Load sample stationery

· Show one stationery item per couple/family/group

3.12.6 Align printing with my stationery

If the printing doesn't align correctly with your stationery there are a number of
possible causes:

· The stationery template dimensions don't match the stationery. Verify the

measurement against the stationery (including the units) and correct the
stationery template if required.

· The paper size set for your printer is incorrect. 

· Your printer positioning is incorrectly calibrated. Most printers have a built-in

calibration function that can fix this. Try Googling: <your printer model>
calibration.

· The printer scaling property is not set to 100%.

To access your printer properties:

1. Select File>Print in PerfectTablePlan.

2. Click on the Setup... button in the Print window.

3. Select the printer (if more than one) and click Preferences.

https://www.perfecttableplan.com/video/stationeryv7.html


454

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

How do I?

If none of the above works, try using the fine adjust controls or change the
scaling property for your printer to compensate for the inaccuracy.

Even the best set-up printer is unlikely be millimetre perfect and most printers
can't print right to the edge of the page. So we recommend that you:

· Don't position text or graphics close to the edge of a card.

· Don't print borders or fold lines or pre-scored stationery (e.g. Avery place

cards).

· Don't try to print within a 5-10 mm margin around the edge of the page.

You can also try exporting the stationery to PDF format and printing from Adobe
Acrobat (or similar). Note that Adobe Acrobat has a scaling property that may
not be set to 100% by default.

See also:

· Print stationery on blank sheets

· Print stationery on press-out sheets

3.12.7 Create address labels

If you have completed the contact information for each group you can print

address labels from the Stationery pane. 

We include A4 and Letter address label templates with PerfectTablePlan, which
you can load.

Or you can create your own design.
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See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Load sample stationery

· Print stationery tutorial

· Merge guest names into stationery

· Show one stationery item per couple

· Change the order of guests in a group

3.12.8 Load sample stationery

Some sample stationery templates (both A4 and letter sized) are installed with

PerfectTablePlan. To load a sample click on the Load stationery button at

the top of the Stationery pane.

https://www.perfecttableplan.com/video/stationeryv7.html
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The samples are usually installed into Documents\PerfectTablePlan.

There are also some templates for popular place cards on our website.

See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Add a new stationery layout

· Remove a stationery border or fold line

3.12.9 Merge guest names into stationery

You can easily merge guest names (and other data from your table plan) into
place cards and other stationery. 

1. Go to the Design tab of the Stationery pane.

2. Click on the Insert text button and then click on the location you want to
place the merged text.

3. Select the text you want to merge from the Insert substitution text drop-
down list.

4. Click on the Preview tab of the Stationery pane to see the text merged.

https://www.perfecttableplan.com/html/buy_place_cards.html
https://www.perfecttableplan.com/video/stationeryv7.html
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See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Load sample stationery

· Print stationery tutorial

· Order place cards

· Add a graphic/image/clipart to the stationery

· Add a guest image to the stationery

· Add a colour coded spot to the stationery

https://www.perfecttableplan.com/video/stationeryv7.html
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· Add a personalised map to the stationery

· Show one stationery item per couple/family/group

3.12.10 Order place cards

You can order sheets of press-out place cards suitable for printing from
PerfectTablePlan from our partners. Click here for details.

See also:

· Print stationery on press-out sheets

3.12.11 Print place cards, invitations, address labels etc

You can design and print various types of stationery from the Stationery
pane. PerfectTablePlan makes it very easy for you to merge in the guest names,
contact details, seat assignments etc.

You can also load sample stationery we install with the software.

Stationery can be exported to a PDF file if you want someone else to print it for
you.

For details see the Printing Stationery tutorial.

Note that PerfectTablePlan is not a fully fledged wordprocessor/DTP package. If
your stationery includes lots of text and/or graphics you might be better
exporting all the data into a .csv file and then importing it into a
wordprocessing/DTP package, such as Microsoft Word.

See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Merge guest names into stationery

· Order place cards

https://www.perfecttableplan.com/html/buy_place_cards.html
https://www.perfecttableplan.com/video/stationeryv7.html
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· Printing stationery

· Create address labels

· Show one stationery item per couple/family/group

· Change the order of guests in a group

3.12.12 Print stationery on blank sheets

1. At the top of the Stationery pane click the Stationery layout button
and set-up the dimensions and layout of your stationery.

2. Design your stationery.

3. The stationery will be easier to fold and cut if you use fold lines, borderlines
and/or cut lines. For the best results we recommend you use cut marks and
a guillotine:

· Click on the  button at the top left of the pane and optionally set the Fold,

Border thickness and Border colour options.

· Click on the Preview tab and optionally check the cut marks check box.

4. Once you are happy with your design select File>Print.
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See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Print stationery on press-out sheets

· Remove a stationery border or fold line

· Merge guest names into stationery

· Show one stationery item per couple/family/group

https://www.perfecttableplan.com/video/stationeryv7.html
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3.12.13 Print stationery on press-out sheets

1. At the top of the Stationery pane click the Stationery layout button
and set-up the dimensions and layout of your stationery.

2. Design your stationery.

3. If you are using pre-scored press-out sheets you shouldn't need to print fold
lines, borders or cut-marks:

· Click on the  button at the top left of the pane and optionally set the Fold,

Border thickness and Border colour options.

· Click on the Preview tab and uncheck the cut marks check box.

4. Once you are happy with your design select File>Print.
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See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Print stationery on blank sheets

· Remove a stationery border or fold line

· Merge guest names into stationery

· Order place cards

· Show one stationery item per couple/family/group

https://www.perfecttableplan.com/video/stationeryv7.html
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3.12.14 Remove a stationery border or foldline

Click on the  button at the top-left of the pane.

· To remove the border from stationery set the Border thickness to 0.

· To remove the fold lines from stationery set Fold to No.

See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

3.12.15 Show one stationery item per couple/family/group

For some types of stationery (e.g. invitations or escort cards) it may be
appropriate to only print one item of stationery per couple/family/group. You can

do this by setting the Item per drop-down list at the top of the Stationery
pane to Group.

Note {group_members} will show either the first name (e.g. Mr & Mrs John

Smith) or initials (e.g. Mr & Mrs John Smith) depending on the setting of the

Display group members as field in the Names tab of the Preferences
window.

See also:

· Create place cards and other stationery (video with audio, 10:08 minutes)

· Move guests from one group to another

https://www.perfecttableplan.com/video/stationeryv7.html
https://www.perfecttableplan.com/video/stationeryv7.html
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3.13 Tables

3.13.1 Add/remove a single seat to/from a table

Right-click on a seat and select Add Seat or Delete. If you add a seat it will be
added clockwise from the selected seat.

To add/remove single seats from a rectangular or banquet table you can also

double-click on the table and change it to a custom table. You can then
separately control how many seats there are on each of the 4 sides.

See also:

· Change table size or shape

· Hide empty seats

3.13.2 Change table size or shape

To change the size (dimension or number of seats) or shape of a single table:

1. Double-click on the table in the Floor Plan, Table Plan or Schematic
pane. The Table properties window will appear.

2. Change the Size or Shape fields, as required.

3. Click OK.

To change the size of multiple tables:

1. Select the tables you wish to change in the  Floor Plan or Schematic
pane.

2. Select Edit>Tables Properties>Size... .

3. Change the size in the Edit Table Size window.

4. Click OK.

Note All tables must be the same shape.

To change the shape of multiple tables:
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1. Select the tables you wish to change in the  Floor Plan or Schematic
pane.

2. Select the shape in the Edit>Tables Properties>Shape menu.

See also:

· Add/remove a single seat to/from a table

· Change table colour

3.13.3 Change table colour

To set the default colours for tables in the Floor Plan or Table Plan panes

click on the Colours and fonts button at the top of the pane.

You can also set each table to have a different solid colour, gradient or texture
different to the default colour. This can improve the aesthetics and allow you to
easily identify different table types in your floor plan.

To change the colour of a single table:

1. Double-click on a table or row of seats to show the Table properties
window.

2. Choose solid, gradient or texture from the drop-down list and set the
appropriate colour or texture.

3. Click OK.

To change the colour of multiple tables:
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1. Select the tables you wish to change in the  Floor Plan or Schematic
pane.

2. Select Edit>Tables Properties>Colour... .

3. Change the colour in the Edit Table Colour window.

4. Click OK.

To change the colour of multiple tables:

1. Select the tables you wish to change.

2. Select Edit>Table Property>Colour... .

3. Choose solid, gradient or texture from the drop-down list and set the
appropriate colour or texture.

4. Click OK.

See also:

· Set transparent as colour

3.13.4 Change the seat numbering

Advanced and Professional editions only
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To change the seat numbering:

1. Double-click on a table or row of seats to show the Table properties
window.

2. Either:

· Set the Seat numbers to sequential to change the number of the first

seat and whether the seats are ordered clockwise or anti-clockwise; or

· Set Seat numbers to custom... to change them to anything you like

(including letters or names) in the Custom seat numbering window
(click the Change... button if custom... is already set).

See also:

· Flexible seat numbering (video with audio, 0:51 minutes)

See also:

· Show seat numbering

http://www.screencast.com/t/Mzg1NTQ4Mzct
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3.13.5 Change the table order

The Table Plan, Table Chart and Schematic panes show tables in a
certain order. By default this is the order in which the tables were created, but
you can change it by either:

· clicking on the Table order... button in the Table Chart or Schematic

pane; or

· dragging a table up or down the order in the Schematic pane; or

· selecting a table and using the up and down arrows at the top of the 

Schematic pane to change its position in the table order

To sort the tables in alphanumeric order:

 1. Go to the Table Chart or Schematic pane (click on the  button at the

top-left of the Table Chart pane).

 2. Click on the Table order... button.

 4. Click the Sort button.

 5. Click OK.

See also:

· Table Order window

3.13.6 Create a horseshoe shaped table

You can create a horseshoe table (and other complex table types) by composing
it from basic table shapes. Typically you will use a serpentine table plus a
banquet table for each 'sprig'. If you need to add guests at the end of the
banquet tables you can use custom tables instead.
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See the sample horseshoe table plan shipped with PerfectTablePlan for an
example. The samples are usually installed into
Documents\PerfectTablePlan.

Hints:

· Set the Inside and Edge colours of the tables the same in the Fonts and

Colours window so that you won't see where the tables overlap.

· Turn the grid snap off.
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· Use the keyboard arrow keys to make small adjustments to the positions of

selected tables.

See also:

· Create an E-shaped table

· Hide empty seats

3.13.7 Create an E-shaped table

Advanced and Professional editions only

You can add an E-shaped table by selecting Insert>E-shaped Table... .

See also:

· E-shaped table (video with audio, 3:39 minutes)

If you have PerfectTablePlan Home edition you can create an E-shaped table
(and other complex table types) by composing it from basic table shapes.
Typically you will use a head table plus a banquet table for each 'sprig'. If you
need to add guests at the end of the banquet tables you can use custom tables
instead.

http://www.screencast.com/t/6WwgYZpP
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See the 'masonic_sample_Home_edition' table plan shipped with
PerfectTablePlan for an example of an E-shaped table plan.

Hints:

· Set the Inside and Edge colours of the tables the same in the Fonts and

Colours window so that you won't see where the tables overlap.

· Set the Seats drop-down list at the top of the Floor Plan pane to Name

only banquet for a name layout that is easy to read and makes good use of
space.

· Turn the grid snap off.
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· Use the keyboard arrow keys to make small adjustments to the positions of

selected tables.

· Use the Shuffle Seats window to move blocks of seated guests around the

table, e.g. after changing the table size.

See also:
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· E-shaped table

· Create a horseshoe shaped table

3.13.8 Create a round ended table

You can create a round ended table by adding a custom table and setting End 1
curve and End 2 curve to the appropriate degree of curvature (0=no
curvature, 180=maximum curvature).

See also:

· Custom table

3.13.9 Create a serpentine table

Advanced and Professional editions only
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You can add 180 or 90 degree serpentine tables by selecting
Insert>Serpentine Table... or Insert>Half Serpentine Table.... You
can set the number of seats separately on each of the 4 sides.

You can join 2 serpentine tables together to make an S-shaped table. You
may need to turn the grid-snap off to align them.
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See also:

· Serpentine table

· Half Serpentine table

· Create a horseshoe shaped table

· Hide empty seats

3.13.10 Create rectangular tables with seats on 1,2 or 3 sides

· For a rectangular table with seats on 3 sides or a different number of seats on

each side use a custom table.

· For a rectangular table with an equal number of seats on 2 sides use a

banquet table.
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· For a rectangular table with seats on 1 side use a head table.

See also:

· Create an E-shaped table

· Hide empty seats

3.13.11 Create sweetheart/cabaret style tables

If you have a circular table that is big enough to have gaps between the seats,
you can choose to space the seats evenly or group them all together. The latter
is useful if you want to use sweetheart or cabaret style seating. Note that
grouping seats together is only possible for circular tables when there are gaps
between the seats (there will be no gaps if auto is checked).

See also:
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· Circle table

· Hide empty seats

3.13.12 Edit a property for multiple tables

To change the shape, colour, number of seats or size for multiple tables in a
single operation:

1. Select multiple tables in the Floor plan or Schematic panes using
Ctrl+click/Shift+click (Ctrl+A to select all). In the floor plan you can also drag
a selection box.

2. Select Edit>Table Property and then choose the appropriate table property
to edit. 

Note All the selected tables must be the same shape to edit the seats or size in
this way.

See also:

· Select multiple items

· Edit a property for multiple guests

3.13.13 Handle sponsored tables

Corporate and charity events will often have tables sponsored by companies or
individuals. One way to accommodate this is to:

1. Include the sponsor name in the table name, e.g. ‘Table 1 (Acme Corp)’.

2. If a guest is associated with a particular sponsor, add a comment to the
guest’s Notes field. If you don’t know the name of the sponsored guests you
can set their last name to ‘Acme guest 1’, ‘Acme guest 2’ etc. (If you have
PerfectTablePlan Advanced or Professional edition you can use a custom field
to record which sponsor each guest is associated with).

3. Select a host for each sponsored table and make them a VIP guest. Drag
them to a seat on that table and Edit>Guest Property>Locked>Yes them
there.
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4. Select a sponsor and all the groups you would like to sit with them by

Ctrl+clicking the sponsor and the groups in the Groups pane. Set them to
have proximity ‘near to’ using Edit>Proximity. 

5. Run the automatic seat assignment File>Auto assign seats.

6. Use drag and drop and visualization to fine-tune the assignments.

Professional edition only

You can use a custom selection field to record which sponsor each guest is
associated with and then set the proximity for that field so that all guests
with the same sponsor sit together.

We don’t recommend you group people by sponsor unless they have the same
contact details (or you don't care about contact details).

See also:

· Assign table captains

· Organize guests by company/organization

· Show custom fields

· Assign seating by guest type/category

· Lock guests to seats

3.13.14 Rename/Renumber tables

To rename a table:

1. Select the table in the Floor Plan, Table Plan or Schematic pane

2. Select Edit>Properties from the menu bar.

3. Change the name.
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4. Click OK.

You can also display the Properties window by double-clicking on the table or
selecting Properties from the right-click menu.

To rename large numbers of tables:

1. Use the Replace Text window, with Tables>Name checked.

Or

1. Go to the Schematic pane.

2. Select Edit from the Mode drop-down list at the top of the pane.

3. Retype the table names.

Professional edition only

You can use the Renumber/Rename tables window to quickly rename

large numbers of tables in the Floor Plan pane.

See also:

· Fast table renumber (video with audio, 0:44 minutes)

To change the default name given to new tables change the New table name

format field in the Names tab of the Preferences window.

See also:

· Change the seat numbering

3.13.15 Rotate tables

To rotate one or more tables:

1. Select the table(s) in the Floor Plan pane.

2. Select Edit>Properties from the menu bar.

http://www.screencast.com/t/MTdhOWYzN
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3. Edit the Angle field.

4. Click OK.

You can also display the Properties window by double-clicking on the table or
selecting Properties from the right-click menu.

To rotate the selected table(s) 45 degrees clockwise or anti-clockwise click on

the  or  buttons at the top of the Floor Plan pane.

See also:

· Shuffle Seats window

3.13.16 Show seat numbers

Floor plan pane

You can show seat numbers in place of guest names by selecting Seat number
(small, medium or large) from the Display drop-down list.

Alternatively, if you need to show both guest names and seat numbers, you can
select Seat number from the Places drop-down list.

Table plan pane

As per the Floor plan pane, above, but you can also show seat numbers in the
legend by checking the seat check box.
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Guest chart pane

You can show seat numbers by checking the seat check box.
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Stationery pane

You can show seat numbers by using the {guest_seat} substitution text.

See also:

· Change the seat numbering

3.14 Other

3.14.1 Add a special character not on my keyboard

PerfectTablePlan supports a very wide range of symbols using Unicode,which is
now the leading standard for encoding non-Latin character sets. However you
need to have another Unicode compliant application to create the symbol and
copy from. If you copy and paste from another application that isn't using
Unicode (such as from Insert>Symbol in MSWord 2000) it may not work. 

The simple way around this is to copy and paste the symbol from your web
browser to PerfectTablePlan. For example copy the symbol from this page:

http://www.htmlhelp.com/reference/html40/entities/symbols.html

and paste it into PerfectTablePlan. We have tested this with recent versions of
both IE and FireFox browsers and it works fine, but older AOL and Netscape
browsers may have problems. Just be careful not to paste in unwanted
characters (such as ‘end of line’ characters).

3.14.2 Change fonts and/or colours

In the Floor Plan, Table Plan, Table Chart or Guest Chart pane

click on the Colours and fonts button at the top of the pane.

Note If the name of a guest can't be fitted into the space available in the 

Floor Plan or Table Plan pane, the font will automatically be scaled smaller
for that name to try to make it fit.

In the Stationery pane select the appropriate text and click on the Font and

Colour buttons at the bottom of the Design tab.

See also:

· Find free textures

http://www.htmlhelp.com/reference/html40/entities/symbols.html
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· Visualization Colours window

· Change table colour

· Set transparent as colour

3.14.3 Change the dashboard charts displayed

To change the charts shown in the  Dashboard pane:

· Click on the  button at the top left of the pane to show additional options.

· Check the charts you want displayed.

3.14.4 Change text inside panes

You can change text inside Table Plan, Guest Chart, Stationery and 

Report panes using the Terms tab of the Preferences window. This is
particularly useful if you want to translate English terms into another language.

See also:

· Terms (video with audio, 0:28 minutes)

http://www.screencast.com/t/MnTFA50fR3e7
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3.14.5 Display seating on a VDU or plasma screen

You can display full screen scrolling text (like film credits) showing seat

assignments in the VDU Chart pane. For example you might be able to
connect the VDU output of a PC or Mac laptop to a plasma screen at a venue.
We strongly recommend you test this before an event to ensure that your
hardware/software is compatible with the screen and you have the correct cable.

The chart below shows the (approximate) time taken for the display to scroll
through a full cycle at a readable speed:

Columns of guests displayed

Seated guests 1 2 4

100 48 seconds 24 seconds 12 seconds

200 1 minute 36
seconds

48 seconds 24 seconds

500 4 minutes 2 minutes 1 minute

1000 8 minutes 4 minutes 2 minutes

2000 16 minutes 8 minutes 4 minutes

Anything over a minute may not be acceptable.

See also:

· VDU chart (video with audio, 2:17 minutes)

· Assign (or reassign) seats in real time

3.14.6 Estimate numbers and budget

Select File>Numbers and Budget... and use the Numbers and Budget
window to estimate guest numbers and help keep track of your budget.

http://www.screencast.com/t/gTZCirs5v
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3.14.7 Find free clipart

We install a range of free floor plan, wedding, Masonic, decorative and
PerfectTablePlan clipart with PerfectTablePlan. Usually this is installed into sub-
folders of your Documents\PerfectTablePlan\Clipart folder.

floor plan clipart

wedding clipart
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Masonic clipart

decorative clipart

PerfectTablePlan clipart

You can also use tools such as Google image search to find images. 
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Ideally the image should be in PNG format and should have at least 40 pixels for
each cm (100 pixels for each inch) that you want to print it at. E.g. If you want
to display a crest 5 cm (2 inches) across on your printout, it should be at least
200 pixels across.

Storing large images in your plan will make your plan file large and may slow
down PerfectTablePlan.

Make sure you comply with the copyright/licensing terms of any images you use.
The licensing terms for our clipart are contained in a .txt file in each clipart sub-
folder.

See also:

· Add a graphic/image/clip-art to the floor plan

· Add a graphic/image/clip-art to the stationery

· Find free textures

3.14.8 Liaise with caterers

The easiest way to send your seating plan to your caterer is to email the plan
file. They can download a free version of PerfectTablePlan to view your plan
(they will need a licence to save changes). Alternatively you can export and
email the information they will need in a range of formats.

Total numbers, meal choices and table
shapes/sizes

You can print or export this information from the Summary report in the 
Report pane (note that meal courses and special requirements will be totalled
separately if they are separated by commas, e.g. soup,fish,flan). Use
File>Export and select report to text/CSV/HTML file to export an HTML or
text file.

Professional edition only

https://www.perfecttableplan.com/html/download.html
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You can create a report of meal by table (and various other custom reports)
using the Detailed (summary) report.

General layout of tables

You can print or export this information from the Floor Plan pane. Use
File>Export and select Floor Plan to image file to export an image file. Most
people can read PDF and PNG format files.

Who is sitting where, meal choices and special
requirements

You can print or export this information from the Table Chart pane or 
Table Plan pane for each table. Ensure the notes, special and meal
information are displayed. Use File>Export and select table chart to
text/CSV/HTML file to export a text, CSV or HTML file. Use File>Export and
select Table Plan to image file to export an image file.

3.14.9 Select multiple items

In the Guests, Groups or Schematic pane:

· To select multiple individual items Ctrl+click on each item.

· To select a group of items click on the first item and Shift+click on the last

item.

· To select multiple groups of items Ctrl+click on the first item in each group

and Shift+Ctrl+click.

To select multiple items in the Floor Plan or Table plan pane:

· Hold down the left mouse button and drag a 'rubber box' around the items you

want to select; or

· Ctrl+click on each item.

To select all visible items in any of the above panes use Edit>Select All or
Ctrl+A.



489

PerfectTablePlan 
 
                                                                                                                                                                                                                                       © 2025 Oryx Digital Ltd

How do I?

See also:

· Edit a property for multiple guests

· Edit a property for multiple tables

3.14.10 Set transparent as a colour

You can set a colour to be partially or completely transparent in the Select
Colour window.

· For full transparency set the Alpha channel to 0.

· For 50% transparency set the Alpha channel to 128.

· For a standard (opaque) colour set the Alpha channel to 255. 
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Using transparency allows you to hide the inside and edge of rows of seats.
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It can be tricky to find something you have made fully transparent! However you

can drag a 'rubber box' in the Floor Plan pane (by left clicking away from
items, holding down the mouse and dragging) to select transparent items.

See also:

· Change fonts and/or colours



Frequently asked questions
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4 Frequently asked questions

4.1 Frequently asked questions

For an up-to-date list of frequently asked questions see our
www.perfecttableplan.com FAQ page.

https://www.perfecttableplan.com/html/faq.html


Expert tips
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5 Expert tips

5.1 Expert tips

We have added a lot of features to PerfectTablePlan, with the aim of making
your life easier. However, quite a few of them are hidden away to prevent the
user interface from becoming too overwhelming for novice users. Below is a list
of useful things you might not know about PerfectTablePlan. Taking 10 minutes
to read through them could save you a lot of time, especially if you are a
frequent user. Note that not all features are available in all editions.

All editions

Drag a group

If you hold down the Shift key while dragging a guest, it will drag all members of
that group.

HTML tags

You can use HTML tags to control the use of bold, italic, line breaks etc in
Display name field.

Textures and gradients

You can use textures and gradients for tables and shapes to liven up your floor
plan. We ship a number of textures with PerfectTablePlan, including grass, tiles,
marble and wood.
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Resize the room by dragging

Change the size of the room in the Floor plan pane by dragging the bottom-
right corner.
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Multiple meal courses

PerfectTablePlan can handle multiple meal courses. Just separate them by
commas in the Meal field. They will be totalled separately in the Summary

report in the Report pane.

Resize text to fit

If you choose too large a font for guests in the Floor plan or Table plan
panes, the font will be scaled smaller to fit. This will result in different font sizes.
You can avoid this by auto sizing the font. 

Keyboard accelerators

You will be much faster at using PerfectTablePlan if you memorize some of the
keyboard accelerators. 

Accelerator Result

Ctrl+A Select all non-hidden items

Ctrl+G Insert single guest

Ctrl+K Lock selected guests

Ctrl+Shift+K Unlock selected guests

Ctrl+O Open a plan

Ctrl+S Save the plan

Ctrl+U Unassign the selected guest(s)

Ctrl+Z Undo
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Ctrl++/Ctrl+- Zoom in/zoom out

Alt+Left / Alt+Right Select previous/next table

Alt+Up / Alt+Down Select previous/next guest

There is a full list of accelerators here.

Edit multiple guests

To change a property for multiple guests, select the guests, select Edit>Guest
Property from the main menu and then select the appropriate sub-menu.

Edit multiple guest properties video

Edit multiple tables

To change a property for multiple tables, select the tables (e.g. by dragging a
box around them in the floor plan), select Edit>Table Property from the main
menu and then select the appropriate sub-menu.

Auto seat assignment

You can select File>Auto Assign Seats as often as you like. Each time it will
start with the current seat assignments and try to improve them. The more you
run it, the better the result is likely to be. Change the settings in the Auto

assign tab of the Preferences window if you want it to run for more or less
time.

Check guest happiness

You can colour code guests in the Floor plan and Table plan panes by how
happy they are with where they are seated, based on their proximity settings.
Green=happy, Red=unhappy. This is a quick way to spot any potential issue you
need to address.

http://www.screencast.com/t/yqNwB3wy
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Dragging in the Floor Plan pane

If you left-click and drag you will drag out a selection rectangle. Everything
inside or touching the rectangle will be selected when you release.

If you right-click and drag on the background of the floor plan, you can scroll the
floor plan horizontally and vertically.

If you are zoomed in and drag a guest near to the edge of the floor plan, the
pane will scroll automatically.

You can add an image by dragging it straight onto the floor plan.

Use 'Near not next to' proximity for couples

Sometimes you want couples to sit on the same table, but not next to each

other. You can use Near not next to proximity for this. You can set this as

the default proximity for couples in the Preferences window.

Align tables
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Aligning tables and other items in the floor plan is much easier if you turn on
grid snap.

You can also select items and move them using the arrow keys. If grid snap is
on it will move them one grid spacing. If grid snap is not on, the item will be
moved 5 cm/2 inches (1 cm/0.4 inch if the Shift key is held down).

Remove/Hide empty seats

You can remove all the empty seats in a single operating using Edit>Remove
Empty Seats. Alternatively you can hide empty seats.

Change the order guests are displayed in a group

You can change the order in which guests are displayed within a group, for

example in the Table Chart , Guest Chart or Stationery pane, in the

Group tab of Guest Properties or Group properties windows:
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Sweetheart/cabaret tables

You can arrange seats around a circular table in a sweetheart/cabaret style
arrangement.
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Round ended tables

You can have tables that are round at one or both ends.
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Freeze the floor plan

If you want to avoid accidentally moving tables after you have set-up your floor
plan, you can freeze the floor plan.

Quick add guests

If you have a list of guest names, you can select Insert>Quick Add Guests...
and paste the names straight in. 
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Change columns during import

If you click the More button in the Import Data window you can add, delete,
split and join columns in the imported data.

Export a chart to Excel or Word

Click the  or  buttons at the top of the Guest chart, Table Chart or 
Report panes to export to Excel or Word (if installed) with one click.

Troubleshooting

The Troubleshooting report in the Report pane gives you a quick overview
of any potential issues in a textual form, e.g.:

· 'Next to' guest pairs not seated near to each other

· Guests without titles

· RSVP accepted guests not assigned to seats

· Guests with no meal assigned
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· Tables with empty seats

Troubleshooting report video

Export to web

Using File>Export... you can export a web version of your plan that can be
accessed by anyone with a web enabled device (e.g. a tablet). This can be very
useful for sharing a plan with a client or to allow staff to show guests to seats at
the event.

Export to web or tablet video

Show unassigned seats

You can highlight unassigned seats using the Tables drop-down list in the 
Floor plan pane.

http://www.screencast.com/t/giJslgIMV2ob
http://www.screencast.com/t/1GyQVEmy6M
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Toggle fullstops in titles

If you press Ctrl+. PerfectTablePlan will toggle a fullstop on the titles of all
guests. E.g. it will convert "Mr" to "Mr." and "Mr." to "Mr".

Change headings in charts and reports

You can change words in printouts (e.g. to a different language) using the
Terms button.
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Terms video

Use an electronic seating chart

Guests have a bad habit of changing their minds as soon as you have printed
your guest chart. You can avoid this by displaying your plan on a large VDU or
Plasma screen. You can even update it in real time.

VDU chart video

Run PerfectTablePlan from a USB drive

You can run PerfectTablePlan from a portable USB drive (memory stick).

Gesture support

If your device supports gestures, you can 'pinch' to zoom in the Floor Plan

and Table Plan panes.

Backup files

PerfectTablePlan automatically creates backup files for you. You can control how

often and where these files are created in the Backups tab of the 
Preferences window. You can list backup files by selecting File>Backups....

Note that this won't save you from a harddisk crash. So always backup your
plans to another device. You can even email them to yourself or a colleague.

How do I? help

At the end of the main menu there is a How do I? button. Click on this to get
context sensitive help.

Edit mode

You can easily edit individual guests in the Guests or Groups pane using
Edit mode. Remember to switch back to Drag and drop mode to drag and drop
guests to seats.

http://www.screencast.com/t/MnTFA50fR3e7
http://www.screencast.com/t/gTZCirs5v
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Drag and drop files

You can drag a plan file onto the Guests, Groups or Floor plan pane to
open it. Similarly you can drag an Excel or CSV file on to PerfectTablePlan to
import it.

Colour tables

You can colour tables individually in the Floor plan and Table plan panes
via the Table Properties window.

Coloured dots on stationery

PerfectTablePlan can add coloured dots to your place cards or other stationery
based on guest properties such as: gender, meal choice or custom field value.
This can be useful for conveying information to serving staff.
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Colour coded dots video

Importing a group column

You can control how PerfectTablePlan imports guests into groups by importing a
Group column.

Import your guest list video

Capitalise new guest names

http://www.screencast.com/t/JWm5m6Fmoej1
https://www.perfecttableplan.com/video/importv7.html
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You can automatically capitalise new  guest names by checking the
automatically capitalise new guest names check box in the Names tab of

the Preferences window. This can save time if you are typing lots of names.

Custom titles and suffixes

PerfectTablePlan is configured to recognise standard titles such as "Mr" and

"Mrs". You can customize the standard titles in the Titles tab of the 
Preferences window. These titles will then be available in the Titles drop-down
list in every plan. You can also associate a gender, age and VIP status with a
title to make importing more intelligent.

Similarly you can customize the list of suffixes in the Suffixes tab of the 
Preferences window.

Sort guests by rank

You can sort guests by the rank of their title or suffix (rather than in alphabetical
order). 

Export to PDF

Names can be hard to read from A4 or letter sized printouts. However you can
export to PDF and send the PDF to someone with a larger format printer. We list
a few companies that will print PDFs for you here.

Schematic pane

The Schematic pane can be a useful alternative to the Floor Plan pane
when you are dragging and dropping guests. You can also drag and drop tables

into a different order (e.g. to change the order they appear in the Table chart
pane).

Show proximity by group

The Proximity pane can be a bit unwieldy if you have large numbers of
guests. However you can view proximity one group at a time by setting the For
drop-down list to By group (to show a group at a time) or By group+ (to
show a group at a time, plus all the guests that members in that group have
non-neutral proximity to).

https://www.perfecttableplan.com/html/order_plan.html
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Editing the plan file directly

PerfectTablePlan plan files are stored in text files in XML format. If you are
feeling brave you can edit the file using a text editor. We recommend you make
a copy first though, as PerfectTablePlan won't be able to read it back in if it is
not a valid XML file.

Finding plan files

If you aren't sure where a plan file is saved, you can quickly search your
harddisk for it using File>Find... in PerfectTablePlan.

Table naming

PerfectTablePlan defaults to naming tables "Table 1", "Table 2" etc. But you can

change this in the New table name format field in the Naming tab of the 
Preferences window. Use {next_table_letter} to default to letters and

{next_table_num} to default to numbers.

Visualization colours

You can change the colours used to visualise meal choice, group etc.

Changing visualization colours video

Colour keys

You can display a colour key for visualisation colours.

http://www.screencast.com/t/MddBzk7Q0
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Use transparency as a colour

It can sometimes be useful to set transparent as a colour.

Estimate numbers

You can make a simple estimate of event numbers and costs in
PerfectTablePlan. Just select File>Numbers and Budget....

Open a plan read-only

You can File>Open a PerfectTablePlan plan file 'read-only' if you don't want to
change it. This means other people can edit it (and you will be notified of any
changes).

Replace text

Replace text in the text properties of guests, groups and tables using the 
Replace Text window. 

Transfer Preferences

You can quickly transfer your Preference window settings from one computer
to another using a .tpp file.
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· On the computer you want to copy preferences from, create a .tpp file by

clicking Export Preferences... in the Transfer tab of the Preferences
window.

· Copy the exported .tpp file to the recipient computer.

· On the recipient computer, click Import Preferences... in the Transfer tab

of the Preferences window and select the .tpp file to import.

Advanced and Professional editions

Use a drawing of the venue

If you have a scale drawing of the venue, you can use it in your floor plan.

scaled floor plan image image used as floor plan background with tables
added

Scaled venue images video

Use your own custom naming

http://www.screencast.com/t/JMiQZoXZa
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In the Floor Plan and Table Plan panes you can set the Display drop-
down list to Custom name... to set your own custom name format, including
HTML tags and custom fields.

Add a new custom field during import

If you want to import a custom field, you don't need to add the field first. Just

select <custom field> from the drop-down list in the Import data window.

Create a template file

If you are going to use the same floor plan and/or guest list for multiple events,
you can create a template file.

Personalised seating plans

You can easily print out or export to PDF table plans that are personalised to
show each guest their seat.

You are here maps video

Use custom seat numbers

You can set custom seat numbers.

Flexible seat numbering video

Professional edition only

Auto assign multiple seatings

If you have an event with multiple seatings (e.g. consecutive nights at a
business event) you can assign all the seatings in a single operation using
File>Auto Assign Multiple....

Networking event seating video

http://screencast.com/t/IEHE0RkpOrVM
http://www.screencast.com/t/Mzg1NTQ4Mzct
http://screencast.com/t/73Va8xNt
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Fast table renumbering/renaming

If you have a lot of tables to rename/renumber, you can do it quickly using the

Renumber/Rename tables window.

Fast table renumber video

Bulk edit proximity

You can change lots of proximities in one operation using the Bulk Edit
Proximity window.

Bulk edit proximity video

Set proximity by category

If you have categories of users you want to sit together or apart you can use
custom proximity.

Custom proximity video

Fast table layout

If you have lots of tables to position in a grid, you can do it quickly using the 
Table Layout window.

http://www.screencast.com/t/MTdhOWYzN
http://www.screencast.com/t/91mvOZ8WZ0
http://www.screencast.com/t/kDCh3c4oWuNo
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Create detailed reports

If you want to create detailed reports, e.g.: meals selected by table or the
special requirements by group, you can do this using the Detailed (summary)
and Detailed (guests) reports.

Detailed reports video

Print barcodes

You can print barcodes on stationery and use a barcode scanner to check-in
guests. Select File>Check-In Guests... to activate check-in.

Import seating and proximity

You can import seating and proximity data.

http://screencast.com/t/huJ6hcSbhq
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Import seating data video

Merge import

It is possible to merge changes in a guest list into your plan.

http://screencast.com/t/R6x41pIA3bWU
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6 Licensing

6.1 Licensing

In order to use this software fully you will need a valid licence key. Without a
licence key you can only save, export, print or scroll the VDU chart for plans
with 30 or fewer guests.

To buy a licence key go to www.perfecttableplan.com .

To fully activate the software select Licensing>Licence and enter the key into

the Licence window.

If you purchased the software electronically off the Internet, the key will have
been emailed to you.

To retrieve a licence you have previously purchased from
www.perfecttableplan.com select Licensing>Retrieve Key.

The same licence key will work on both Windows and Mac.

Note A standard licence entitles one named person to use this software on up to
5 computers. If you have more than one person using the software you should
purchase a licence key for each user. However, we allow to share your licence
key with 1 immediate family member, if you are planning the same event. 

You can also purchase an organizational licence.

Version 1-6 licence keys are not valid for version 7. You can upgrade to version

7 for a small fee.

You can also upgrade your edition, e.g. from PerfectTablePlan Home edition to
PerfectTablePlan Advanced edition.

6.2 Qt

PerfectTablePlan uses the Qt cross-platform framework under a commercial
licence.

Third party licences used by Qt are described here.

6.3 LibXL

PerfectTablePlan uses the LibXL Excel library under a commercial licence.

https://www.perfecttableplan.com/html/purchase.html
https://www.perfecttableplan.com/html/purchase.html
https://www.perfecttableplan.com/html/perfecttableplan_site_licences.html
https://www.perfecttableplan.com/html/upgrade.html
https://www.perfecttableplan.com/html/upgrade.html
https://www.perfecttableplan.com/html/upgrade_edition.html
https://doc.qt.io/qt-5/licenses-used-in-qt.html
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7 Support

7.1 Contact support

If you are having problems with the software please check if your question has
already been answered in this documentation or on the
www.perfecttableplan.com FAQ page. If you can't find an answer here or on the
web site then email us at support@perfecttableplan.com . We will reply as
quickly as we can.

7.2 Report a bug

We take every effort to deliver high quality software. However, the sheer
complexity of software and the number of platforms and configurations we have
to support means that we can't guarantee our software is completely bug free.
Please report any bugs you find to sales@perfecttableplan.com and we will
attempt to fix them. Please include:

· a description of the bug

· your operating system (e.g. Windows 11)

· the version of PerfectTablePlan (from the About window)

· a step-by-step description of how we can reproduce the problem

· a screen capture can often be helpful

The step-by-step description is particularly important - if we can't reproduce
your problem, then we probably won't be able to fix it.

To assist us in fixing bugs we have added email-based error reporting. When
PerfectTablePlan detects that something has gone horribly wrong it will try to
email a report to sales@perfecttableplan.com (with your permission). Please
send the email and add any relevant details.

7.3 Request an enhancement

We are always very interested to hear your suggestions on how the software can
be improved. Please email us at support@perfecttableplan.com .

https://www.perfecttableplan.com/html/faq.html
mailto:support@perfecttableplan.com
mailto:sales@perfecttableplan.com
https://www.perfecttableplan.com/html/creating_a_screen_capture.html
mailto:sales@perfecttableplan.com
mailto:support@perfecttableplan.com
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8 Updates

8.1 Updates

From time to time we release new versions of the software with new features
and/or bug fixes. Minor updates are available for no charge (e.g. v7.0.0 and
v7.1.1 will both work with a v7 licence key). Major updates require a licence key
upgrade (e.g. a v6 licence key will not work with version 7.0.0). If you
purchased a licence key close to a major upgrade you may get a free upgrade
licence key. See our licensing page for details of our upgrade policy.

To check which version of the software you are running look in the About
window.

To check if you are running the latest version select Help>Check for Updates.
This requires an Internet connection.

PerfectTablePlan will also check for software updates automatically. You can set

it to check for updates monthly, weekly or never, in the Preferences window
(the default is weekly). It will only advise the availability of updates, you still
have to download and install the update from a web page.

You can also subscribe to our email newsletter for update information.

8.2 Newsletter

If you subscribe to our newsletter you will receive occasional email newsletters telling
you when new releases of this software become available, and other useful
information. You can always unsubscribe at a later date and we won't sell your details
to anyone else.

https://www.perfecttableplan.com/html/licensing.html
https://www.perfecttableplan.com/html/register.html
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